Zabbix Documentation 4.4

2.23.04.04.2 (current)In development:4.4 (devel)Unsupported:1.82.02.43.23.4

User Tools

Site Tools

This translation is older than the original page and might be outdated. See what has changed.

Sidebar

ru:manual:appendix:compatibility

13 Совместимость версий

Поддерживаемые агенты

Zabbix агенты начиная с 1.4 версии совместимы с Zabbix 4.0. Однако, возможно вам потребуется пересмотреть конфигурацию старых агентов, так как некоторые параметры могли измениться, например, параметры связанные с журналированием по сравнению с версиями до 3.0.

Чтобы воспользоваться всеми преимуществами новых и улучшенных элементов данных, улучшенной производительности и уменьшенным использованием памяти, используйте последнюю версию агента 4.0.

Поддерживаемые Zabbix прокси

Zabbix 4.0.x сервер может работать только с Zabbix 4.0.x прокси. Zabbix 4.0.x прокси могут работать только с Zabbix 4.0.x сервером.

Известно, что имеется возможность запустить обновленный сервер с ещё не обновленными прокси, которые будут отправлять данные на новый сервер (хотя прокси и не смогут обновлять свою конфигурацию). Однако, такой подход не рекомендуется и не поддерживается Zabbix, его выбор исключительно на ваш страх и риск. Для получения более подробных сведений, смотрите процедуру обновления.

Поддержка XML файлов

XML файлы, экспортированные в версиях 1.8, 2.0, 2.2, 2.4, 3.0, 3.2 и 3.4 поддерживаются при импорте в версию Zabbix 4.0.

В XML формате Zabbix 1.8 при экспорте, зависимости триггеров сортируются только по названию. Если имеется несколько триггеров с одинаковым именем (например, имеющие разные важности и выражения), которые имеют заданную зависимость между собой, то их невозможно импортировать. Такие зависимости должны быть удалены вручную из файла XML и добавлены после импорта.