Zabbix Documentation 2.4

3.04.04.24.4 (current)| In development:5.0 (devel)| Unsupported:1.82.02.22.43.23.4Guidelines

User Tools

Site Tools


manual:appendix:compatibility

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

manual:appendix:compatibility [2014/09/25 14:42] (current)
sasha Page moved from 2.4:manual:appendix:compatibility to manual:appendix:compatibility
Line 1: Line 1:
 +==== 11 Version compatibility ====
  
 +=== Supported agents ===
 +
 +Older agents from Zabbix 1.x and previous versions of Zabbix 2.x can still be used with Zabbix 2.4. It does not require any configuration changes on agent side.
 +
 +However, to take full advantage of new and improved items, improved performance and reduced memory usage, use the latest 2.4 agent.
 +
 +=== Supported Zabbix proxies ===
 +
 +Only Zabbix 2.4 proxies may be used with Zabbix server. Zabbix 1.6, 1.8, 2.0 and 2.2 proxies are not supported with Zabbix 2.4 server.
 +
 +Zabbix 2.4 proxies may only be used with Zabbix 2.4 server. They will not work with 2.2 or older Zabbix server.
 +
 +=== Supported XML files ===
 +
 +XML files, exported with 1.8, 2.0 and 2.2 are supported for import in Zabbix 2.4.
 +
 +<note important>​In Zabbix 1.8 XML export format, trigger dependencies are stored by name only. If there are several triggers with the same name (for example, having different severities and expressions) that have a dependency defined between them, it is not possible to import them. Such dependencies must be manually removed from the XML file and re-added after import.</​note>​