Zabbix Documentation 4.0

3.04.05.0 (current)| In development:5.2 (devel)| Unsupported:1.82.02.22.43.23.44.24.4Guidelines

User Tools

Site Tools


ru:manual:installation:upgrade:packages:debian_ubuntu

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
ru:manual:installation:upgrade:packages:debian_ubuntu [2018/07/19 03:04]
dotneft
ru:manual:installation:upgrade:packages:debian_ubuntu [2019/12/17 03:09]
dotneft
Line 20: Line 20:
 |3.4.x |[[:​ru/​manual/​installation/​upgrade_notes_400|Для 4.0]]  |Библиотеки '​libpthread'​ и '​zlib'​ теперь обязательны;​\\ Поддержка протокола в виде простого текста убрана и заголовок обязателен;​\\ Zabbix агенты версий Pre-1.4 более не поддерживаются;​\\ Параметр Server в конфигурации пассивного прокси теперь обязателен ​ | |3.4.x |[[:​ru/​manual/​installation/​upgrade_notes_400|Для 4.0]]  |Библиотеки '​libpthread'​ и '​zlib'​ теперь обязательны;​\\ Поддержка протокола в виде простого текста убрана и заголовок обязателен;​\\ Zabbix агенты версий Pre-1.4 более не поддерживаются;​\\ Параметр Server в конфигурации пассивного прокси теперь обязателен ​ |
 |3.2.x |Также [[https://​www.zabbix.com/​documentation/​3.4/​ru/​manual/​installation/​upgrade_notes_340|для 3.4]]  |Поддержка SQLite в виде основной базы данных убрана для Zabbix сервера/​веб-интерфейса;​\\ Поддерживается Perl совместимые регулярные выражения (PCRE) вместо POSIX расширенных;​\\ Библиотеки '​libpcre'​ and '​libevent'​ обязательны для Zabbix сервера;​\\ Добавлены проверки кода выхода для пользовательских параметров,​ удаленных команд и элементов данных system.run[] без '​nowait'​ флага, а также для выполняемых скриптов Zabbix сервером;​\\ Zabbix Java gateway необходимо обновить для поддержки новых функций ​ | |3.2.x |Также [[https://​www.zabbix.com/​documentation/​3.4/​ru/​manual/​installation/​upgrade_notes_340|для 3.4]]  |Поддержка SQLite в виде основной базы данных убрана для Zabbix сервера/​веб-интерфейса;​\\ Поддерживается Perl совместимые регулярные выражения (PCRE) вместо POSIX расширенных;​\\ Библиотеки '​libpcre'​ and '​libevent'​ обязательны для Zabbix сервера;​\\ Добавлены проверки кода выхода для пользовательских параметров,​ удаленных команд и элементов данных system.run[] без '​nowait'​ флага, а также для выполняемых скриптов Zabbix сервером;​\\ Zabbix Java gateway необходимо обновить для поддержки новых функций ​ |
-|3.0.x |Также [[https://​www.zabbix.com/​documentation/​3.2/​ru/​manual/​installation/​upgrade_notes_320|для 3.2]]  |Обновление базы данныз может быть медленным,​ в зависимости от размеров таблиц истории ​ |+|3.0.x |Также [[https://​www.zabbix.com/​documentation/​3.2/​ru/​manual/​installation/​upgrade_notes_320|для 3.2]]  |Обновление базы данных может быть медленным,​ в зависимости от размеров таблиц истории ​ |
  
 Вы возможно захотите также проверить [[:​ru/​manual/​installation/​requirements|требования]] для 4.0. Вы возможно захотите также проверить [[:​ru/​manual/​installation/​requirements|требования]] для 4.0.
Line 66: Line 66:
  
 Для **Debian 9** выполните:​ Для **Debian 9** выполните:​
-  # wget https://​repo.zabbix.com/​zabbix/​3.5/​debian/​pool/​main/​z/​zabbix-release/​zabbix-release_3.5-1+stretch_all.deb +  # wget https://​repo.zabbix.com/​zabbix/​4.0/​debian/​pool/​main/​z/​zabbix-release/​zabbix-release_4.0-2+stretch_all.deb 
-  # dpkg -i zabbix-release_3.5-1+stretch_all.deb+  # dpkg -i zabbix-release_4.0-2+stretch_all.deb
  
 Для **Debian 8** выполните:​ Для **Debian 8** выполните:​
-  # wget https://​repo.zabbix.com/​zabbix/​3.5/​debian/​pool/​main/​z/​zabbix-release/​zabbix-release_3.5-1+jessie_all.deb +  # wget https://​repo.zabbix.com/​zabbix/​4.0/​debian/​pool/​main/​z/​zabbix-release/​zabbix-release_4.0-2+jessie_all.deb 
-  # dpkg -i zabbix-release_3.5-1+jessie_all.deb +  # dpkg -i zabbix-release_4.0-2+jessie_all.deb 
-   +
-Для **Debian 7** выполните:​ +
-  # wget https://​repo.zabbix.com/​zabbix/​3.5/​debian/​pool/​main/​z/​zabbix-release/​zabbix-release_3.5-1+wheezy_all.deb +
-  # dpkg -i zabbix-release_3.5-1+wheezy_all.deb +
-  ​+
 Для **Ubuntu 18.04** выполните:​ Для **Ubuntu 18.04** выполните:​
  
-  # wget https://​repo.zabbix.com/​zabbix/​3.5/​ubuntu/​pool/​main/​z/​zabbix-release/​zabbix-release_3.5-1+bionic_all.deb +  # wget https://​repo.zabbix.com/​zabbix/​4.0/​ubuntu/​pool/​main/​z/​zabbix-release/​zabbix-release_4.0-2+bionic_all.deb 
-  # dpkg -i zabbix-release_3.5-1+bionic_all.deb+  # dpkg -i zabbix-release_4.0-2+bionic_all.deb
  
 Для **Ubuntu 16.04** выполните:​ Для **Ubuntu 16.04** выполните:​
  
-  # wget https://​repo.zabbix.com/​zabbix/​3.5/​ubuntu/​pool/​main/​z/​zabbix-release/​zabbix-release_3.5-1+xenial_all.deb +  # wget https://​repo.zabbix.com/​zabbix/​4.0/​ubuntu/​pool/​main/​z/​zabbix-release/​zabbix-release_4.0-2+xenial_all.deb 
-  # dpkg -i zabbix-release_3.5-1+xenial_all.deb+  # dpkg -i zabbix-release_4.0-2+xenial_all.deb
  
 Для **Ubuntu 14.04** выполните:​ Для **Ubuntu 14.04** выполните:​
  
-  # wget https://​repo.zabbix.com/​zabbix/​3.5/​ubuntu/​pool/​main/​z/​zabbix-release/​zabbix-release_3.5-1+trusty_all.deb +  # wget https://​repo.zabbix.com/​zabbix/​4.0/​ubuntu/​pool/​main/​z/​zabbix-release/​zabbix-release_4.0-2+trusty_all.deb 
-  # dpkg -i zabbix-release_3.5-1+trusty_all.deb+  # dpkg -i zabbix-release_4.0-2+trusty_all.deb
  
 Обновите информацию о репозитории. Обновите информацию о репозитории.
Line 121: Line 117:
 === Обновление между минорными версиями === === Обновление между минорными версиями ===
  
-Имеется возможность обновления минорные версии 4.0.x (например,​ с 4.0.1 на 4.0.3). Процедура очень проста.+Имеется возможность обновления ​между ​минорными версиями 4.0.x (например,​ с 4.0.1 на 4.0.3). Процедура очень проста.
  
 Для минорного обновления Zabbix, пожалуйста,​ выполните:​ Для минорного обновления Zabbix, пожалуйста,​ выполните:​