Zabbix Documentation 5.0

3.04.04.4 (current)| In development:5.0 (devel)| Unsupported:1.82.02.22.43.23.44.2Guidelines

User Tools

Site Tools


Sidebar

manual:installation:install_from_packages:frontend_on_debian

7 Debian/Ubuntu frontend installation

Overview

Starting from version 5.0, Zabbix frontend requires PHP version 7.2 or later. Unfortunately, older versions of Debian & Ubuntu provide only PHP versions below 7.2.

Supported PHP versions by distribution

Distribution PHP Version
Debian 10 (buster) 7.3
Debian 9 (stretch) 7.0
Debian 8 (jessie) 5.6
Ubuntu 18.04 (bionic) 7.2
Ubuntu 16.04 (xenial) 7.0
Ubuntu 14.04 (trusty) 5.5
Raspbian 10 (buster) 7.3
Raspbian 8 (stretch) 7.0

On stretch, jessie, xenial and trusty distributions, PHP 7.2 dependency is not available, and therefore Zabbix frontend 5.0 or newer cannot be easily installed. Considering this, zabbix-frontend-php package has been replaced with zabbix-frontend-php-deprecated package on aforementioned distributions.
The main difference is absence of direct dependencies on any php or web-server packages. Thus, the user can (and must) provide these dependencies on their own. In other words, installing zabbix-frontend-php-deprecated package on its own will not give you a working frontend. A web server as well as PHP 7.2 with its modules have to be installed manually (use PPAs / build PHP from source). We don't endorse any particular method.

The official way of getting PHP 7.2 or later on older versions of Debian/Ubuntu is to upgrade to buster/bionic.

PHP modules required for Zabbix frontend are php-gd, php-bcmath, php-mbstring, php-xml, php-ldap and php-json.