Ad Widget

Collapse

Problème de communication

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problème de communication

    Bonjour, à toutes et tous,

    Je commence à découvrir le monde merveilleux de Zabbix.
    Toutefois, je me heurte à une problématique assez gênante concernant la communication de mon Serveur Zabbix avec un serveur proxy et un agent Windows.

    Tout d'abord, ma configuration est la suivante :
    • 1 Serveur Zabbix en version 4.4.5 avec une base Postgres le tout avec Docker sur un serveur VPS ;
    • 1 Serveur Zabbix Proxy en version 4.4.5 sur un Raspberry et Docker également ;
    • 1 agent Windows Zabbix sur un de mes ordinateurs ;

    Ma problématique est la suivante : mon agent Zabbix ne voit pas mon serveur proxy et mon serveur Zabbix principale ne voit pas mon serveur Proxy.
    Je traite les problèmes dans l'ordre, déjà l'agent et le serveur proxy.

    Dans les logs de l'agent, j'ai le message d'erreur suivant (adresse IP remplacer par des X) :

    7024:20200213:100814.913 active check configuration update from [X.X.X.X:10051] started to fail (cannot connect to [[X.X.X.X]:10051]: Connection refused.)
    Pour faire suite à mes recherches, j'ai pensé à un problème de pare-feu, mais le port est bien en écoute sur mon serveur proxy :

    Click image for larger version

Name:	2020-02-13_12h20_33.png
Views:	69
Size:	5.1 KB
ID:	395497

    Le fait que la commande NETSTAT affiche une réponse en IPv6 est normal, d'après les lectures que j'ai faites par rapport à Docker.

    J'ai exploré différents forums, documentation Zabbix, etc.
    Mais là je sèche, je ne vois ce qui bloque.

    Je m'occuperais du problème de communication entre le serveur proxy et le serveur Zabbix après résolution de celui-ci.

    Je vous remercie par avance de vos retours et de votre aide.

    #2
    Bonjour,

    Pour s'assurer de ce qu'il se passe en réel, je mettrais une sonde de type wireshark au milieu du lien server-proxy, histoire de constater 'dans le monde réel' de ce qu'il se passe... soit la sonde montre communication entre les machines et c'est un problème de conf entre les 2, soit rien ne transite et c'est un problème d'acheminement réseau.
    Comme c'est monté en container, il peut y avoir une autorisation d'oubliée quelque part?

    cordialement

    Comment


      #3
      Hello Cyber,

      pourrais-tu nous donner la configuration de ton agent zabbix ?
      Et que donne un telnet depuis l'agent zabbix vers l'IP du proxy sur le port 10051.

      Steve
      "izi-it.io / ZABBIX Certified Trainer / ZABBIX French Evangelist / Rejoignez le ZABBIX Discord francophone https://discordapp.com/invite/hvauXEQ"

      Comment


        #4
        Bonjour,

        Merci à vous deux pour les retours.

        J'ai eu d'autres soucis sur le VPS depuis.
        J'ai donc refait une installation au propre et sans Docker.
        Je n'ai pas encore eu le temps de refaire le serveur proxy sans Docker pour refaire des tests.

        Je vais donc faire ceci et si besoin je reviendrais vers vous.

        Dans tous les cas, merci !

        Comment

        Announcement

        Collapse
        No announcement yet.
        Working...
        X