<?xml version="1.0" encoding="UTF-8"?>
<rss version="2.0" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:content="http://purl.org/rss/1.0/modules/content/">
	<channel>
		<title>ZABBIX Forums - Zabbix Feedback for alpha and beta versions</title>
		<link>https://www.zabbix.com/forum/</link>
		<description>Use this forum to discuss everything related to alpha and beta versions of Zabbix</description>
		<language>en</language>
		<lastBuildDate>Sun, 11 Oct 2026 12:14:31 GMT</lastBuildDate>
		<generator>vBulletin</generator>
		<ttl>60</ttl>
		<image>
			<url>https://assets.zabbix.com/img/logo.png</url>
			<title>ZABBIX Forums - Zabbix Feedback for alpha and beta versions</title>
			<link>https://www.zabbix.com/forum/</link>
		</image>
		<item>
			<title>Zabbix Agent2 with native Ceph Plugin does not yet support aes256k</title>
			<link>https://www.zabbix.com/forum/zabbix-feedback-for-alpha-and-beta-versions/516800-zabbix-agent2-with-native-ceph-plugin-does-not-yet-support-aes256k</link>
			<pubDate>Thu, 17 Sep 2026 03:13:12 GMT</pubDate>
			<description><![CDATA[Dear Zabbix team, 
 
the new native ceph client in the beta version of 8 does not yet support the new CephX aes256k authentication/keys. 
When rotating the key of client.zabbix, the client immediately returns error -22: 
 
 
 
Workaround is to rotate back to default &quot;aes&quot; but this is strongly...]]></description>
			<content:encoded><![CDATA[Dear Zabbix team,<br />
<br />
the new native ceph client in the beta version of 8 does not yet support the new CephX aes256k authentication/keys.<br />
When rotating the key of client.zabbix, the client immediately returns error -22:<br />
<br />
<div class="bbcode_container">
	<div class="bbcode_quote">
		<div class="quote_container">
			
			<div class="bbcode_quote_container b-icon-fa b-icon-fa--24 fa-solid fa-quote-left"></div>
			
				2026/09/17 04:54:24.226185 failed to execute direct exporter task for key 'ceph.df.details[[10.1.xx.xx:3300 zabbix AgAFVqtqecmLKiAAhU9ivFNRzsgNknYnSW6WMrre6kCOJJ5Tgo HJAchSm5Y= native]]' error: 'Failed to get connection: cannot get connection: cannot create connection 10.1.xx.xx:3300: failed to connect: rados: ret=-22, Invalid argument.'
			
		</div>
	</div>
</div>Workaround is to rotate back to default &quot;aes&quot; but this is strongly discouraged since it blocks cluster upgrade (old variant has security flaws and upgrade to aes256k is mandatory),<br />
<br />
Following packages are installed on the proxmox host:<br />
<br />
<div class="bbcode_container">
	<div class="bbcode_quote">
		<div class="quote_container">
			
			<div class="bbcode_quote_container b-icon-fa b-icon-fa--24 fa-solid fa-quote-left"></div>
			
				ii zabbix-agent2 2:8.0.0~beta2-1+debian13 amd64 Zabbix network monitoring solution - agent<br />
ii zabbix-agent2-plugin-ceph 1:8.0.0~beta2-1+debian13 amd64 Zabbix Agent2 plugin for monitoring MongoDB installations<br />
ii zabbix-release 2:8.0-0.3+debian13 all Zabbix official repository configuration<br />
​
			
		</div>
	</div>
</div>Maybe the go client can't yet process the new key format?<br />
<br />
Best regards,<br />
Bernhard]]></content:encoded>
			<category domain="https://www.zabbix.com/forum/zabbix-feedback-for-alpha-and-beta-versions">Zabbix Feedback for alpha and beta versions</category>
			<dc:creator>broth-itk</dc:creator>
			<guid isPermaLink="true">https://www.zabbix.com/forum/zabbix-feedback-for-alpha-and-beta-versions/516800-zabbix-agent2-with-native-ceph-plugin-does-not-yet-support-aes256k</guid>
		</item>
	</channel>
</rss>
