Zabbix works fine with PHP7, in fact I'm using it with PHP7.2. What version of Zabbix were you trying to install? I'd suggest using either Zabbix 3.0 or Zabbix 4.0 if you need LTS. Otherwise Zabbix 3.4 will work with PHP7 as well.