View Single Post
  #1  
Old 23-02-2010, 10:55
QwErTy_LoGiC QwErTy_LoGiC is offline
Member
 
Join Date: Feb 2010
Location: Québec, Canada
Posts: 64
Question Zabbix 1.8.1 - Discovery SNMPv2

Hello all,

I am currently trying to discover a network of Cisco switches using the auto-discovery feature in Zabbix 1.8.1 but without success. I have tried the ICMP discovery and that works, it finds all the devices in a given network.

But SNMPv2 returns absolutely nothing. Just to be sure, here is the /tmp/zabbix-server.log output when I start the server:

Code:
21672:20100223:071858.020 Starting zabbix_server. Zabbix 1.8.1 (revision 9702).
 21672:20100223:071858.020 **** Enabled features ****
 21672:20100223:071858.020 SNMP monitoring:       YES
 21672:20100223:071858.020 IPMI monitoring:       YES
 21672:20100223:071858.020 WEB monitoring:        YES
 21672:20100223:071858.020 Jabber notifications:  YES
 21672:20100223:071858.020 ODBC:                   NO
 21672:20100223:071858.020 SSH2 support:           NO
 21672:20100223:071858.020 IPv6 support:           NO
 21672:20100223:071858.020 **************************
 21673:20100223:071858.028 server #1 started [DB Cache]
 21682:20100223:071858.030 server #10 started [Trapper]
 21683:20100223:071858.031 server #11 started [Trapper]
 21684:20100223:071858.031 server #12 started [ICMP pinger]
 21685:20100223:071858.031 server #13 started [Alerter]
 21686:20100223:071858.031 server #14 started [Housekeeper]
 21686:20100223:071858.031 Executing housekeeper
 21687:20100223:071858.032 server #15 started [Timer]
 21689:20100223:071858.032 server #17 started [Node watcher. Node ID:0]
 21691:20100223:071858.033 server #18 started [HTTP Poller]
 21672:20100223:071858.033 server #0 started [Watchdog]
 21680:20100223:071858.055 server #8 started [Trapper]
 21674:20100223:071858.057 server #2 started [Poller. SNMP:YES]
 21676:20100223:071858.057 server #4 started [Poller. SNMP:YES]
 21675:20100223:071858.057 server #3 started [Poller. SNMP:YES]
 21677:20100223:071858.058 server #5 started [Poller. SNMP:YES]
 21679:20100223:071858.058 server #7 started [Trapper]
 21681:20100223:071858.058 server #9 started [Trapper]
 21688:20100223:071858.062 server #16 started [Poller for unreachable hosts. SNMP:YES]
 21695:20100223:071858.062 server #21 started [Escalator]
 21692:20100223:071858.062 server #19 started [Discoverer. SNMP:YES]
 21694:20100223:071858.062 server #20 started [DB Syncer]
 21678:20100223:071858.087 server #6 started [Poller. SNMP:YES]
 21686:20100223:071900.552 Deleted 0 records from history and trends
And here is the SNMPv2 discovery configuration:

IP Address range: 172.16.0.1-255
Delay: 600 (for testing purposes)
Type: SNMPv2 agent
Port: 161
Community: MyCommunity
OID: .1.3.6.1.2.1.1.2.0

I have tested my parameters using the snmpget command successfully. However, unlike the ICMP discovery, absolutely nothing happens in the Monitoring>Discovery screen and nothing appears in the server log.

What am I doing wrong?

Thanks for any help!
Reply With Quote