View Single Post
  #1  
Old 11-12-2008, 23:27
zibbax zibbax is offline
Junior Member
 
Join Date: Nov 2008
Posts: 11
Default SNMP Timeout errors

I have configured an SNMP item to check a cisco switch. The data does not populate, and it gives the error that it times out connecting to the host. I can snmpwalk or snmpget this host with this FQDN from the zabbix server without issue.

15575:20081211:151214 In get_value(key:.1.3.6.1.4.1.9.1.896)
15575:20081211:151214 In get_value_snmp(key:.1.3.6.1.4.1.9.1.896, oid:.1.3.6.1.2.1.1.2.0)
15575:20081211:151214 Standard processing
15575:20081211:151214 In snmp_normalize(oid:.1.3.6.1.2.1.1.2.0)
15575:20081211:151214 End of snmp_normalize(result:.1.3.6.1.2.1.1.2.0)
15575:20081211:151214 In get_snmp(oid:.1.3.6.1.2.1.1.2.0)
15575:20081211:151214 SNMP [mycom@myswitch.domain.com:161:161]
15575:20081211:151214 OID [.1.3.6.1.2.1.1.2.0]
15575:20081211:151214 In get_value_SNMP() 0.2
15575:20081211:151214 In get_value_SNMP() 0.3
... snip ...
15575:20081211:151220 In get_value_SNMP() 0.4
15575:20081211:151220 In get_value_SNMP() 1
15575:20081211:151220 Timeout while connecting to [myswitch.gxt.com:161]

Output from snmpwalk

]# snmpwalk -v2c -On -c mycom myswitch.domain.com system
.1.3.6.1.2.1.1.1.0 = STRING: Cisco IOS Software, s72033_rp Software (s72033_rp-IPSERVICESK9_WAN-VM), Version 12.2(33)SXH2a, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2008 by Cisco Systems, Inc.
Compiled Fri 25-Apr-08 20:02 by pro
.1.3.6.1.2.1.1.2.0 = OID: .1.3.6.1.4.1.9.1.896
.1.3.6.1.2.1.1.3.0 = Timeticks: (925885317) 107 days, 3:54:13.17


The configuration of my Item

Description: SNMP Test
Type: (tried both SNMPv1 and SNMPv2 agent)
SNMP community: mycom
SNMP OID: .1.3.6.1.2.1.1.2.0
SNMP port: 161
Key: .1.3.6.1.4.1.9.1.896
Type of information: (tried numeric, text, and character)
Status: Active


Let me know if you need any more information.
Reply With Quote