ZABBIX Forums  
  #1  
Old 04-05-2012, 22:27
gopher_49 gopher_49 is offline
Junior Member
 
Join Date: Apr 2012
Posts: 24
Default active windows agents

I have a remote windows agent in active mode reporting to my server through the Internet via the default agent port. The CPU trigger / item is working but the free swap space and free disk space isn't not reporting any data. Also, the free memory items are reading information but it is not correct. The total and free memory amount is incorrect? I tried setting the agent port to 0 on the host config on the server. I also tried 10051. It seems to only receive any data when set to 10050 but Im missing the data mentioned above and most of the data I receive is incorrect. What could be wrong? I also deployed to another monitored server with the same config and received the same results.

Last edited by gopher_49; 07-05-2012 at 18:01. Reason: Issues changed
Reply With Quote
  #2  
Old 07-05-2012, 19:15
gopher_49 gopher_49 is offline
Junior Member
 
Join Date: Apr 2012
Posts: 24
Default

I had to open the SuSE firewall via the below commands?! Why in the world a firewall is enabled on these needed ports by default I don't know.. But.. I got it working now.

6.4 Firewall
By default, only two ports are open - 22 (SSH) and 80 (HTTP). To open additional ports - for example, Zabbix server and agent ports - modify iptables rules with SuSEfirewall2 utility:

SuSEfirewall2 open EXT TCP zabbix-trapper zabbix-agentThen reload the firewall rules:

SuSEfirewall2 stop
SuSEfirewall2 start
Reply With Quote
  #3  
Old 15-05-2012, 01:29
gopher_49 gopher_49 is offline
Junior Member
 
Join Date: Apr 2012
Posts: 24
Default

agents not reporting after changing public NAT translation...

I changed the public to private NAT translation and now my active/remote agents are not reporting back to me... I ran the firewall config syntax posted earlier in this post which fixed it before but now it seems to still have the ports close. Keep in mind that my private IP did not change. Only the public IP that I'm NAT'ing from did.. What can I try? I turned off the firewall and that didn't help... Port 80 is open but 10050-10051 is still closed... I tripled checked my NAT rules and still no luck. Any suggestions?
Reply With Quote
  #4  
Old 15-05-2012, 03:58
gopher_49 gopher_49 is offline
Junior Member
 
Join Date: Apr 2012
Posts: 24
Default

oops... It ended up being my ISP filtering ports... They filter ports when handing off even public IP's.. We requested this some time ago and I forgot.. Anyway.. Everything works just fine.. The firewall syntax below allows active agents to send data to the Zabbix server..

6.4 Firewall

By default, only two ports are open - 22 (SSH) and 80 (HTTP). To open additional ports - for example, Zabbix server and agent ports - modify iptables rules with SuSEfirewall2 utility:

SuSEfirewall2 open EXT TCP zabbix-trapper zabbix-agent
Then reload the firewall rules:

SuSEfirewall2 stop
SuSEfirewall2 start
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 18:58.