ZABBIX Forums  

Go Back   ZABBIX Forums > Zabbix Discussions and Feedback > Zabbix Cookbook

Reply
 
Thread Tools Display Modes
  #11  
Old 05-03-2014, 19:11
mrafi mrafi is offline
Junior Member
 
Join Date: Feb 2014
Posts: 10
Default Item is being not supported in 2.0.9, any help ?

Hi ericgearhart,

I have followed exactly what you have mentioned above, every things look good on the zabbix server console but when I set up in the GUI, item doesn't get any value and become unsupported, as per zabbix server logs I am getting the following...

4443:20140304:161527.994 item [ASA:query_asa_lan2lan.pl[public ASA get RX x.x.x.x]] became not supported: Received value [usage:./query_lan2lan_cisco.pl community host {ASA,CONCENTRATOR} index./query_lan2lan_cisco.pl community host {A

Where x.x.x.x is a public ip of my peer ASA.

Please let me know if you or anyone else can help me out....

Thanks
Reply With Quote
  #12  
Old 05-03-2014, 19:12
mrafi mrafi is offline
Junior Member
 
Join Date: Feb 2014
Posts: 10
Default

Quote:
Originally Posted by ericgearhart View Post
If you're having problems getting this setup you should first make sure the script is working OK.

Run the script by hand and make sure it returns your tunnels first:

Code:
perl query_asa_lan2lan.pl <YourASA> <YourSNMP string> index
should return a list of IPsec tunnels you have established on your ASA/VPN concentrator

Here's an example:

Code:
perl query_asa_lan2lan.pl 192.168.1.1 my_snmp_string ASA index


Hi ericgearhart,

I have followed exactly what you have mentioned above, every things look good on the zabbix server console but when I set up in the GUI, item doesn't get any value and become unsupported, as per zabbix server logs I am getting the following...

4443:20140304:161527.994 item [ASA:query_asa_lan2lan.pl[public ASA get RX x.x.x.x]] became not supported: Received value [usage:./query_lan2lan_cisco.pl community host {ASA,CONCENTRATOR} index./query_lan2lan_cisco.pl community host {A

Where x.x.x.x is a public ip of my peer ASA.

Please let me know if you or anyone else can help me out....

Thanks
Reply With Quote
  #13  
Old 05-03-2014, 19:37
darwinaloot darwinaloot is offline
Junior Member
 
Join Date: Jan 2014
Posts: 4
Default Try this

Hi,

Try this format on Key

query_asa_lan2lan_cisco.pl["{$SNMP_COMMUNITY}","<CISCOPIX IP HERE>","ASA","get","RX","<YOUR GATEWAY IP HERE>"]
Reply With Quote
  #14  
Old 06-03-2014, 13:01
mrafi mrafi is offline
Junior Member
 
Join Date: Feb 2014
Posts: 10
Default

Quote:
Originally Posted by darwinaloot View Post
Hi,

Try this format on Key

query_asa_lan2lan_cisco.pl["{$SNMP_COMMUNITY}","<CISCOPIX IP HERE>","ASA","get","RX","<YOUR GATEWAY IP HERE>"]
Many thanks for your reply, I tried the above command but no luck, same error log...any other thoughts ? because I have tried many combinations for the key but nothing made any difference...
Reply With Quote
  #15  
Old 06-03-2014, 13:12
mrafi mrafi is offline
Junior Member
 
Join Date: Feb 2014
Posts: 10
Default update

Quote:
Originally Posted by mrafi View Post
Many thanks for your reply, I tried the above command but no luck, same error log...any other thoughts ? because I have tried many combinations for the key but nothing made any difference...


Sorry dude, i exactly copied you Key but i realized now your script name has different name, corrected the name and now I am having below error.

became not supported: Received value [] is not suitable for value type [Numeric (unsigned)] and data type [Decimal]
Reply With Quote
  #16  
Old 06-03-2014, 13:35
mrafi mrafi is offline
Junior Member
 
Join Date: Feb 2014
Posts: 10
Smile Final Update hopefully

Quote:
Originally Posted by mrafi View Post
Sorry dude, i exactly copied you Key but i realized now your script name has different name, corrected the name and now I am having below error.

became not supported: Received value [] is not suitable for value type [Numeric (unsigned)] and data type [Decimal]
apologies for too many replies, as I have been trying different thing but this below key worked for me.

query_asa_lan2lan.pl["<CISCOPIX IP HERE>","{$SNMP_COMMUNITY}","ASA","get","RX","<YOUR GATEWAY IP HERE>"]

it might be because when we call script in the console we mention IP first and then community string and rest is as it is...anyway I get some value, dont know whether they are correct or not and also need to figure it out why I am not getting the graph.

Thanks for your help dude....darwinaloot
Reply With Quote
  #17  
Old 06-03-2014, 13:53
darwinaloot darwinaloot is offline
Junior Member
 
Join Date: Jan 2014
Posts: 4
Default Update

Yeah.. no problem.. do you have the updated query_asa_lan2lan_cisco.pl script?
Reply With Quote
  #18  
Old 06-03-2014, 13:54
mrafi mrafi is offline
Junior Member
 
Join Date: Feb 2014
Posts: 10
Default

Quote:
Originally Posted by darwinaloot View Post
Yeah.. no problem.. do you have the updated query_asa_lan2lan_cisco.pl script?
No dude, I have used exactly the same script, not the final one, that dint work for me...do you have updated one ?
Reply With Quote
  #19  
Old 06-03-2014, 14:14
darwinaloot darwinaloot is offline
Junior Member
 
Join Date: Jan 2014
Posts: 4
Default Update

Quote:
Originally Posted by mrafi View Post
No dude, I have used exactly the same script, not the final one, that dint work for me...do you have updated one ?
Yes If I remember it correctly im using the updated script... I uploaded the script so you could also check..

query_asa_lan2lan_cisco.txt
Reply With Quote
  #20  
Old 06-03-2014, 14:17
mrafi mrafi is offline
Junior Member
 
Join Date: Feb 2014
Posts: 10
Default

Quote:
Originally Posted by darwinaloot View Post
Yes If I remember it correctly im using the updated script... I uploaded the script so you could also check..

Attachment 6737
I will try your script as well, but if it is same as the expouser one then it will not work for me because I tried that before...
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 17:52.