ZABBIX Forums  

Go Back   ZABBIX Forums > Zabbix in Your Language > Em Português y En Español

Reply
 
Thread Tools Display Modes
  #1  
Old 01-04-2010, 12:38
G3orG3 G3orG3 is offline
Junior Member
 
Join Date: Mar 2010
Posts: 10
Exclamation Ajuda!após instalação user zabbix não conecta no Banco Mysql.

Olá vão bem rapaziada? eu não rsrsrsr
A encrenca é a seguinte fiz a instalação do Zabbix numa boa (+/- ralei rsrs),consigo acessar a interface web e tudo mas na hora em que vou verificar o status do serviço em REPORTS >Availability report >Status of Zabbix eu vejo em Parameter "Zabbix server is running > Value NO" no meu log consta acesso negado para o usuário Zabbix,mas acesso o Mysql normal com esse usuario, procurei em diversos foruns e não tive resposta gostaria de que se alguem pudesse dar essa força pq ja fazem 2 semanas que estou em cima disso e não ta rolando...info.george@gmail.com

Desde ja agradeço o espaço disponibilizado para nosso crescimento obrigado! [IMG]<a href="http://www.flickr.com/photos/48929272@N04/4481467226/" title="erroZabbix1 por G30G3FB, no Flickr"><img src="http://farm3.static.flickr.com/2751/4481467226_c9d7a41556.jpg" width="500" height="163" alt="erroZabbix1" /></a>[/IMG]
Reply With Quote
  #2  
Old 01-04-2010, 13:04
harmonica harmonica is offline
Senior Member
 
Join Date: Jan 2009
Location: Portugal, Lisbon
Posts: 220
Send a message via MSN to harmonica
Default

Olá,

Trata-se de permissões.
Deste as permissões correctas e definiste o Zabbix para iniciar no boot da máquina?
Reply With Quote
  #3  
Old 01-04-2010, 18:46
G3orG3 G3orG3 is offline
Junior Member
 
Join Date: Mar 2010
Posts: 10
Default

Quote:
Originally Posted by jose_lourdes View Post
Olá,

Trata-se de permissões.
Deste as permissões correctas e definiste o Zabbix para iniciar no boot da máquina?
acredito fielmente que sim ficou desse jeito olha:

sudo chmod 755 /etc/init.d/zabbix-server

sudo update-rc.d zabbix-server defaults

sudo chmod 755 /etc/init.d/zabbix-agent

sudo update-rc.d zabbix-agent defaults

Qualquer engano por favor me fale muito obrigado a atenção
Reply With Quote
  #4  
Old 01-04-2010, 22:51
G3orG3 G3orG3 is offline
Junior Member
 
Join Date: Mar 2010
Posts: 10
Unhappy Ta complicado!

Ja verifiquei o serviço e ele sobe sempre que eu ligo a maquina.
Com o usuário Zabbix na maquina local acesso normal o mysql com os devidos parametros "mysql -u zabbix -p" na sequencia entro com a senha e ok ou seja o usuário esta com devido acesso,certo?
passei o dia de hoje correndo atras disso e nada...
Outra duvida qual é a porta padrão de acesso do DB? em todos os tutoriais eu vi como "0" é isso mesmo ? confesso não ser nenhum ninja no assunto Mysql mas todas as configuraçoes que me foram apresentadas de mysql para o Zabbix estão idens ok.Onde sera que estou pecando !!!! meu gerente esta na bota pq hoje nós não temos um monitoramento decente na empresa e eu conseguindo essa proeza aqui poderia me dar um upgrade no cargo pois não aguento mais o suporte local 5srsrsr...outra coisa hoje ja nem sei mais pra onde ir ? sera que devo deixar tudo sem senha ? o user root o zabbix pra poder acessar o banco ? to aqui batendo cabeça ...mas to com fé (é o que me restou...)
Reply With Quote
  #5  
Old 05-04-2010, 15:43
zabbix_zen zabbix_zen is offline
Senior Member
 
Join Date: Jul 2009
Location: Portugal
Posts: 426
Default

Olá George.

Suspeito que seja falha na configuração do zabbix_server.conf

Tem os campos
DBName=
DBUser=
DBPassword=

configurados de acordo com os dados introduzidos ao acessar o mysql -u zabbix -p?

Quote:
qual é a porta padrão de acesso do DB?
??
Está acessando pelo porto ou pelo socket?
O zabbix_server.conf padrão vem com
DBPort=3306 (caso de ser usado porto)
e
ao configurar,
DBHost=localhost (o socket é automaticamente usado para MySQL)

apenas tendo de ser garantido o caminho absoluto para onde o socket é aberto em,
DBSocket=

Quote:
o user root o zabbix pra poder acessar o banco ?
Use evidentemente um user BD isolado do de root, um por exemplo chamado zabbix
com password que outra pessoa não adivinhe facilmente.

Last edited by zabbix_zen; 05-04-2010 at 15:48.
Reply With Quote
  #6  
Old 05-04-2010, 20:01
G3orG3 G3orG3 is offline
Junior Member
 
Join Date: Mar 2010
Posts: 10
Default Vamos la avanti! na Luta rsrsrs

Então pessoal legal a força de todos envolvidos até o momento so tenho a agradecer...
ainda não resolvio problema....
Os arquivos informados onde devo colocar DB,USER,PASSWORD estão ok (meu zabbix_server.conf o agentd tambem com o numero IP) usei esse e mais alguns tutoriais da web para instalar até onde cheguei
http://wendelneves.wordpress.com/2009/06/17/instalando-o-zabbix-no-ubuntu/#comment-16.
Consigo conectar ao banco normal pelo usuário criado (no caso o zabbix) usando os paramentros do mysql -u zabbix -p senha.... conecto no phpmyadmin normal com o user zabbix...o mesmo user tem "grant all" de privilegios mas na hora de ver o serviço acessando o console web admin>zabbix vou em relatorios status do serviço > Zabbix rodadando > valor não. ainda continua...obs: acesso interface web normal,Não estou vendo mais meus arquivos de log em tmp/zabbix_server.log (essa linha não esta comentada no arquivo Zabbix_server.conf) continuo em cima qualquer novidade até ja...
Attached Images
 
Attached Files
File Type: txt zabbix_server.txt (3.7 KB, 140 views)
Reply With Quote
  #7  
Old 05-04-2010, 21:12
exkg exkg is offline
Senior Member
Zabbix Certified Specialist
 
Join Date: Mar 2007
Location: Porto Alegre - Rio Grande do Sul - Brasil
Posts: 696
Send a message via MSN to exkg Send a message via Skype™ to exkg
Default

Oi,

Nos teus testes tentou acessar o banco com outro usuario (root) e senha ?
Verificou as credenciais do usuario zabbix ? Via cliente do mysql eh possivel acessar o banco do zabbix com as mesmas credencias utilizadas na interface ?


[]s,
Luciano
__________________
--
Luciano Alves
www.unirede.net
Twitter|Facebook|Blog|Youtube
Porto Alegre - RS - Brasil
Reply With Quote
  #8  
Old 06-04-2010, 09:45
zabbix_zen zabbix_zen is offline
Senior Member
 
Join Date: Jul 2009
Location: Portugal
Posts: 426
Default

Quote:
Não estou vendo mais meus arquivos de log em tmp/zabbix_server.log
Como não?

Para despiste de problemas com o Server é fundamental a informação que aí aparece.

Também é fundamental que todos os caminhos dos files existam e tenham as permissões de SO correctas.

Ou seja,
PidFile=/var/tmp/zabbix_server.pid
LogFile=/tmp/zabbix_server.log
FpingLocation=/usr/sbin/fping (não esquecer de instalar fping e apontar para o seu binário)
TmpDir=/tmp
DBSocket=/tmp/mysql.sock (sempre está usando DBSocket?? verifique se essa path está correcta)
Reply With Quote
  #9  
Old 07-04-2010, 16:06
G3orG3 G3orG3 is offline
Junior Member
 
Join Date: Mar 2010
Posts: 10
Default Segue duvidas...

Quote:
Originally Posted by zabbix_zen View Post
Como não?

Para despiste de problemas com o Server é fundamental a informação que aí aparece.

Também é fundamental que todos os caminhos dos files existam e tenham as permissões de SO correctas.

Ou seja,
PidFile=/var/tmp/zabbix_server.pid ----> esse esta igual ao meu! ok.
LogFile=/tmp/zabbix_server.log ---> não sei porque mas não encontro mais esse arquivo nesse diretorio e em mais nenhum outro...o caminho esta idem...
FpingLocation=/usr/sbin/fping (não esquecer de instalar fping e apontar para o seu binário) --> esta instalado porem esta em /usr/bin/fping (onde esta o executavel)
TmpDir=/tmp ---> tambem ok
DBSocket=/tmp/mysql.sock (sempre está usando DBSocket?? verifique se essa path está correcta)
estava comentado pois apontei somente via porta(padrao 3306).É necessario utilizar esse mysql.sock?Apontei para o caminho dele no meu caso /var/run/mysqld/mysqld.sock,para fazer um teste mas nada mudou no momento deixei ele comentado novamente, vou colar aqui o log que existiu somente uma vez no diretorio informado....

6040:20100331:130649 [Z3001] Connection to database 'zabbix' failed: [1045] Access denied for user 'zabbix'@'localhost' (using password: YES)
6356:20100331:152908 Starting zabbix_server. ZABBIX 1.6.5 (revision 7442).
6356:20100331:152908 **** Enabled features ****
6356:20100331:152908 SNMP monitoring: YES
6356:20100331:152908 WEB monitoring: YES
6356:20100331:152908 Jabber notifications: NO
6356:20100331:152908 ODBC: NO
6356:20100331:152908 IPv6 support: NO
6356:20100331:152908 **************************
6356:20100331:152908 [Z3001] Connection to database 'zabbix' failed: [1045] Access denied for user 'zabbix'@'localhost' (using password: YES)

é isso muito obrigado por enquanto pessoal, ta dificil mesmo pra mim essa responsa não sei mais quais os rumos devo seguir aceito sugestões !
Reply With Quote
  #10  
Old 07-04-2010, 16:29
zabbix_zen zabbix_zen is offline
Senior Member
 
Join Date: Jul 2009
Location: Portugal
Posts: 426
Default

Calma....

De certeza que adicionou os grants necessários à BD zabbix??

Algo do género, (dentro da consola mysql)
Quote:
GRANT ALL PRIVILEGES ON zabbixdb.* to zabbixuser@localhost identified by 'zabbixpasswd';
Confirme usando,
Quote:
show grants for 'zabbixuser'@'localhost';
Recomendo vivamente parar um par de dias para leitura de tutoriais Mysql.
Até porque com o tempo vai ter problemas de performance e vai ter que tunar o /etc/my.cnf
Reply With Quote
Reply

Tags
deny, user, zabbix access

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 21:32.