ZABBIX Forums  

Go Back   ZABBIX Forums > Zabbix in Your Language > Em Português y En Español

Reply
 
Thread Tools Display Modes
  #11  
Old 07-04-2010, 17:11
G3orG3 G3orG3 is offline
Junior Member
 
Join Date: Mar 2010
Posts: 10
Question Respostas:

Quote:
Originally Posted by exkg View Post
Oi,

Nos teus testes tentou acessar o banco com outro usuario (root) e senha ?
Verificou as credenciais do usuario zabbix ? Via cliente do mysql eh possivel acessar o banco do zabbix com as mesmas credencias utilizadas na interface ?


[]s,
Luciano

Nos teus testes tentou acessar o banco com outro usuario (root) e senha ? SIM! conectou normal conforme os print's abaixo.


Verificou as credenciais do usuario zabbix ? Via cliente do mysql eh possivel acessar o banco do zabbix com as mesmas credencias utilizadas na interface ?

Sim normalmente,conforme telas anexadas abaixo todos os requisitos de privilegios de acesso ao Banco estão ok (aparentemente pra mim!) toda ajuda é muito bem vindo obrigado a força até o momento valeu ainda estou na luta pessoal TO NA FÉ QUE VOU CONSEGUIR ... até mais!
Attached Images
   
Reply With Quote
  #12  
Old 09-04-2010, 17:59
G3orG3 G3orG3 is offline
Junior Member
 
Join Date: Mar 2010
Posts: 10
Default

Quote:
Originally Posted by zabbix_zen View Post
Calma....

De certeza que adicionou os grants necessários à BD zabbix??

Algo do género, (dentro da consola mysql)


Confirme usando,


Recomendo vivamente parar um par de dias para leitura de tutoriais Mysql.
Até porque com o tempo vai ter problemas de performance e vai ter que tunar o /etc/my.cnf
################################################## ##
Segue resultado! ainda to na mesma!

mysql> show Grants for 'zabbix'@'localhost';
+------------------------------------------------------------------------------- -------------------------------------------------------------------------------- -------------------------------------------------------------------------------- -----+
| Grants for zabbix@localhost |
+------------------------------------------------------------------------------- -------------------------------------------------------------------------------- -------------------------------------------------------------------------------- -----+
| GRANT ALL PRIVILEGES ON *.* TO 'zabbix'@'localhost' IDENTIFIED BY PASSWORD '*A 80A9ADF5E7B6959E96C48A049F94E536D79BDE1' WITH GRANT OPTION |
| GRANT ALL PRIVILEGES ON `zabbix`.* TO 'zabbix'@'localhost' WITH GRANT OPTION |
| GRANT ALL PRIVILEGES ON `mysql`.* TO 'zabbix'@'localhost' WITH GRANT OPTION |
| GRANT ALL PRIVILEGES ON `information\_schema`.* TO 'zabbix'@'localhost' WITH G RANT OPTION |
| GRANT ALL PRIVILEGES ON `phpmyadmin`.* TO 'zabbix'@'localhost' WITH GRANT OPTI ON |
| GRANT SELECT (functionid), INSERT (functionid), UPDATE (functionid), DELETE, C REATE, DROP, REFERENCES (functionid), INDEX, ALTER, CREATE VIEW, SHOW VIEW, TRIG GER ON `zabbix`.`functions` TO 'zabbix'@'localhost' WITH GRANT OPTION |
| GRANT SELECT (Host), INSERT (Host), UPDATE (Host), DELETE, CREATE, DROP, REFER ENCES (Host), INDEX, ALTER, CREATE VIEW, SHOW VIEW, TRIGGER ON `mysql`.`columns_ priv` TO 'zabbix'@'localhost' WITH GRANT OPTION |
| GRANT SELECT (eventid), INSERT (eventid), UPDATE (eventid), DELETE, CREATE, DR OP, REFERENCES (eventid), INDEX, ALTER, CREATE VIEW, SHOW VIEW, TRIGGER ON `zabb ix`.`events` TO 'zabbix'@'localhost' WITH GRANT OPTION |
| GRANT SELECT (acknowledgeid), INSERT (acknowledgeid), UPDATE (acknowledgeid), DELETE, CREATE, DROP, REFERENCES (acknowledgeid), INDEX, ALTER, CREATE VIEW, SHO W VIEW, TRIGGER ON `zabbix`.`acknowledges` TO 'zabbix'@'localhost' WITH GRANT OP TION |
| GRANT SELECT (actionid), INSERT (actionid), UPDATE (actionid), DELETE, CREATE, DROP, REFERENCES (actionid), INDEX, ALTER, CREATE VIEW, SHOW VIEW, TRIGGER ON ` zabbix`.`actions` TO 'zabbix'@'localhost' WITH GRANT OPTION |
| GRANT SELECT (alertid), INSERT (alertid), UPDATE (alertid), DELETE, CREATE, DR OP, REFERENCES (alertid), INDEX, ALTER, CREATE VIEW, SHOW VIEW, TRIGGER ON `zabb ix`.`alerts` TO 'zabbix'@'localhost' WITH GRANT OPTION |
| GRANT SELECT (applicationid), DELETE, CREATE, DROP, INDEX, ALTER, CREATE VIEW, SHOW VIEW, TRIGGER ON `zabbix`.`applications` TO 'zabbix'@'localhost' WITH GRAN T OPTION |
| GRANT SELECT (conditionid), INSERT (conditionid), UPDATE (conditionid), DELETE , CREATE, DROP, REFERENCES (conditionid), INDEX, ALTER, CREATE VIEW, SHOW VIEW, TRIGGER ON `zabbix`.`conditions` TO 'zabbix'@'localhost' WITH GRANT OPTION |
| GRANT SELECT (dcheckid), INSERT (dcheckid), UPDATE (dcheckid), DELETE, CREATE, DROP, REFERENCES (dcheckid), INDEX, ALTER, CREATE VIEW, SHOW VIEW, TRIGGER ON ` zabbix`.`dchecks` TO 'zabbix'@'localhost' WITH GRANT OPTION |
| GRANT SELECT (dhostid), INSERT (dhostid), UPDATE (dhostid), DELETE, CREATE, DR OP, REFERENCES (dhostid), INDEX, ALTER, CREATE VIEW, SHOW VIEW, TRIGGER ON `zabb ix`.`dhosts` TO 'zabbix'@'localhost' WITH GRANT OPTION |
| GRANT SELECT (configid), INSERT (configid), UPDATE (configid), DELETE, CREATE, DROP, REFERENCES (configid), INDEX, ALTER, CREATE VIEW, SHOW VIEW, TRIGGER ON ` zabbix`.`config` TO 'zabbix'@'localhost' WITH GRANT OPTION |
| GRANT SELECT (dserviceid), INSERT (dserviceid), UPDATE (dserviceid), DELETE, C REATE, DROP, REFERENCES (dserviceid), INDEX, ALTER, CREATE VIEW, SHOW VIEW, TRIG GER ON `zabbix`.`dservices` TO 'zabbix'@'localhost' WITH GRANT OPTION |
| GRANT SELECT (escalationid), INSERT (escalationid), UPDATE (escalationid), DEL ETE, CREATE, DROP, REFERENCES (escalationid), INDEX, ALTER, CREATE VIEW, SHOW VI EW, TRIGGER ON `zabbix`.`escalations` TO 'zabbix'@'localhost' WITH GRANT OPTION |
| GRANT SELECT (druleid), INSERT (druleid), UPDATE (druleid), DELETE, CREATE, DR OP, REFERENCES (druleid), INDEX, ALTER, CREATE VIEW, SHOW VIEW, TRIGGER ON `zabb ix`.`drules` TO 'zabbix'@'localhost' WITH GRANT OPTION |
| GRANT SELECT (auditid), INSERT (auditid), UPDATE (auditid), DELETE, CREATE, DR OP, REFERENCES (auditid), INDEX, ALTER, CREATE VIEW, SHOW VIEW, TRIGGER ON `zabb ix`.`auditlog` TO 'zabbix'@'localhost' WITH GRANT OPTION |
+------------------------------------------------------------------------------- -------------------------------------------------------------------------------- -------------------------------------------------------------------------------- -----+
Reply With Quote
  #13  
Old 10-04-2010, 21:33
exkg exkg is offline
Senior Member
Zabbix Certified Specialist
 
Join Date: Mar 2007
Location: Porto Alegre - Rio Grande do Sul - Brasil
Posts: 696
Send a message via MSN to exkg Send a message via Skype™ to exkg
Default

Mas pelo erro no log:

Code:
6356:20100331:152908 [Z3001] Connection to database 'zabbix' failed: [1045] Access denied for user 'zabbix'@'localhost' (using password: YES)

O problema eh com as credenciais mesmo .... mas to confuso qt a tua afirmacao de que via cliente do MySQL funciona sem problemas.

Um outro teste:

Code:
# su - zabbix
Code:
mysql -uzabbix -p<A TUA SENHA> <BANCO DO ZABBIX>
Code:
select * from hosts;

E nos conta o resultado ...



[]s,
Luciano
__________________
--
Luciano Alves
www.unirede.net
Twitter|Facebook|Blog|Youtube
Porto Alegre - RS - Brasil
Reply With Quote
  #14  
Old 12-04-2010, 11:44
lndgoncalves lndgoncalves is offline
Junior Member
 
Join Date: Apr 2010
Posts: 27
Default

bom.. não tenho certeza se você conseguiu resolver seu problema mas ai vai uma dia.

primeira coisa,
no seu zabbix_server.conf
a variavel DBHost ta comentanda.

#DBHost=localhost
troca por
DBHost=localhost

não sei se o seu vervidor mysql ta no mesmo servidor que o zabbix.
segundo.
faz um teste.

mysql -u zabbix -p

e ve se consegue acessar o banco de dados do zabbix

use zabbix;
show tables;

acho que pode resolver voce testando um por um..
caso não de certo.

refaça todos os seus passos novamente.
ah, eu recomendo seriamente você compilar o zabbix na mão.
Reply With Quote
  #15  
Old 12-04-2010, 16:49
G3orG3 G3orG3 is offline
Junior Member
 
Join Date: Mar 2010
Posts: 10
Question Resultado do teste proposto.

Quote:
Originally Posted by exkg View Post
Mas pelo erro no log:

Code:
6356:20100331:152908 [Z3001] Connection to database 'zabbix' failed: [1045] Access denied for user 'zabbix'@'localhost' (using password: YES)
O problema eh com as credenciais mesmo .... mas to confuso qt a tua afirmacao de que via cliente do MySQL funciona sem problemas.

Um outro teste:

Code:
# su - zabbix
Code:
mysql -uzabbix -p<A TUA SENHA> <BANCO DO ZABBIX>
Code:
select * from hosts;
E nos conta o resultado ...
[]s,
Luciano
################################################## ##
Bom dia pessoal ! segue resultado aparentemente ok.

0 | 2 | | | 0 | 0 | 0 | 0 |
| 10012 | 0 | Template_AIX | Template_AIX | 0 | | 10050 | 3 | 0 | | 0 | 0 | 0 | 0 | 0 | 0 | 623 | 0 | 2 | | | 0 | 0 | 0 | 0 |
| 10013 | 0 | Template_HPUX | Template_HPUX | 0 | | 10050 | 3 | 0 | | 0 | 0 | 0 | 0 | 0 | 0 | 623 | 0 | 2 | | | 0 | 0 | 0 | 0 |

| 10016 | 0 | Template_SNMPv1_Device | | 0 | | 10050 | 3 | 0 | | 0 | 0 | 0 | 0 | 0 | 0 | 623 | 0 | 2 | | | 0 | 0 | 0 | 0 |
| 10017 | 0 | ZABBIX Server | | 1 | 10.4.33.36 | 10050 | 0 | 0 | | 0 | 0 | 0 | 0 | 0 | 0 | 623 | 0 | 2 | | | 0 | 0 | 0 | 0 |
| 10018 | 0 | Template_Cisco_PIX_525 | | 0 | | 10050 | 3 | 0 | | 0 | 0 | 0 | 0 | 0 | 0 | 623 | 0 | 2 | | | 0 | 0 | 0 | 0 |
| 10019 | 0 | Template_Dell_PowerConnect_6248 | | 0 | | 10050 | 3 | 0 | | 0 | 0 | 0 | 0 | 0 | 0 | 623 | 0 | 2 | | | 0 | 0 | 0 | 0 |
| 10020 | 0 | Template_APC_Battery | | 0 | 0.0.0.0 | 10050 | 3 | 0 | | 0 | 0 | 0 | 0 | 0 | 0 | 623 | 0 | 2 | | | 0 | 0 | 0 | 0 |
| 10021 | 0 | Template_HP_InsightManager | | 0 | 127.0.0.1 | 10050 | 3 | 0 | | 0 | 0 | 0 | 0 | 0 | 0 | 623 | 0 | 2 | | | 0 | 0 | 0 | 0 |
| 10022 | 0 | Template_Dell_OpenManage | | 0 | 0.0.0.0 | 10050 | 3 | 0 | | 0 | 0 | 0 | 0 | 0 | 0 | 623 | 0 | 2 | | | 0 | 0 | 0 | 0 |
| 10023 | 0 | Template_Cisco_PIX | | 0 | | 10050 | 3 | 0 | | 0 | 0 | 0 | 0 | 0 | 0 | 623 | 0 | 2 | | | 0 | 0 | 0 | 0 |

+--------+--------------+----------------------------------------+--------------------+--------------------+----------------+
47 rows in set (0,00 sec)

mysql> 0 | 2 | | | 0 | 0 | 0 | 0 |
-> | 10041 | 0 | Template_Microsoft_Exchange_2007 | | 0 | 0.0.0.0 | 10050 | 3 | 0 | | 0 | 0 | 0 | 0 | 0 | 0 | 623 | 0 | 2 | | | 0 | 0 | 0 | 0 |
-> | 10042 | 0 | Template_IPMI_Sun_Fire_X4100_M2 | | 0 | 0.0.0.0 | 10050 | 3 | 0 | | 0 | 0 | 0 | 0 | 0 | 0 | 623 | 0 | 2 | | | 0 | 0 | 0 | 0 |
-> | 10043 | 0 | Template_Tomcat | | 0 | | 10050 | 3 | 0 | | 0 | 0 | 0 | 0 | 0 | 0 | 623 | 0 | 2 | | | 0 | 0 | 0 | 0 |
-> | 10044 | 0 | Template_Microsoft_SQLServer_2005 | | 0 | 0.0.0.0 | 10050 | 3 | 0 | | 0 | 0 | 0 | 0 | 0 | 0 | 623 | 0 | 2 | | | 0 | 0 | 0 | 0 |
-> | 10045 | 0 | Template_pfSense | | 0 | 0.0.0.0 | 10050 | 3 | 0 | | 0 | 0 | 0 | 0 | 0 | 0 | 623 | 0 | 2 | | | 0 | 0 | 0 | 0 |
-> | 10046 | 0 | Template_NetScreen_25 | | 0 | 0.0.0.0 | 10050 | 3 | 0 | | 0 | 0 | 0 | 0 | 0 | 0 | 623 | 0 | 2 | | | 0 | 0 | 0 | 0 |
-> | 10047 | 0 | WSFL01972 | 10.7.80.10 | 0 | 10.4.11.26 | 10050 | 0 | 0 | | 0 | 0 | 0 | 0 | 0 | 0 | 623 | -1 | 2 | | | 0 | 0 | 0 | 0 |
-> | 10048 | 0 | 10.4.11.26 | | 0 | 10.4.11.26 | 10050 | 0 | 0 | | 0 | 0 | 0 | 0 | 0 | 0 | 623 | -1 | 2 | | | 0 | 0 | 0 | 0 |
-> | 10049 | 0 | server CMA | | 1 | 172.22.3.121 | 10050 | 0 | 0 | | 0 | 0 | 0 | 0 | 0 | 0 | 623 | -1 | 2 | | | 0 | 0 | 0 | 0 |
-> | 10050 | 0 | SWBV08AC01 | 10.0.0.47 | 1 | 10.0.0.47 | 10050 | 0 | 0 | | 0 | 0 | 0 | 0 | 0 | 0 | 623 | -1 | 2 | | | 0 | 0 | 0 | 0 |
-> --+--------------+----------------------------------------+-------------- -> 47 rows in set (0,00 sec)
->
-> mysql>
##############################################
e foi isso ... mas ainda assim continuo com o problema "status do Zabbix rodando>valor>não "
Attached Images
 
Reply With Quote
  #16  
Old 12-04-2010, 17:45
lndgoncalves lndgoncalves is offline
Junior Member
 
Join Date: Apr 2010
Posts: 27
Default

entao

primeira coisa

testa com o usuario root do seu mysql..
funcionou blz??
entao entra no phpmyadmin deleta o usuario zabbix
e crie-o novamente, dando os devidos privilegios..

caso o usuario root nao de certo.
entao e melhor voce rever sua instalacao do banco de dados.


ah.. uma outra coisa tambem.
e sua 1ª instalacao do zabbix?
entao refaz tudo com calma..
passo a passo..
testando tudo com calma.
Reply With Quote
  #17  
Old 13-04-2010, 11:57
G3orG3 G3orG3 is offline
Junior Member
 
Join Date: Mar 2010
Posts: 10
Thumbs down

Quote:
Originally Posted by lndgoncalves View Post
entao

primeira coisa

testa com o usuario root do seu mysql..
funcionou blz??
entao entra no phpmyadmin deleta o usuario zabbix
e crie-o novamente, dando os devidos privilegios..

caso o usuario root nao de certo.
entao e melhor voce rever sua instalacao do banco de dados.


ah.. uma outra coisa tambem.
e sua 1ª instalacao do zabbix?
entao refaz tudo com calma..
passo a passo..
testando tudo com calma.
Foi feito a sugestão acima, sem sucesso é minha segunda tentativa de configuração e paro sempre no mesmo lugar....
To encima mas ta muito estranho tambem acho agora não faço idéia...
De uma maquina windows fecho telnet e tudo mais...,
porem ainda estou com a mensagem abaixo...
Attached Images
 
Reply With Quote
  #18  
Old 13-04-2010, 12:27
lndgoncalves lndgoncalves is offline
Junior Member
 
Join Date: Apr 2010
Posts: 27
Default

Na instalação você executou os 3 arquivos .sql?
schema_mysql
data_mysql
images_mysql
Reply With Quote
  #19  
Old 14-04-2010, 11:37
exkg exkg is offline
Senior Member
Zabbix Certified Specialist
 
Join Date: Mar 2007
Location: Porto Alegre - Rio Grande do Sul - Brasil
Posts: 696
Send a message via MSN to exkg Send a message via Skype™ to exkg
Default

Bom ... a coisa parece bastante 'extra-terrestre'.

A sugestao eh uma nova instalacao do ZERO seguindo todos os passos do manual e tendo atencao a qualquer erro (mesmo que warning) que ocorra.

Fora isso soh com acesso aos teus dados ... mas aparentemente o erro tah diretamente ligado as credencias do usuario que o ZABBIX utiliza para acesso ao MySQL.



[]s,
Luciano
__________________
--
Luciano Alves
www.unirede.net
Twitter|Facebook|Blog|Youtube
Porto Alegre - RS - Brasil
Reply With Quote
  #20  
Old 22-04-2010, 15:50
G3orG3 G3orG3 is offline
Junior Member
 
Join Date: Mar 2010
Posts: 10
Default é o jeito...

Vai ter de ser assim mesmo então,vou fazer uma nova instal tanto do server Linux quanto do zabbix,e vamos ver o que acontece alguem teria um tutorial bacana e de preferencia em portugues(Brasil) pra indicar? sera bem vindo!

Outra coisa que gostaria de ver aqui com os senhores,estou pensando em fazer o curso de Zabbix na 4 Linux,seria valido? alguem conhece outra opção ou tem outra recomendação sobre isso pois vou precisar muito aprender Zabbix,ja virou urgencia aqui na empresa.Temos uma grande necessidade de implantar o ambiente aqui.
obrigado

OBS: meu problema ainda persiste rsrsr
Reply With Quote
Reply

Tags
deny, user, zabbix access

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 09:03.