ZABBIX Forums  
  #1  
Old 30-09-2016, 12:53
lfernandosg lfernandosg is offline
Member
 
Join Date: Dec 2015
Posts: 86
Default Acesso externo grafana

Pessoal
Instalei o plugin grafana e está rodando 100%.
Para acessar de fora de minha rede, fiz um direcionamento ipexterno:3000 para ipinternografana:3000

Ele abre a tela de login e quando logo, ele não carrega nenhum gráfico.

O que pode ser?
Reply With Quote
  #2  
Old 30-09-2016, 16:16
edsrj edsrj is offline
Junior Member
 
Join Date: Aug 2013
Posts: 4
Default

Para começar o troubleshooting eu veria através de uma solução estilo feedler para ver onde está o erro de carregamento. Uma das possibilidades pode ser que exista algum bloqueio no firewall de borda (um chute).
Reply With Quote
  #3  
Old 30-09-2016, 16:47
lfernandosg lfernandosg is offline
Member
 
Join Date: Dec 2015
Posts: 86
Default

Quote:
Originally Posted by edsrj View Post
Para começar o troubleshooting eu veria através de uma solução estilo feedler para ver onde está o erro de carregamento. Uma das possibilidades pode ser que exista algum bloqueio no firewall de borda (um chute).

Tem alguma outra porta alem da porta 3000?

Acesso o zabbix externamente normal e é porque direcionei para porta 2222
Reply With Quote
  #4  
Old 30-09-2016, 18:52
edsrj edsrj is offline
Junior Member
 
Join Date: Aug 2013
Posts: 4
Default

*a ferramenta que informei anteriormente na verdade o nome é fiddler, é um debugger web.

Eu não publiquei o meu, mas que eu tenha visto de portas abertas agora, aparentemente não abre outras que não a 3000. (Hoje em dia existem fw's de "próxima geração" que pode não surtir efeito caso vc libere apenas a porta, já aconteceu aqui na empresa).
Reply With Quote
  #5  
Old 03-10-2016, 13:32
lfernandosg lfernandosg is offline
Member
 
Join Date: Dec 2015
Posts: 86
Default

Quote:
Originally Posted by edsrj View Post
*a ferramenta que informei anteriormente na verdade o nome é fiddler, é um debugger web.

Eu não publiquei o meu, mas que eu tenha visto de portas abertas agora, aparentemente não abre outras que não a 3000. (Hoje em dia existem fw's de "próxima geração" que pode não surtir efeito caso vc libere apenas a porta, já aconteceu aqui na empresa).
Vou testar. É estranho porque ele abre a tela emloginr entro normalmente.
Só os gráficos que não aparecem...ficam tentando um refresh e nada
Reply With Quote
  #6  
Old 04-10-2016, 17:42
Hernandes Martins Hernandes Martins is offline
Senior Member
Zabbix certified specialist
 
Join Date: Apr 2011
Location: São Paulo - Brasil
Posts: 550
Send a message via Skype™ to Hernandes Martins
Talking

Internamento funciona ?
__________________
__

Att.
Hernandes Martins

http://www.unirede.net - Zabbix Brazil Premium Partner
Blog: http://hernandesmartins.blogspot.com.br/
Skype: hernandss | Youtube: HernandesMartins
São Paulo - SP - Brazil Comunnity: http://zabbixbrasil.org/
Grupo Facebook
Zabbix LATAM Español https://www.facebook.com/groups/zabbixlatam/
Zabbix Brasil Portugues https://www.facebook.com/groups/zabbixbrasil/
Reply With Quote
  #7  
Old 04-10-2016, 17:43
lfernandosg lfernandosg is offline
Member
 
Join Date: Dec 2015
Posts: 86
Default

sim!! dentro da minha rede mesmo atrás de um NAT funciona 100%

Externo ele abre a tela de login, e quando logo, fica tentando carregar os gráficos.
Reply With Quote
  #8  
Old 04-10-2016, 17:48
Hernandes Martins Hernandes Martins is offline
Senior Member
Zabbix certified specialist
 
Join Date: Apr 2011
Location: São Paulo - Brasil
Posts: 550
Send a message via Skype™ to Hernandes Martins
Talking

Provavelmente está tentando acesso ao source e não está conseguindo chegar, vai ter que debugar os logs pra saber aonde está parando a consulta, para achar esse real problema.

Abraços
__________________
__

Att.
Hernandes Martins

http://www.unirede.net - Zabbix Brazil Premium Partner
Blog: http://hernandesmartins.blogspot.com.br/
Skype: hernandss | Youtube: HernandesMartins
São Paulo - SP - Brazil Comunnity: http://zabbixbrasil.org/
Grupo Facebook
Zabbix LATAM Español https://www.facebook.com/groups/zabbixlatam/
Zabbix Brasil Portugues https://www.facebook.com/groups/zabbixbrasil/
Reply With Quote
  #9  
Old 06-11-2017, 09:41
Alexsandro Alexsandro is offline
Junior Member
 
Join Date: Nov 2017
Posts: 3
Default

Quote:
Originally Posted by lfernandosg View Post
sim!! Dentro da minha rede mesmo atrás de um nat funciona 100%

externo ele abre a tela de login, e quando logo, fica tentando carregar os gráficos.
conseguiu resolver seu problema ? Estou com mesmo problema ...
Reply With Quote
  #10  
Old 21-11-2017, 16:54
angelhc angelhc is offline
Senior Member
Zabbix certified specialist
 
Join Date: Nov 2009
Location: Madrid, Spain
Posts: 226
Default

Es fácil, grafana tiene que tener acceso a Zabbix, si has usado una redirección tienes que configurar en el firewall que esa redirección pueda acceder a zabbix.
Saludos.
__________________
Number of hosts 1600,Number of items +90k,Number of triggers +22k, Number of users +100, New values per second +1270

http://zabbixes.wordpress.com/
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 10:10.