ZABBIX Forums  

Go Back   ZABBIX Forums > Zabbix Discussions and Feedback > Zabbix Troubleshooting and Problems

Reply
 
Thread Tools Display Modes
  #1  
Old 01-12-2017, 10:56
marcin11858 marcin11858 is offline
Junior Member
 
Join Date: Dec 2017
Posts: 6
Default Problem with installing Zabbix 3.0.13 on Red Hat 4.8.5-4

I'm trying to install Zabbix 3.0.13 with MySQL from sources on Red Hat and I got below error when I was executing make install command:

Code:
gcc -DZABBIX_DAEMON -DSYSCONFDIR="\"/usr/local/etc\"" -DDATADIR="\"/usr/local/share\"" -DLIBDIR="\"/usr/local/lib\"" -I../../src/libs/zbxdbcache -g -O2 -L/usr/lib64        -L/usr/lib64      -rdynamic   -o zabbix_server zabbix_server-actions.o zabbix_server-operations.o zabbix_server-events.o zabbix_server-scripts.o zabbix_server-server.o alerter/libzbxalerter.a dbsyncer/libzbxdbsyncer.a dbconfig/libzbxdbconfig.a discoverer/libzbxdiscoverer.a pinger/libzbxpinger.a poller/libzbxpoller.a housekeeper/libzbxhousekeeper.a timer/libzbxtimer.a trapper/libzbxtrapper.a snmptrapper/libzbxsnmptrapper.a httppoller/libzbxhttppoller.a watchdog/libzbxwatchdog.a escalator/libzbxescalator.a proxypoller/libzbxproxypoller.a selfmon/libzbxselfmon.a vmware/libzbxvmware.a ../../src/libs/zbxsysinfo/libzbxserversysinfo.a ../../src/libs/zbxsysinfo/common/libcommonsysinfo.a ../../src/libs/zbxsysinfo/simple/libsimplesysinfo.a ../../src/libs/zbxlog/libzbxlog.a ../../src/libs/zbxserver/libzbxserver.a ../../src/libs/zbxdbcache/libzbxdbcache.a ../../src/libs/zbxmemory/libzbxmemory.a ../../src/libs/zbxregexp/libzbxregexp.a ../../src/libs/zbxalgo/libzbxalgo.a ../../src/libs/zbxnix/libzbxnix.a ../../src/libs/zbxsys/libzbxsys.a ../../src/libs/zbxconf/libzbxconf.a ../../src/libs/zbxmedia/libzbxmedia.a ../../src/libs/zbxcommon/libzbxcommon.a ../../src/libs/zbxcrypto/libzbxcrypto.a ../../src/libs/zbxcomms/libzbxcomms.a ../../src/libs/zbxcommshigh/libzbxcommshigh.a ../../src/libs/zbxjson/libzbxjson.a ../../src/libs/zbxexec/libzbxexec.a ../../src/libs/zbxself/libzbxself.a ../../src/libs/zbxicmpping/libzbxicmpping.a ../../src/libs/zbxdbupgrade/libzbxdbupgrade.a ../../src/libs/zbxdbhigh/libzbxdbhigh.a ../../src/libs/zbxdb/libzbxdb.a ../../src/libs/zbxmodules/libzbxmodules.a -lmysqlclient         -lnetsnmp       -lm -ldl  -lresolv
/bin/ld: /usr/lib64/libmysqlclient.a(mysql_async.c.o): undefined reference to symbol 'SSL_get_error@@libssl.so.10'
/bin/ld: note: 'SSL_get_error@@libssl.so.10' is defined in DSO /lib64/libssl.so.10 so try adding it to the linker command line
Do you have any idea how I can solve this problem?
Thank you in advance
Reply With Quote
  #2  
Old 02-12-2017, 13:11
volter volter is offline
Member
Zabbix certified specialist
 
Join Date: Dec 2011
Location: Vienna, Austria
Posts: 49
Default

Why are you trying to compile it on your own?

A missing -lssl might be the concrete problem.
Reply With Quote
  #3  
Old 02-12-2017, 15:24
marcin11858 marcin11858 is offline
Junior Member
 
Join Date: Dec 2017
Posts: 6
Default

When I'm trying to run Zabbix from RPM file I got below error:
Code:
Unit zabbix-server.service has begun starting up.
Dec 01 10:10:06  kernel: zabbix_server[17549]: segfault at 18 ip 00007f24d5101c00 sp 00007ffdfca9bdb8 error 4
Dec 01 10:10:06  kernel: zabbix_server[17554]: segfault at 18 ip 00007f24d5101c00 sp 00007ffdfca9bdb8 error 4
Dec 01 10:10:06  kernel:  in libpthread-2.17.so[7f24d50f8000+16000]
Dec 01 10:10:06  kernel:
Dec 01 10:10:06  kernel:  in libpthread-2.17.so[7f24d50f8000+16000]
Dec 01 10:10:06  kernel:
Dec 01 10:10:06  audispd[8018]: node= type=ANOM_ABEND msg=audit(1512141006.574:304267): auid=4294967295 uid=0 gid=0 ses=4294967295 pid=17554 comm="zabbix_server" reason="memory violation" sig=11
Dec 01 10:10:06  audispd[8018]: node= type=ANOM_ABEND msg=audit(1512141006.580:304268): auid=4294967295 uid=0 gid=0 ses=4294967295 pid=17549 comm="zabbix_server" reason="memory violation" sig=11
Dec 01 10:10:06  systemd[1]: zabbix-server.service: control process exited, code=killed status=11
Dec 01 10:10:09  audispd[8018]: node= type=ANOM_ABEND msg=audit(1512141009.446:304269): auid=4294967295 uid=0 gid=0 ses=4294967295 pid=17555 comm="zabbix_server" reason="memory violation" sig=11
Dec 01 10:10:09  audispd[8018]: node= type=SERVICE_START msg=audit(1512141009.455:304270): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=zabbix-server comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=?
Dec 01 10:10:09  polkitd[2391]: Unregistered Authentication Agent for unix-process:17531:3034576394 (system bus name :1.209605, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (disconnected from b
Dec 01 10:10:09  systemd[1]: Failed to start Zabbix Server.
Do you know where may be issue with this?
Reply With Quote
  #4  
Old 04-12-2017, 05:31
Atsushi Atsushi is offline
Senior Member
 
Join Date: Aug 2013
Location: Japan
Posts: 751
Default

I think the RHEL 4 standard library is too old.
With standard libraries, you will not be able to build Zabbix server.
For building Zabbix server, please use the newer OS.
Reply With Quote
  #5  
Old 04-12-2017, 09:50
volter volter is offline
Member
Zabbix certified specialist
 
Join Date: Dec 2011
Location: Vienna, Austria
Posts: 49
Default

That's quite possible, Atsushi. EL5 is unsupported by Redhat and EL4 more so. While I can somehow understand a need to have an agent on a long-unsupported legacy system, building the server doesn't make sense to me.

Hang on! EL4 and "systemd"? Something is wrong here.
Reply With Quote
  #6  
Old 04-12-2017, 12:44
Atsushi Atsushi is offline
Senior Member
 
Join Date: Aug 2013
Location: Japan
Posts: 751
Default

Hi volter,
So I wrote that they will not be able to build Zabbix server with RHEL 4.

Also, in RHEL 4 you should use init instead of systemd for agent.
Reply With Quote
  #7  
Old 04-12-2017, 12:59
marcin11858 marcin11858 is offline
Junior Member
 
Join Date: Dec 2017
Posts: 6
Default

Unfortunately I can not change OS.
How can I use init instead of systemd?
This are my first steps with Zabbix.
Reply With Quote
  #8  
Old 04-12-2017, 14:44
Atsushi Atsushi is offline
Senior Member
 
Join Date: Aug 2013
Location: Japan
Posts: 751
Default

Hi marcin11858,

If you can not change the OS, you can not build a Zabbix server on that server.
Please prepare another server.

init is the service management process installed by RHEL 4 by default.
It can be started and managed with init in the case of agent only.
Reply With Quote
  #9  
Old 05-12-2017, 10:15
marcin11858 marcin11858 is offline
Junior Member
 
Join Date: Dec 2017
Posts: 6
Default

I also can not prepare another server.
Maybe I should use docker Zabbix image?
Reply With Quote
  #10  
Old 05-12-2017, 10:52
Atsushi Atsushi is offline
Senior Member
 
Join Date: Aug 2013
Location: Japan
Posts: 751
Default

Docker can not run on RHEL 4.
That OS is too old.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 22:53.