Ad Widget

Collapse

Zabbix Dynamic PDF Report Generation

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • AaronMVP
    replied
    Hello,

    Somehow my reports aren't showing any data when I enable 'Include graphs'. The only way to get a report is unchecking every checkbox, then I get a empty report without any data.
    I also get alot of these kind of CURL commands:

    {"groupid":"6","name":"Virtual machines"},{"groupid":"4","name":"Zabbix servers"}],"id":1}) Response decoded: (Array ( [jsonrpc] => 2.0 [result] => Array ( [0] => Array ( [groupid] => 20 [name] => DATTS_AMSD ) [1] => Array ( [groupid] => 5 [name] => Discovered hosts ) [2] => Array ( [groupid] => 2 [name] => Linux servers ) [3] => Array ( [groupid] => 19 [name] => Synology ) [4] => Array ( [groupid] => 18 [name] => UPS ) [5] => Array ( [groupid] => 6 [name] => Virtual machines ) [6] => Array ( [groupid] => 4 [name] => Zabbix servers ) ) [id] => 1 ) CURL URL: http://10.0.20.206/zabbix/api_jsonrpc.php
    CURL Options: Array ( [19913] => 1 [41] => [13] => 30 [78] => 5 [81] => [64] => [52] => 1 [74] => 1 [10023] => Array ( [0] => Content-Type: application/json-rpc [1] => User-Agent: ZabbixAPI v1.0 - http://andrewfarley.com/zabbix_php_api ) [10036] => POST [10015] => {"auth":"c406e1cbe85f7e88f2b8fd694a019b83","met hod ":"user.logout","id":1,"params":[],"jsonrpc":"2.0"} [10102] => gzip ) Got response from API: ({"jsonrpc":"2.0","result":true,"id":1}) Response decoded: (Array ( [jsonrpc] => 2.0 [result] => 1 [id] => 1 ) __logout() Got response from API: (1)

    In /var/log/apache2/error.log I get the following error:
    [Wed Sep 16 11:32:22.950385 2020] [php7:warn] [pid 1429] [client 10.60.2.239:62368] PHP Warning: get_class() expects parameter 1 to be object, null given in /usr/share/zabbix/zabbix-pdf-report/inc/ZabbixAPI.class.php on line 208, referer: http://10.0.20.206/zabbix/zabbix-pdf-report/chooser.php

    Could anyone help me out with this issue? So I can make a report with data.

    CURL and PHP is installed. Using zabbix version 4.4.

    Leave a comment:


  • Pavlik
    commented on 's reply
    Hi, provels

    I checked it in 3 browsers (Chrome, Edge, Yandex) with security settings turned off - no effect, the same problem :/

  • provels
    replied
    In one of my past posts, I said I thought the PDF Report Generator was crashing when the URL was added as a screen. This is not the case; it is the 30 second screen auto-refresh that is clearing the report.
    Is there a way to disable auto-refresh for a single page/screen or would that disable it globally? Thank you.

    EDIT - I found in another post that the refresh interval is defined in the user profile (upper right corner of screen). I can change it to whatever I wish.
    So another problem solved!

    Last edited by provels; 12-09-2020, 00:19.

    Leave a comment:


  • provels
    commented on 's reply
    Could it be security settings in your browser?

  • vatixxx
    replied
    It's possible to automate generation of this report, and send every day by e-mail?

    Leave a comment:


  • geekypr
    commented on 's reply
    Hi,
    Have you figure it out why the "Old Reports" link?
    I can't find any solution to this, even trying with different browsers...

    Regards,

  • parmesh
    replied
    Hello there, ...

    I'm new here and, I'm attempting to find out about this module. I put it working yet something is missing yet, I accept on the grounds that the chart isn't appearing. I saw another post on a similar subject who has a similar issue, however, nobody answer plainly how fixed this.

    Would someone be able to help or simply show the "North" hehe?

    Apologies, my English is a lot of poor.

    Much appreciated!
    Last edited by parmesh; 23-08-2020, 10:42.

    Leave a comment:


  • Pavlik
    replied
    Screen doesn't work

    By the way, I ran into a problem. The reporter works well on its own web-page. But Zabbix screen with reporter as URL resource seems not.

    It shows all elements of the form, and when I select something and click "Generate" button, nothing happens.
    Click image for larger version  Name:	reporter.png Views:	19 Size:	52.5 KB ID:	407183

    Can anyone help, please?

    My soft:
    Zabbix server version: 4.4.10 and 5.0.2 (doesn't work on both servers)
    PHP version: 7.0.33-0+deb9u8 (Zabbix 4.4.10) and 7.4.3 (Zabbix 5.0.2)
    zabbix-pdf-report version: 1.2.3

    EDIT:

    When screen is opened, Chrome's dev-tool shows error:
    Blocked script execution in '<URL>' because the document's frame is sandboxed and the 'allow-scripts' permission is not set.
    And when I click "Generate" button, it shows the following message:
    Blocked form submission to 'createpdf.php' because the form's frame is sandboxed and the 'allow-forms' permission is not set.

    Still don't know how to fix it.
    Last edited by Pavlik; 18-08-2020, 16:06.

    Leave a comment:


  • Pavlik
    replied
    Installation instruction

    Hi!

    First of all, I want to thank martinm_76 and other people who had a hand in this project. I've been looking for a reporting tool for quite a long time, and this one is great.

    However, it was difficult for me to get started. How-to section, honestly, isn't really helpful, and I had to read lots of messages on this forum to find out all installation steps. And I can see that I'm not the only one.

    So, I want to clarify author's How-to to help other people.

    I also want to mention that I've just registred in this forum, so my text formatting skills can be horrible... and my English isn't the best as well.

    Installation

    1) Clone repo to /usr/share/zabbix/ (you may also create inner directory, e.g. custom_pages, and place repo there):
    Code:
    sudo git clone https://github.com/martinm76/zabbix-pdf-report /usr/share/zabbix/zabbix-pdf-report
    cd /usr/share/zabbix/zabbix-pdf-report
    2) Create tmp and reports folders with proper rights by running script:
    Code:
    sudo ./fixrights.sh
    3) Copy config.inc.php.dist to config.inc.php and configure the latter:
    Code:
    sudo cp config.inc.php.dist config.inc.php
    sudo nano config.inc.php
    4) Make sure you have php-curl and php-json packages installed.

    5) Restart apache:
    Code:
    sudo service apache2 restart
    6) Now you should be able to access PDF report generation page using a URL like this:

    http://x.x.x.x/zabbix/zabbix-pdf-report, where x.x.x.x is your Zabbix server IP.

    7) You may also create a Zabbix screen to make using zabbix-pdf-report more convenient. In zabbix web-interface go to Screens -> Create New. Create a new 1 row 1 column screen with width and height of 800x600 / Centre / Top. Set Resource as URL:
    http://x.x.x.x/zabbix/zabbix-pdf-report

    If you have SELinux being active on the system and fail to get the PDF's generated, try disabling SELinux for a while:
    Code:
    setenforce 0
    A little bit about usage

    Most of the elements of zabbix-pdf-report web-interface are quite clear. But I think that "Graphs to show" and "Items to graph" text fields can be tricky. So I want to explain this part:

    Default content here is actually regular expressions with hash signs (#) as delimiters. So you may enter partial matches instead of complete names. Use vertical line (|) to separate names.

    NB: Regexps are case sensitive by default. Use ignore case flag (i) to change case sensitivity.

    Leave a comment:


  • sanemogi
    replied
    Hello,

    I am new to zabbix - could you send me directions on how we initiate this ? I have so far:

    1. installed the project from git
    2. copied the config.inc.php.dist to config.inc.php
    2. edited the config.inc.php file with my server info etc.
    3. Run the ./fixrights.sh

    then what we do ? restart httpd and zabbix server ?

    thank you,

    Spyros

    Leave a comment:


  • Markus_M
    commented on 's reply
    provels,
    that´s not that what i like. for example: i have a template with 43 service-checks, but on some hosts, only 2-3 services are on this host existent, the other items are disabled. i try to exclude the disabled items for the report, but the disabled items will show with no data...

    Thx for help

  • rvanderkooi
    commented on 's reply
    This is fixed it!

    I downloaded the newest version of generator tool and change zabbix version: 4.4 to 5.0 in the config.inc.php.

  • rvanderkooi
    replied
    Hello,

    i have Centos 8 with Zabbix 5.0.2 and nginx with php-pfm 7.2

    i have installed this pdf report, but it doesn't work.

    my nginx log said:

    2020/07/28 18:36:53 [error] 23162#0: *261 FastCGI sent in stderr: "PHP message: PHP Warning: get_class() expects parameter 1 to be object, null given in /usr/share/zabbix/zabbix-pdf-report/inc/ZabbixAPI.class.php on line 208" while reading response header from upstream, client: MYIP, server: myzabbixserver, request: "GET /zabbix-pdf-report/chooser.php HTTP/1.1", upstream: "fastcgi://unix:/run/php-fpm/zabbix.sock:", host: "myzabbixserver"


    when i browse i have many of errors: CURL URL: https://myserver.
    I can see and choose the hosts.

    anybody a idea?

    Leave a comment:


  • provels
    commented on 's reply
    Try changing the filter line to #.*#
    That will show anything and everything configured.

  • rvanderkooi
    commented on 's reply
    Yes, install the zabbix-pdf-folder into your zabbix folder.

    I have also installed nginx en place the zabbix-pdf-folder into /usr/share/zabbix/

Announcement

Collapse
No announcement yet.
Working...
X