Announcement

Collapse
No announcement yet.

Announcing official Zabbix 2.0 packages in EPEL6 (RHEL, CentOS, Scientific Linux)

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Announcing official Zabbix 2.0 packages in EPEL6 (RHEL, CentOS, Scientific Linux)

    I'm happy to announce official 2.0 packages for Enterprise Linux 6.

    The packages are available via EPEL, a repository maintained by Fedora people, carefully crafted to augment RHEL, CentOS or Scientific Linux. These packages follow the same packaging rules as original RHEL packages. They therefore aim to be the best fitting you can get. Due to EPEL's stable policy, the package is called "zabbix20" instead of "zabbix" and can't be installed in parallel.

    # yum install zabbix20 <zabbix20-stuff-you-need>

    Bugs are tracked on bugzilla.redhat.com. Please don't try to contact me here, but rather via this tracker or on Freenode IRC (volter) or volker27[at]gmx.at.

    The packages include a file called zabbix-fedora.README. It explains what changed between 1.8 and 2.0 package and what is specific to Fedora/EPEL. Among others, it explains why the Java gateway is not in. Feel free to vote on the tickets below, if that is important to you.

    https://support.zabbix.com/browse/ZBX-4800
    https://support.zabbix.com/browse/ZBX-4987

    I can not guarantee compatibility, if you installed Zabbix packages from a different source in the past (besides geofrogger.net). I consider packaging the task of distributions and their contributors. For a rationale, see https://zabbix.org/wiki/Appeal_again...ream_packaging
    Last edited by volter; 25-12-2012, 12:02.

    #2
    I did an upgrade from 1.8 to 2.0 using these packages and everything is working now. The only issue I ran into were the usual database schema changes. MySQL loves to time out.... GRRR... The only other issue I thought I was was that some graphs would not show, but that has proven to likely be a stale CSS cache.

    Overall, works well!

    Key points to note, old zabbix packages need to be ininstalled first (yum erase zabbix*) then the new zabbix packages installed from epel (yum install zabbix20-agent zabbix20-web-<DB> zabbix20-server-<DB>). The upgrade scripts can be found in /usr/share/zabbix-<DB>.
    RHCE, author of zbxapi
    Ansible, the missing piece (Zabconf 2017): https://www.youtube.com/watch?v=R5T9NidjjDE
    Zabbix and SNMP on Linux (Zabconf 2015): https://www.youtube.com/watch?v=98PEHpLFVHM

    Comment


      #3
      As 2.0.3-4 went to the regular repository, I updated my initial post.

      Newer versions will always make their way through the testing repository and will proceed to stable 14 days later, unless problems arise.

      To try versions from the testing repository:

      yum --enablerepo=epel-testing install zabbix20 <zabbix20-stuff-you-need>

      With enough positive feedback, the incubation period can be vastly shortened. If you find it well working or broken, please register, search for the latest EPEL build and leave feedback.

      https://admin.fedoraproject.org/updates
      Last edited by volter; 26-11-2012, 14:20.

      Comment


        #4
        2.0.4-1 is on the way to epel-testing. It should be available on the 9th of December.

        yum --enablerepo=epel-testing install zabbix20 <zabbix20-stuff-you-need>

        Please test and leave feedback on https://admin.fedoraproject.org/updates. With enough positive feedback, the incubation period can be shortened vastly. Please register and log in, search for the latest EPEL build and leave feedback.

        Comment


          #5
          should this srpm compile on el5 ?

          i got these error in mock logs


          Code:
          --snip--
          DEBUG util.py:257:  zabbix20                    ##################################################
          DEBUG util.py:257:  error: unpacking of archive failed on file /builddir/build/SOURCES/zabbix-1.8.12-fping3.patch;50c398e2: cpio: MD5 sum mismatch
          DEBUG util.py:347:  Child return code was: 1
          --snip---

          Comment


            #6
            The problem you're seeing, is the change in checksum algorithm in rpm between RHEL 5 and 6, which is not really a big deal.

            Nevertheless, the SRPM won't build in EL 5 like it is. Zabbix considers the libssh in EL5 as too old, so there'll be no SSH support. EL 5 spec files also need some additional lines, no longer necessary in EL 6.

            I have a working draft, but there are a few details I need to clarify.

            Comment


              #7
              Originally posted by volter View Post
              I have a working draft, but there are a few details I need to clarify.
              Hey, any progress on this?
              I'm currently running Zabbix on a number of RH5 boxes and would love to upgrade them to 2. I was about to start pulling apart the SRPMS and see if I could get them to build but if you've got some work in progress?
              Cheers

              Comment


                #8
                Yeah

                thanks

                Comment


                  #9
                  The EPEL 5 packages entered testing stage. Please test and leave comments on:

                  https://admin.fedoraproject.org/upda...20-2.0.4-4.el5

                  It will only be available via yum in a couple of days. In the meantime, you can download from:

                  https://koji.fedoraproject.org/koji/...ackageID=14989

                  Also notice the Zabbix blog article:

                  http://blog.zabbix.com/zabbix-2-0-pa...entos-sl/1893/

                  Comment

                  Working...
                  X