Announcement

Collapse
No announcement yet.

Zabbix server is running No

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Zabbix server is running No

    Maybe I am having a blonde moment, but...

    I have installed 1.9.9 in a test environment (obviously).
    The Dashboard shows me:

    Code:
    Zabbix server is running	No
    if I give the command #ps -A | grep zabbix, I get

    Code:
    26835 ?        00:00:00 zabbix_server
    26837 ?        00:00:17 zabbix_server
    26838 ?        00:00:05 zabbix_server
    26839 ?        00:03:36 zabbix_server
    26840 ?        00:03:35 zabbix_server
    26841 ?        00:03:35 zabbix_server
    26842 ?        00:03:36 zabbix_server
    26845 ?        00:03:36 zabbix_server
    26846 ?        00:00:23 zabbix_server
    26847 ?        00:00:00 zabbix_server
    26848 ?        00:00:00 zabbix_server
    26849 ?        00:00:00 zabbix_server
    26850 ?        00:00:00 zabbix_server
    26855 ?        00:00:01 zabbix_server
    26856 ?        00:00:55 zabbix_server
    26857 ?        00:00:04 zabbix_server
    26858 ?        00:00:08 zabbix_server
    26859 ?        00:00:06 zabbix_server
    26860 ?        00:00:29 zabbix_server
    26861 ?        00:00:04 zabbix_server
    26862 ?        00:01:02 zabbix_server
    26870 ?        00:01:02 zabbix_server
    26871 ?        00:01:02 zabbix_server
    26872 ?        00:01:01 zabbix_server
    26873 ?        00:00:47 zabbix_server
    26874 ?        00:00:23 zabbix_server
    26875 ?        00:00:49 zabbix_server
    29547 ?        00:00:00 zabbix_agentd
    29548 ?        00:02:19 zabbix_agentd
    29549 ?        00:02:51 zabbix_agentd
    29550 ?        00:02:51 zabbix_agentd
    29551 ?        00:02:50 zabbix_agentd
    29552 ?        00:00:44 zabbix_agentd
    which means both the agent and the server are running.

    Further more, it is gathering data, which means it is running...

    Is this a bug or have I been indoors too long without sunshine?

    #2
    Pointing to correct port?

    One quick an easy thing to check is if your web interface configuration file (zabbix.conf.php) is pointing to the correct server and port.

    The two following variables should be set to the correct values:

    $ZBX_SERVER
    $ZBX_SERVER_PORT

    Comment


      #3
      Ok, have re-installed the test server with Ver 2.0.0rc1 (I have also reinstalled the OS)

      The Overview (triggers) show that the zabbix server is up.
      The "Status of Zabbix" on the dashboard says no.
      Attached Files

      Comment


        #4
        I worksr to me. I just put the server's IP at $ZBX_SERVER in zabbix.conf .php....now it says "zabbix server is running = Yes

        Comment


          #5
          Upgraded to 2.0.0rc3 and the problem went away

          I see there is a change to the format of the zabbix.conf.php file

          Comment


            #6
            Same problem on rc3

            I have the same on rc3.
            I do test it on 127.0.0.1 (ZBX_SERVER)
            I didn't try with it's real ip, but that shouldn't be an issue, though?

            Minor problem, but still annoying...
            I run Centos 6.2
            i use rpm apache, mysql and php....

            Comment


              #7
              Originally posted by dickinson View Post
              I worksr to me. I just put the server's IP at $ZBX_SERVER in zabbix.conf .php....now it says "zabbix server is running = Yes
              I have same issue with fresh installed 3.0.4, but change to IP address did not help me solve it.

              Looking for solution.....

              Comment


                #8
                Zabbix server is running No

                I had the same issue and followed/verified all the settings but I also changed the ListenIP of zabbix_server.conf to the host's ip address and reloaded zabbix server and it worked like a charm. I figured that it was referring to 127.0.0.1 ip address from the zabbix_server.log messages like below and looked up the zabbix_server.conf for the ip address which had been assigned to the ListenIP directive.

                cannot send list of active checks to "127.0.0.1": host [feplnx7] not found


                Let me know if that fixed your issue.

                Comment


                  #9
                  Please tell me the detailed version and installation method of Zabbix and OS you are using.

                  Suppose you have Zabbix 3.0.7 installed on CentOS 7.3.1611.
                  If you changed ListenIP in zabbix_server.conf, please also change the setting of the Web front end.
                  For CentOS, it is the following file.

                  /etc/zabbix/web/zabbix.conf.php

                  Please change the value of $ZBX_SERVER_PORT in this file to the changed value.

                  Also check that the host named "feplnx7" is registered.

                  Comment


                    #10
                    Hi,

                    Yes, I did change the values in the zabbix.conf.php file. I changed the values for the below parameters and it is a Zabbix 3.0.7 installed on CentOS 7.3.1611.

                    $DB['TYPE']
                    $DB['SERVER']
                    $DB['PORT']
                    $DB['DATABASE']
                    $DB['USER']
                    $DB['PASSWORD']

                    $ZBX_SERVER
                    $ZBX_SERVER_PORT
                    $ZBX_SERVER_NAME

                    Comment


                      #11
                      Hi nawazahmed,

                      Is your problem outputting the following error?

                      cannot send list of active checks to "127.0.0.1": host [feplnx7] not found
                      If so, please check that the host is registered with the hostname "feplnx7".

                      This is output when the character string specified by the Hostname of the Zabbix agent does not match the character string of the host's name registered on the Zabbix server side.

                      Comment


                        #12
                        Hi Atsushi,

                        The issue is resolved now, I had the same as raytracy and MrQ and I was responding to them that change the ListenIP to the ip address of the server fixed it. The host is indeed registered with the hostname.

                        And thank you so much for your updated regarding the $ZBX_SERVER_PORT parameter.

                        ~

                        Nawaz

                        Comment

                        Working...
                        X