Ad Widget


Server returned invalid UTF-8 sequence!!

  • Filter
  • Time
  • Show
Clear All
new posts

    Server returned invalid UTF-8 sequence!!

    I am already with this problem for more than 2 weeks and is driving me insane.

    So here is the problem, fingers crossed someone can help me:

    Trying to create an monitoring via HTTP Agent
    Version of Zabbix: 4.2.1
    Request Body Type: XML Data
    Not Converting to Json, but already tried this option
    SSL verified peer/host off but already tried this option on
    No HTTP Proxy

    looked everywhere wth this error means (really) and could not find

    Already put the lof debug until 5, no luck also

    if the return has an iso-8859-1, even with a preprocessor in place, gives an error

    Preprocessors I tried to convert the characters, the test of the preprocessor works, but the error persists

    ==> return value.replace(/ã/g,'a').replace(/ç/g,'c');
    ==> return unescape(encodeURIComponent(value));

    Preprocessors I tried just to extract part of the return (just to confirm the preprocessor was not working)

    ==> ^(?<=\<ns2:status>)(.*?)(?=\</ns2:status>)$
    ==> (?<=\<ns2:status>)(.*?)(?=\</ns2:status>)


    the logs show that,even with the preprocessing rule, when the ISO characters are not there, the data is inserted in the db, and processed, if not, is right away discarded like the rules are being completely ignored.

    there is 10 preprocessors processes started

    I am so frustrated
    Last edited by jilingkapoor; 26-05-2019, 19:15.

    Hi buddy, the solution is already live on this forum at:

    Hope this helps Tutuapp . ShowBox . Kodi .

    Last edited by sixigavi; 08-06-2019, 22:13.



    No announcement yet.