Announcement

Collapse
No announcement yet.

Zabbix Trapper Help

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Zabbix Trapper Help

    Hi, I've been trying to create a Zabbix Trapper item without success.
    This is what I have so far:

    Name: ThisIsATrap
    Type: Zabbix trapper
    Key: trap

    Allowed Hosts: <ip address of machine I am using zabbix_sender to attempt to send data to the trapper>
    Applications: General

    Then on my machine I am using zabbix_sender -z <ip address of zabbix server> -p 10051 -s "nameOfHostTrapperIsOn" -k trap -o 50

    I'm doing this zabbix_sender as a test to see if 50 is output on latest data, and when I run this command I get:

    sent: 1; skipped: 0; total: 1

    This is the only information received, and under latest data there is no data for 'trap' shown.

    Another thing is on my machine when I try and telnet the zabbix server ip address and port or ping it, I'm never able to ping/telnet successfuly.

    Is there any part of the configuration or zabbix_sender I am not understanding properly? Please let me know if there's any other information I can supply.

    #2
    Is the host monitored by a proxy? If so, use that for the zabbix-server address, not the main server.

    Do you have any "Allowed hosts" in the item definition?
    Last edited by LenR; 25-09-2015, 17:20.

    Comment


      #3
      There is no proxy. For Allowed Hosts I tried to add the ip addresses I was calling zabbix_sender from, but with no luck.

      Comment


        #4
        Any update on this? I'm having the exact same problem. Here's what I'm trying:

        Code:
        zabbix_sender -vv -z <ip of zabbix server> -p 10051 -s <ip of server sending key> -k key -o 10
        zabbix_sender [4188]: DEBUG: answer [{"response":"success","info":"processed: 0; failed: 1; total: 1; seconds spent: 0.000027"}]
        info from server: "processed: 0; failed: 1; total: 1; seconds spent: 0.000027"
        sent: 1; skipped: 0; total: 1
        I checked zabbix_server.log, but didn't find any entries from that server. I have this in server.conf:

        Code:
        ListenIP=0.0.0.0
        ListenPort=10051

        Comment


          #5
          @foreright360
          First in your command the -s is false -> s, --host <host>
          Specify host name as registered in Zabbix frontend. Host IP address and DNS name will not work.
          It has to be the hostname that you find on the web interface of Zabbix.

          I had the same problem, but in the zabbix sender command I added -c <path of your agent conf file> and -I <IP of the machine sending key>

          Comment

          Working...
          X