Upgrade Zabbix from 3.2.7 to 3.4

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Upgrade Zabbix from 3.2.7 to 3.4

    Hi all ,
    I am using zabbix and I decided to upgrade rpm package from 3.2.7 to 3.4
    I am trying to use rpm -upgrade zabbix , but it is not working
    i aslo try to install zabbix-release-3.4-1.el7.centos.noarch.rpm to upgrade repositey but I recive error :
    file /etc/yum.repos.d/zabbix.repo from install of zabbix-release-3.4-1.el7.centos.noarch conflicts with file from package zabbix-release-3.2-1.el7.noarch

    can anyone help me to update ?

    #2
    Please try update instead of install.

    Code:
    # yum update zabbix-release-3.4-1.el7.centos.noarch.rpm
    # yum clean all

    Comment


      #3
      Originally posted by omid1979 View Post
      Hi all ,
      I am using zabbix and I decided to upgrade rpm package from 3.2.7 to 3.4
      I am trying to use rpm -upgrade zabbix , but it is not working
      So what exactly is not working?
      http://uk.linkedin.com/pub/tomasz-k%...zko/6/940/430/
      https://kloczek.wordpress.com/
      zapish - Zabbix API SHell binding https://github.com/kloczek/zapish
      My zabbix templates https://github.com/kloczek/zabbix-templates

      Comment


        #4
        Thanks for your answer ,
        I do the flowing steps and now upgrade to Zabbix 3.4

        PHP Code:
        yum update http://repo.zabbix.com/......zabbix-release-3.4-1.el7.centos.noarch.rpm
        yum update zabbix-agent
        yum update zabbix
        -web
        yum update zabbix
        -server-mysql
        yum update zabbix
        -sender
        yum update zabbix
        -get
        yum update zabbix
        -java-gateway
        yum update zabbix
        -release-3.2-1.el7.noarch.rpm 
        systemctl restart zabbix
        -server 
        Thanks so much ,

        Comment


          #5
          Hi,

          I've followed that but it's just not doing any database upgrade i just get the "The frontend does not match Zabbix database. Current database version (mandatory/optional): 3020000/3020000. Required mandatory version: 3040000. Contact your system administrator."

          The logs are not saying it's doing the upgrade.

          Comment


            #6
            Originally posted by AlexYoung View Post
            Hi,

            I've followed that but it's just not doing any database upgrade i just get the "The frontend does not match Zabbix database. Current database version (mandatory/optional): 3020000/3020000. Required mandatory version: 3040000. Contact your system administrator."

            The logs are not saying it's doing the upgrade.
            This could take some time. What exactly logs are showing to you?

            Regards,
            Alex!

            Comment


              #7
              11543:20170929:102211.405 syncing trend data done
              11543:20170929:102211.405 Zabbix Server stopped. Zabbix 3.2.2 (revision 64245).
              12400:20170929:102222.320 Starting Zabbix Server. Zabbix 3.2.2 (revision 64245).
              12400:20170929:102222.320 ****** Enabled features ******
              12400:20170929:102222.320 SNMP monitoring: YES
              12400:20170929:102222.320 IPMI monitoring: NO
              12400:20170929:102222.320 Web monitoring: YES
              12400:20170929:102222.320 VMware monitoring: YES
              12400:20170929:102222.320 SMTP authentication: YES
              12400:20170929:102222.321 Jabber notifications: NO
              12400:20170929:102222.321 Ez Texting notifications: YES
              12400:20170929:102222.321 ODBC: NO
              12400:20170929:102222.321 SSH2 support: NO
              12400:20170929:102222.321 IPv6 support: YES
              12400:20170929:102222.321 TLS support: NO
              12400:20170929:102222.321 ******************************
              12400:20170929:102222.321 using configuration file: /usr/local/etc/zabbix_server.conf
              12400:20170929:102222.330 current database version (mandatory/optional): 03020000/03020000
              12400:20170929:102222.330 required mandatory version: 03020000
              12400:20170929:102223.460 server #0 started [main process]
              12405:20170929:102223.461 server #1 started [configuration syncer #1]
              12406:20170929:102223.461 server #2 started [db watchdog #1]

              so on my centos i've done the yum update on all the bits and its showing i've got 3.4 installed so bit unsure why this is staying at 3.2

              Comment


                #8
                Hi AlexYoung,
                The package of 3.4 is already installed, is not it?
                Please check if you installed version installed from source.
                Last edited by Atsushi; 30-09-2017, 04:29.

                Comment

                Announcement

                Collapse
                No announcement yet.
                Working...
                X