Ad Widget

Collapse

Not found NET-SNMP library

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Not found NET-SNMP library

    hi,
    i have error in configuration of Zabbix 1.6.1. I'm on Suse 10.0 and use net-snmp 5.3. I have problem on SNMP.See the problem:

    checking for net-snmp-config... /usr/bin/net-snmp-config
    checking for main in -lcrypto ... (cached) yes
    checking for main in -lm ... (cached) yes
    checking for main in -lwrap ... yes
    checking for main in -lcrypto ... (cached) yes
    checking for main in -lnetsnmp ... no
    configure: error: Not found NET-SNMP library

    I have tried other thread but i can't resolve the problem.
    my parameters are:
    ./configure --with-mysql --with-net-snmp --with-libcurl --enable-server --enable-static --prefix=/zabbix

    Someone can help me ??
    Thank you

    Ahui SIKA

    #2
    Do you have the net-snmp development libraries present?

    Comment


      #3
      Not found NET-SNMP library

      Thank you for your reply,

      net-snmp-devel is install

      see the response of: rpm -qa | grep snmp:

      net-snmp-devel-5.3.0.1-25.2
      net-snmp-5.3.0.1-25.2
      php5-snmp-5.1.2-29.5

      thank you

      Ahui SIKA

      Comment


        #4
        hi
        No body to help me ?

        Thank for help

        Ahui SIKA

        Comment


          #5
          Some people don't monitor these sites hour in hour out, so if you don't get a reply instantly, getting upset isn't going to help.

          Their should be a configure log file generated by the configuration script, which should give you a bit more information.

          Review the log file, and find the line where it checks for snmp, what does it say?

          Comment


            #6
            Execute command;
            $ net-snmp-config --libs

            You will see paths net-snmp library installed.
            And then check the symbolic link 'libnetsnmp.so' existance in those pathes directories.

            If libnetsnmp.so does not exist, make a symbolic link to physical file, named like libnetsnmp.so.10.X.X, in the directory.

            Comment


              #7
              i had the same problem

              I had the same problem.
              'libnetsnmp.so' exists in
              Code:
              ns1n:/usr/src/zabbix-1.6.1 # net-snmp-config --libs
              -L/usr/lib -lnetsnmp -lcrypto -lm -L/usr/lib -lwrap
              Code:
              ns1n:/usr/lib # ls -l | grep libnetsnmp.so
              lrwxrwxrwx   1 root root      20 Dec 11 15:00 libnetsnmp.so -> libnetsnmp.so.10.0.1
              lrwxrwxrwx   1 root root      20 Dec 11 15:00 libnetsnmp.so.10 -> libnetsnmp.so.10.0.1
              -rwxr-xr-x   1 root root  622080 Apr 24  2008 libnetsnmp.so.10.0.1
              Part of config.log:
              Code:
              ......
              configure:10604: checking for net-snmp-config
              configure:10622: found /usr/bin/net-snmp-config
              configure:10635: result: /usr/bin/net-snmp-config
              configure:10758: checking for main in -lnetsnmp 
              configure:10787: gcc -o conftest -g -O2   -I/usr/include/mysql -march=i586 -mtune=i686 -fmessage-length=0 -D_FORTIFY_SOURCE=2 -g -DPIC -fPIC -DUNDEF_HAVE_INITGROUPS -fno-strict-aliasing     -I/usr/include/rpm -I. -I/usr/include    -L/usr/lib -lnetsnmp -lcrypto -lm -L/usr/lib -lwrap -lcrypto conftest.c -lnetsnmp   -lm -lresolv   >&5
              /usr/lib/gcc/i586-suse-linux/4.1.2/../../../../i586-suse-linux/bin/ld: cannot find -lwrap
              collect2: ld returned 1 exit status
              configure:10793: $? = 1
              ......
              But then i installed tcpd-devel (tcp wrapper library) and problem was solved.

              Comment


                #8
                Originally posted by bondbig View Post
                ...

                But then i installed tcpd-devel (tcp wrapper library) and problem was solved.
                Man... you're simple the best... thanks!

                Comment


                  #9
                  For Debian:

                  apt-get install libsnmp-dev

                  Comment


                    #10
                    I have installed the apt-get install libsnmp-dev but i still can't make it work. I try to make snap-walk but apparently i don't have that command. Please somebody help me.

                    Thanks in advance!

                    Comment

                    Announcement

                    Collapse
                    No announcement yet.
                    Working...
                    X