Windows Agent - Error 1053

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Windows Agent - Error 1053

    Good Morning

    I just installed a Zabbix server (2.4) on Ubuntu. Everything is apparently well. I have access to the Zabbix console.

    I want to add a Windows 2012 server to make my first tests.
    I downloaded the 2.4.0 Agent for Windows,
    I proceeded to install
    zabbix_agentd.exe --install

    The service has been added.
    In the properties of the service, the path of the EXE file and CONF are good.

    When I want to start the service, I get a Windows error service could not be started. Error 1053: The service did not respond to the start or control request in a timely fashion.

    After some research, I could see that took the last FrameWork. I just did all available updates ... Nothing to do.

    I performed the same installation on an old 2003 server I had exactly the same problem. I'm looking, I see no way out.

    Could you help me?

    In the config file.
    Server = I put the IP address of my Zabbix server
    # ListenPort = 10050 allowed to comment?
    ServerActive = 127.0.0.1 Must be Zabbix server here?
    Hostname = my server name (server1) without domaine.com

    Thank you for your help

    #2
    Hi,

    Most likely this error is because of incorrect path to the configuration file. If you installed the service just by running "zabbix_agentd.exe --install" then most likely it will look for the config file in the C:\ directory.

    Here is how I install agent on my Windows:
    1. Create directory C:\Zabbix and place zabbix_agentd.exe and zabbix_agentd.win.conf files there.
    2. Edit the zabbix_agentd.win.conf file and set the values:
    Code:
    LogFile=C:\Zabbix\zabbix_agentd.log
    Server = IP address of your Zabbix server 
    # ListenPort = 10050 Leave it commented as is if you don't change the defaults
    ServerActive = IP of your Zabbix server
    Hostname = my server name (server1) without domaine.com
    3. Open command prompt and execute:
    Code:
    C:\Zabbix\zabbix_agentd.exe --config C:\Zabbix\zabbix_agentd.win.conf --install
    4. Start Windows service.

    If you have the agent service installed incorrectly now, you can remove it by running "zabbix_agentd.exe --uninstall".

    Please find more info here: https://www.zabbix.com/documentation.../windows_agent

    Hope this helps!

    Best Regards,
    Ingus

    Comment


      #3
      Hello,

      I have the same problem with a Windows server and followed your instructions. I still receive the service error no. 1035. I disabled the antivirus program and the firewall. Nevertheless I can't start the service. Other Windows servers don't have this problem. I can't find any differences, since I copied the config file from server to server. Any ideas else how to solve it?

      Comment


        #4
        If your config file has any scripts, like the hostname.item hack to get the fqdn via powershell, and that script fails or is very slow, you can get this error.

        Try starting the zabbix agent from the command so you can ensure that there are no errors.

        Comment


          #5
          The zabbix agent for Windows is useless. I've tried everything to get it going... with or without the config file it just will not start. Tried Server 2008, 2012, Windows 7 and 10.

          It leads me to believe there is something fundamentally flawed with the agent installer.

          Comment


            #6
            Originally posted by Exist2Resist View Post
            The zabbix agent for Windows is useless. I've tried everything to get it going... with or without the config file it just will not start. Tried Server 2008, 2012, Windows 7 and 10.
            Looks like a bug in the documentation. "Server=" is mandatory. Please have a look some details here (https://www.zabbix.com/forum/showpos...41&postcount=2).
            Last edited by Heilig; 24-08-2015, 10:27.

            Comment


              #7
              If you cannot start Zabbix agent, try to start it from a command line. Example:
              "C:\Program Files (x86)\Zabbix agent>zabbix_agentd.exe -c "C:\Program Files (x86) \Zabbix agent\zabbix_agentd.conf" -s"
              Latest agent will return more detailed error message. Try to start it in such way and paste error message here.

              Comment


                #8
                Originally posted by Heilig View Post
                If you cannot start Zabbix agent, try to start it from a command line. Example:
                "C:\Program Files (x86)\Zabbix agent>zabbix_agentd.exe -c "C:\Program Files (x86) \Zabbix agent\zabbix_agentd.conf" -s"
                Latest agent will return more detailed error message. Try to start it in such way and paste error message here.
                Thank you, as you specified in my previous post, I needed to set the "serveragents" parameter.

                Comment


                  #9
                  Zabbix 2.4 x64 agent

                  I have installed Zabbix in every shop i go to and consider myself pretty good at getting things running and using it... I install the server on ubuntu 14.04 with no problem and decided to do my agent testing on a windows 7 x64 box. I was not able to install the agent no matter what I tried. I decided to install the old 2.0.4 x64 agent that I have installed 100's of times and it did not work either. After much frustration I tried the 32bit agent and it worked like a champ... Do not want to do this here going forward but it seems that something has changed with the agent. I will try installing it on my 2012 boxes soon

                  Comment


                    #10
                    I opened up my config file with Notepad++ and it turned out that my hostname had part of the next line in it. It read something like Hostname={Myhost} ### Option: LogFile" all in one line. After fixing this I got the service to start. I never noticed this before because I used notepad to edit the config file initially.

                    Comment


                      #11
                      I have heard of that issue with notepad before... but I always use notepad++ and I do not see that issue in my conf file... To be honest I haven't tried to address that issue in a while... got another 100 or so agents installed since

                      Comment


                        #12
                        Originally posted by Heilig View Post
                        Looks like a bug in the documentation. "Server=" is mandatory. Please have a look some details here (https://www.zabbix.com/forum/showpos...41&postcount=2).
                        You are 100% correct and this is till the issue in 3.4.2.

                        Comment


                          #13
                          Let me rephrase that my phrase to avoid misunderstanding.

                          You must provide a value for "Server" parameter if you have default value for (# StartAgents=3). These "agents/processes" will listen Zabbix agent port and will accept (or not) incoming connections. To manage incoming connection, they must to know IPs which are allowed to connect to agent (i.e. "Server" which defines list of allowed IPs is mandatory in this situation).

                          If you would like to disable passive checks at all, just define "StartAgents=0". You can comment out "Server" parameter or leave empty value for it in this situation (i.e. "Server" is not mandatory in this situation).

                          Comment


                            #14
                            Error 1053 on Windows agent

                            At my installation on windows Server 2012R2 the problem was the following:

                            The Agent Zip-File cam with the con file zabbix_agentd.win.conf

                            But the Agent-Service was installed using a conf file named zabbix_agentd.conf

                            This led to the Error 1053 when starting the agent. Renaming the config file to zabbix_agentd.conf fixed the issue.

                            Hope this helps.

                            Comment


                              #15
                              Hi Guys,

                              In my case it was just a matter of a machine restart

                              Comment

                              Announcement

                              Collapse

                              Announcement

                              Meet Zabbix Dev Team at the Zabbix Summit 2018!
                              See more
                              See less
                              Working...
                              X