Announcement

Collapse
No announcement yet.

Zabbix Proxy - No data to server for monitored hosts

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Zabbix Proxy - No data to server for monitored hosts

    Hi Everyone.

    I'm hoping someone can help me figure out why the Zabbix server is not receiving data for the Hosts being monitored through the Zabbix Proxy.

    I was able to successfully get the proxy to work following these procedures:
    https://www.zabbix.com/documentation...y_installation

    The Zabbix server does see the hosts monitored through the proxy however there is no data being received.

    In reviewing the Zabbix-proxy log I noticed that there are failures that keeps coming up. They are as follows:

    End of get_host_availability_data():FAIL

    End of process_proxyconfig_table():FAIL

    End of get_hostid_by_host():FAIL

    send_list_of_active_checks_json() sending [{"response":"failed","info":"host [666762-db13] not found"}]

    failed to update local proxy configuration copy: invalid field name "hosts.tls_connect"

    Is this the reason I am not getting any data? I so how do I fix this. I noticed some topics in the forum however they have not fixed the issue.

    I hope someone can help.

    Thanks in advance.

    #2
    Originally posted by pmsilva View Post
    Hi Everyone.

    I'm hoping someone can help me figure out why the Zabbix server is not receiving data for the Hosts being monitored through the Zabbix Proxy.

    I was able to successfully get the proxy to work following these procedures:
    https://www.zabbix.com/documentation...y_installation

    The Zabbix server does see the hosts monitored through the proxy however there is no data being received.

    In reviewing the Zabbix-proxy log I noticed that there are failures that keeps coming up. They are as follows:

    End of get_host_availability_data():FAIL

    End of process_proxyconfig_table():FAIL

    End of get_hostid_by_host():FAIL

    send_list_of_active_checks_json() sending [{"response":"failed","info":"host [666762-db13] not found"}]

    failed to update local proxy configuration copy: invalid field name "hosts.tls_connect"

    Is this the reason I am not getting any data? I so how do I fix this. I noticed some topics in the forum however they have not fixed the issue.

    I hope someone can help.

    Thanks in advance.
    Please provide version of proxy and server

    Comment


      #3
      Hi VSO,

      Thank you for your reply. As I am very new to Linux and Zabbix it can only tell you that I have Zabbix server 3.2.6 installed.

      As for the proxy. I am not sure what version is installed following the direction in the Zabbix 3.2 manual.

      I executed the following command to retrieve the proxy as stated in the manual

      # apt-get install zabbix-proxy-mysql.

      From here I am not sure how to find the version #. Since the command is in the 3.2 manual I would presume that it is Zabbix Proxy 3.2. I can be completely wrong though.


      Update_________________________-

      I was able to find that the Proxy is running a older version

      [email protected]:/etc/init.d# zabbix_proxy -V
      Zabbix proxy v2.4.7 (revision 56694) (12 November 2015)
      Compilation time: Jun 28 2016 00:03:29

      I'm not sure how 2.4.7 was installed when I was following the 3.2 manual instructions. How do I get zabbix-proxy 3.2?
      Last edited by pmsilva; 13-09-2017, 15:44. Reason: Updated note

      Comment


        #4
        Update---------------------------

        I was able to upgrade the proxy version using this procedure

        https://www.zabbix.com/documentation.../debian_ubuntu

        I executed this command to upgrade

        # apt-get install --only-upgrade zabbix-server-mysql

        I am now running version 3.2.7.

        [email protected]:~# zabbix_proxy -V
        zabbix_proxy (Zabbix) 3.2.7
        Revision 70298 18 July 2017, compilation time: Jul 18 2017 16:33:42

        Copyright (C) 2017 Zabbix SIA
        License GPLv2+: GNU GPL version 2 or later <http://gnu.org/licenses/gpl.html>.
        This is free software: you are free to change and redistribute it according to
        the license. There is NO WARRANTY, to the extent permitted by law.
        [email protected]:~#

        It has considerably reduced the amount of errors in the log however one keeps coming up

        End of get_host_availability_data():FAIL

        On the Zabbix server side. I can now see that the monitored HOST is now RED for the Zabbix agent with the following error

        "Get Value from agent Failed: Cannot connect to...................."
        Last edited by pmsilva; 13-09-2017, 17:50. Reason: spelling erro

        Comment


          #5
          Are you sure the zabbix agent is running on the host you're trying to monitor? Is port 10050 open in the firewall on the host you're trying to monitor?

          Comment


            #6
            That was exactly my issue. I had the port set to 10051. Changed it to 10050.

            Everything is working now.

            Thanks for all you help

            Comment


              #7
              Monitor Servers in other Subnets behind a Firewall

              Hello,
              I need to monitor servers and network equipment that are in other subnets. How can I do it. All subnets are behind a firewall.

              Zabbix 3.4.1

              AK

              Comment

              Working...
              X