Ad Widget

Collapse

Error: ZBX_TCP_READ() failed [Interrupted system call] ; zabbix-agent1.4.4 is broken

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Error: ZBX_TCP_READ() failed [Interrupted system call] ; zabbix-agent1.4.4 is broken

    I spent several hours yesterday trying to get the zabbix agent to work. I am running FreeBSD7-RC1 amd64, and used the zabbix agent from ports.

    When the server tried to poll the agent, it would return:
    Error: ZBX_TCP_READ() failed [Interrupted system call]

    The agent log showed no sign of a connection even with full debug turned on. A TCPdump showed the TCP connection complete, but then die off.

    The version that came from ports was zabbix-agent-1.4.4

    After spending hours on this and getting no where, I uninstalled the agent, and then reinstalled the pre-compiled binary from pkg_add. This gave me version zabbix-agent-1.4.2. I started it up, and instantly it started working.

    zabbix-agent-1.4.4 from ports does not work. Use zabbix-agent-1.4.2 from pkg_add -r instead.

    Someone else had the same exact problem on the IRC channel this morning and this worked for them too.

    #2
    Had the same problem here with the agent from ports on FreeBSD 6.2. I then installed the pre-compiled from the downloads and that one works fine.

    Comment


      #3
      This problem as been seen in this thread too: http://www.zabbix.com/forum/showthread.php?t=8843

      Please indicate the OS name/version in your thread name.

      Can someone fill a bug report?
      Last edited by elgoretto; 12-02-2008, 16:35.

      Comment


        #4
        Can someone confirm that this is a 1.4.4 agent-related issue? Alexei?

        I can just say that I've had this error quite frequently in the past, and USUALLY it's something on the client end that is not right: log file isn't owned by zabbix or log file fills up and the directory that the log writes to isn't owed by zabbix or in that group that zabbix resides. Ummm...what else...Perhaps the host is set to connect as a DNS name and the DNS name isn't correct, or the IP address isn't accurate?

        My problem appears to be firewall-related I believe. I am able to establish connectivity and my agents are reachable, however, after a period of time, that the agent becomes unreachable; at which time I restart the agent and it seems to reestablish connectivity with the server again.

        I ran a tcpdump from my server to one of my agents and the communication didn't seem to work the same as it does as if an agent were to reside on the same physical subnet as the server. It appears packets are getting lost somehow.

        Can anyone tell me if they've had similar problems?
        Last edited by cbidwell; 12-02-2008, 18:25.

        Comment


          #5
          @cbidwell: please open your own thread, as it appears you have a different problem than the one that is discussed here.
          However, my hosts are spread in different subnets too (without FW between them), and I've other problems that are not systematic if monitored hosts are in a different subnet than zabbix server.

          Comment


            #6
            I encountered exactly the same ZBX_TCP_READ() error on my fresh installation of zabbix on freebsd.

            I had the server all going and then i compiled the agent from ports and the agent would refuse to talk to the server at all.

            Googling lead me to this thread and so I followed the posters advice to deinstall and use the pkg version and it worked.

            On the other hand I used the precompiled 1.4.4 agent for win32 on a w2k3 server and although I had initial problems with it (it was causing a child process to die on zabbix making the entire server daemons go "defunct") I somehow got it working anyway.

            Seems to be problems on 1.4.4 agentd

            Comment


              #7
              Up.

              I'm quite disappointed by the fact that (I must be cursed) every problem (except one finally after having done 4 or 5 "up" of the thread, one per month) I encounter with Zabbix just end up with the post slowly sliding out of sight and no one from the Zabbix team acknowledging our report.

              Has Zabbix too many users that forum and their owner can't cope with our bug reports?

              Comment


                #8
                Well, the message "Error: ZBX_TCP_READ() failed [Interrupted system call]" does not indicate that you have a problems that has to be fixed. It is just a normal message indicating that a timeout has happened. You may see lots of such messages on a busy system.

                I hardly believe there is a bug. However the agent log file with Debug=4 may change my mind.

                Please do not expect ZABBIX staff to jump and troubleshoot all problems posted in ZABBIX forums. This is not what ZABBIX Forums are created for!
                Alexei Vladishev
                Creator of Zabbix, Product manager
                New York | Tokyo | Riga
                My Twitter

                Comment


                  #9
                  Well from my perspective, I installed the ports version and it didn't work...

                  then I used the pkg version with the same configuration file and it does work.

                  From the initial outset it looks like there is a problem with the ports 1.4.4

                  Comment


                    #10
                    Originally posted by KamiCrazy View Post
                    From the initial outset it looks like there is a problem with the ports 1.4.4
                    If so, this is something out of our control...
                    Alexei Vladishev
                    Creator of Zabbix, Product manager
                    New York | Tokyo | Riga
                    My Twitter

                    Comment


                      #11
                      Thanks. Problem fixed in rev. 5497
                      ZABBIX Developer
                      Riga, Latvia

                      Comment


                        #12
                        I'm having almost the same problem and I posted in another thread already. Instead of read, I get write.

                        Here is a copy and paste:
                        The problem is.... I'm getting the below errors in my error logs, and when I check latest data, it's not getting a value at all for the DNS item. When I run the script at the command line it gives me a 1, which is correct.

                        4608:20080707:154427 Run remote command [php /etc/zabbix/alert.d/dnschk.php 192.168.2.1] Result [1] [1]...
                        4608:20080707:154427 Sending back [1]
                        4608:20080707:154427 Got SIGPIPE. Where it came from???
                        4608:20080707:154427 Process listener error: ZBX_TCP_WRITE() failed [Broken pipe]

                        It looks like it's dieing when it's sending it back. But the logs continue on with all of the other checks.

                        It's quite strange, everything else works. I am running debian etch 4.0 on all production servers except the 2 zabbix servers we have. I'm running Ubuntu 8.04 so I could get the latest Zabbix without compiling it myself. I thought it was permissions so I set the file to zabbix:www-data and still no go. Yes I have it executable, but it doesn't matter cause it runs the script with php in front of it anyways. The file is in /etc/zabbix/alert.d/dnschk.php
                        I also set the zabbix-agentd.conf on that machine to: EnableRemoteCommands=1 but still get that error. Anybody have an idea??? I have tried stopping, waiting, then starting back up. I even did a killall zabbix-agentd which did kill them all but after starting the agent back up, same error occured.

                        Here is the line I have in the zabbix_agentd.conf:
                        UserParameter=DNS1,php /etc/zabbix/alert.d/dnschk.php 192.168.2.1

                        Ideas? The script is running, it's getting a value but the agent on the machine can't send it back to the server. I can telnet on port 10050 and 10051 from that box to the zabbix server, so it's not firewall. The agent can send back every other item. Attached is the script. If you need any more info, just let me know. Thanks guys.

                        Here are screen shots of my item and trigger.

                        Here is the item:


                        Here is the trigger:
                        Attached Files

                        Comment

                        Announcement

                        Collapse
                        No announcement yet.
                        Working...
                        X