Zabbix Documentation 4.2

2.23.04.04.2 (current)In development:4.4 (devel)Unsupported:1.82.02.43.23.4

User Tools

Site Tools


ru:manual:installation:containers

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
ru:manual:installation:containers [2018/07/07 08:10]
127.0.0.1 external edit
ru:manual:installation:containers [2019/02/11 09:25] (current)
martins-v fixing typos
Line 49: Line 49:
   * ''​alpine-latest''​ - последняя стабильная версия Zabbix компоненты на основе образа Alpine Linux   * ''​alpine-latest''​ - последняя стабильная версия Zabbix компоненты на основе образа Alpine Linux
   * ''​ubuntu-latest''​ - последняя стабильная версия Zabbix компоненты на основе образа Ubuntu   * ''​ubuntu-latest''​ - последняя стабильная версия Zabbix компоненты на основе образа Ubuntu
-  * ''​alpine-3.4-latest''​ - последняя минорная версия Zabbix ​3.4 компоненты на основе образа Alpine Linux +  * ''​alpine-4.0-latest''​ - последняя минорная версия Zabbix 4.0 компоненты на основе образа Alpine Linux 
-  * ''​ubuntu-3.4-latest''​ - последняя минорная версия Zabbix ​3.4 компоненты на основе образа Ubuntu +  * ''​ubuntu-4.0-latest''​ - последняя минорная версия Zabbix 4.0 компоненты на основе образа Ubuntu 
-  * ''​alpine-3.4.*''​ - различные минорные версии Zabbix ​3.4 компоненты на основе образа Alpine Linux, где ''​*''​ - минорная версия Zabbix компоненты +  * ''​alpine-4.0.*''​ - различные минорные версии Zabbix 4.0 компоненты на основе образа Alpine Linux, где ''​*''​ - минорная версия Zabbix компоненты 
-  * ''​ubuntu-3.4.*''​ - различные минорные версии Zabbix ​3.4 компоненты на основе образа Ubuntu, где ''​*''​ - минорная версия Zabbix компоненты+  * ''​ubuntu-4.0.*''​ - различные минорные версии Zabbix 4.0 компоненты на основе образа Ubuntu, где ''​*''​ - минорная версия Zabbix компоненты
  
 === Использование === === Использование ===
Line 245: Line 245:
 Имеется несколько различных версий файлов наборов:​ Имеется несколько различных версий файлов наборов:​
 |  **Имя файла** ​ |  **Описание** ​ | |  **Имя файла** ​ |  **Описание** ​ |
-|''​docker-compose_v3_alpine_mysql_latest.yaml''​|Файл набора запускает последнюю версию компонент Zabbix ​3.4 на Alpine Linux с поддержкой MySQL базы данных. | +|''​docker-compose_v3_alpine_mysql_latest.yaml''​|Файл набора запускает последнюю версию компонент Zabbix 4.0 на Alpine Linux с поддержкой MySQL базы данных. | 
-|''​docker-compose_v3_alpine_mysql_local.yaml''​|Файл набора собирает локально последнюю версию Zabbix ​3.4 и запускает компоненты Zabbix на Alpine Linux с поддержкой MySQL базы данных. | +|''​docker-compose_v3_alpine_mysql_local.yaml''​|Файл набора собирает локально последнюю версию Zabbix 4.0 и запускает компоненты Zabbix на Alpine Linux с поддержкой MySQL базы данных. | 
-|''​docker-compose_v3_alpine_pgsql_latest.yaml''​|Файл набора запускает последнюю версию компонент Zabbix ​3.4 на Alpine Linux с поддержкой PostgreSQL базы данных.| +|''​docker-compose_v3_alpine_pgsql_latest.yaml''​|Файл набора запускает последнюю версию компонент Zabbix 4.0 на Alpine Linux с поддержкой PostgreSQL базы данных.| 
-|''​docker-compose_v3_alpine_pgsql_local.yaml''​|Файл набора собирает локально последнюю версию Zabbix ​3.4 и запускает компоненты Zabbix на Alpine Linux с поддержкой PostgreSQL базы данных.| +|''​docker-compose_v3_alpine_pgsql_local.yaml''​|Файл набора собирает локально последнюю версию Zabbix 4.0 и запускает компоненты Zabbix на Alpine Linux с поддержкой PostgreSQL базы данных.| 
-|''​docker-compose_v3_centos_mysql_latest.yaml''​|Файл набора запускает последнюю версию компонент Zabbix ​3.4 на CentOS 7 с поддержкой MySQL базы данных. | +|''​docker-compose_v3_centos_mysql_latest.yaml''​|Файл набора запускает последнюю версию компонент Zabbix 4.0 на CentOS 7 с поддержкой MySQL базы данных. | 
-|''​docker-compose_v3_centos_mysql_local.yaml''​|Файл набора собирает локально последнюю версию Zabbix ​3.4 и запускает компоненты Zabbix на CentOS 7 с поддержкой MySQL базы данных. | +|''​docker-compose_v3_centos_mysql_local.yaml''​|Файл набора собирает локально последнюю версию Zabbix 4.0 и запускает компоненты Zabbix на CentOS 7 с поддержкой MySQL базы данных. | 
-|''​docker-compose_v3_centos_pgsql_latest.yaml''​|Файл набора запускает последнюю версию компонент Zabbix ​3.4 на CentOS 7 с поддержкой PostgreSQL базы данных.| +|''​docker-compose_v3_centos_pgsql_latest.yaml''​|Файл набора запускает последнюю версию компонент Zabbix 4.0 на CentOS 7 с поддержкой PostgreSQL базы данных.| 
-|''​docker-compose_v3_centos_pgsql_local.yaml''​|Файл набора собирает локально последнюю версию Zabbix ​3.4 и запускает компоненты Zabbix на CentOS 7 с поддержкой PostgreSQL базы данных.| +|''​docker-compose_v3_centos_pgsql_local.yaml''​|Файл набора собирает локально последнюю версию Zabbix 4.0 и запускает компоненты Zabbix на CentOS 7 с поддержкой PostgreSQL базы данных.| 
-|''​docker-compose_v3_ubuntu_mysql_latest.yaml''​|Файл набора запускает последнюю версию компонент Zabbix ​3.4 на Ubuntu 14.04 с поддержкой MySQL базы данных.| +|''​docker-compose_v3_ubuntu_mysql_latest.yaml''​|Файл набора запускает последнюю версию компонент Zabbix 4.0 на Ubuntu 14.04 с поддержкой MySQL базы данных.| 
-|''​docker-compose_v3_ubuntu_mysql_local.yaml''​|Файл набора собирает локально последнюю версию Zabbix ​3.4 и запускает компоненты Zabbix на Ubuntu 14.04 с поддержкой MySQL базы данных.| +|''​docker-compose_v3_ubuntu_mysql_local.yaml''​|Файл набора собирает локально последнюю версию Zabbix 4.0 и запускает компоненты Zabbix на Ubuntu 14.04 с поддержкой MySQL базы данных.| 
-|''​docker-compose_v3_ubuntu_pgsql_latest.yaml''​|Файл набора запускает последнюю версию компонент Zabbix ​3.4 на Ubuntu 14.04 с поддержкой PostgreSQL базы данных.| +|''​docker-compose_v3_ubuntu_pgsql_latest.yaml''​|Файл набора запускает последнюю версию компонент Zabbix 4.0 на Ubuntu 14.04 с поддержкой PostgreSQL базы данных.| 
-|''​docker-compose_v3_ubuntu_pgsql_local.yaml''​|Файл набора собирает локально последнюю версию Zabbix ​3.4 и запускает компоненты Zabbix на Ubuntu 14.04 с поддержкой PostgreSQL базы данных.|+|''​docker-compose_v3_ubuntu_pgsql_local.yaml''​|Файл набора собирает локально последнюю версию Zabbix 4.0 и запускает компоненты Zabbix на Ubuntu 14.04 с поддержкой PostgreSQL базы данных.|
  
 <note important>​Доступные файлы наборов Docker поддерживают как версию 2, так и версию 3 Docker Compose.</​note>​ <note important>​Доступные файлы наборов Docker поддерживают как версию 2, так и версию 3 Docker Compose.</​note>​
Line 268: Line 268:
 === Файлы окружения === === Файлы окружения ===
  
-В той же директории с файлами наборов на github.com вы можете найти файы с переменными окружения по умолчанию для какждой компоненты из файла наборов. Этип файлы окружения называются примерно так ''​.env_<​тип компоненты>''​.+В той же директории с файлами наборов на github.com вы можете найти файы с переменными окружения по умолчанию для какждой компоненты из файла наборов. Эти файлы окружения называются примерно так ''​.env_<​тип компоненты>''​.
  
 === Примеры === === Примеры ===
Line 278: Line 278:
 </​code>​ </​code>​
  
-Эта команда загрузит последние образы Zabbix ​3.4 для каждой Zabbix компоненты и затем запустит их в detach режиме.+Эта команда загрузит последние образы Zabbix 4.0 для каждой Zabbix компоненты и затем запустит их в detach режиме.
  
 <note important>​Не забудьте загрузить ''​.env_<​тип компонента>''​ файлы с github.com официального репозитория Zabbix вместе с файлами наборов.</​note>​ <note important>​Не забудьте загрузить ''​.env_<​тип компонента>''​ файлы с github.com официального репозитория Zabbix вместе с файлами наборов.</​note>​
Line 288: Line 288:
 </​code>​ </​code>​
  
-Эта команда загрузит базовый образ Ubuntu 14.04, затем соберет Zabbix ​3.4 компоненты локально и запустит их в detach режиме.+Эта команда загрузит базовый образ Ubuntu 14.04, затем соберет Zabbix 4.0 компоненты локально и запустит их в detach режиме.