Zabbix Documentation 2.4

3.04.04.2 (current)In development:4.4 (devel)Unsupported:1.82.02.22.43.23.4

User Tools

Site Tools


Sidebar

ru:manual:appendix:compatibility

11 Совместимость версий

Поддерживаемые агенты

С Zabbix 2.4 можно всё еще использовать старые версии агентов начиная с Zabbix 1.x и предыдущие версии Zabbix 2.x. Никаких изменений конфигурации на стороне агента не потребуется.

Однако, чтобы воспользоваться всеми преимуществами новых и улучшенных элементов данных, улучшенной производительности и уменьшенным использованием памяти, используйте последнюю версию агента 2.4.

Поддерживаемые Zabbix прокси

С Zabbix сервером можно использовать только Zabbix 2.4 прокси. Zabbix 1.6, 1.8, 2.0 и 2.2 прокси не поддерживаются Zabbix 2.4 сервером.

Zabbix 2.4 прокси можно использовать только с Zabbix 2.4 сервером. Они не будут работать с 2.2 или более старыми версиями Zabbix сервера.

Поддержка XML файлов

XML файлы, экспортированные в версиях 1.8, 2.0 и 2.2, поддерживаются при импорте в версию Zabbix 2.4.

В XML формате Zabbix 1.8 при экспорте, зависимости триггеров сортируются только по названию. Если имеется несколько триггеров с одинаковым именем (например, имеющие разные важности и выражения), которые имеют заданную зависимость между собой, то их невозможно импортировать. Такие зависимости должны быть удалены вручную из файла XML и добавлены после импорта.