General Information

Sidebar

packages

Zabbix Packages

Here you can find some general information regarding Zabbix packages.

Support By Platform

Distribution 5.2 5.0 LTS 4.0 LTS 3.0 LTS
RHEL/CentOS 8 Yes Yes Yes Agent Only
RHEL/CentOS 7 Agent & Proxy(5) Frontend SCL(1)(5) Yes Yes
RHEL/CentOS 6 Agent Only Agent Only Agent & Proxy Agent & Proxy
RHEL/CentOS 5 Agent Only Agent Only Agent & Proxy Agent & Proxy
SLES 15 Yes Yes Yes Yes
SLES 12(3) SP4+(3) SP4+(3) SP4+(3) SP4+(3)
Debian 10 (Buster) Yes Yes Yes Yes
Debian 9 (Stretch) Agent Only Deprecated Frontend(2) Yes Yes
Debian 8 (Jessie) Agent Only Agent & Proxy(5) Yes Yes
Ubuntu 20.04 (Focal) Yes Yes Yes No
Ubuntu 18.04 (Bionic) Yes Yes Yes Yes
Ubuntu 16.04 (Xenial) Agent Only Deprecated Frontend(2) Yes Yes
Ubuntu 14.04 (Trusty) Agent Only Deprecated Frontend(2) Yes Yes
Raspbian 10 (Buster)(4) Yes Yes Yes No
Raspbian 9 (Stretch)(4) Agent Only Deprecated Frontend(2) Yes Yes

(1) Frontend SCL
Zabbix 5.0 frontend packages on RHEL/Centos 7 depend on PHP 7.2 from Red Hat Software Collections. Extra attention is required when installing and especially when making upgrades from previous versions. Refer to Zabbix 5.0 documentation.

(2) Deprecated Frontend
Zabbix 5.0 frontend packages for old Debian-based systems have been deprecated. Refer to respective documentation page.

(3) SLES 12 SP4+
Zabbix packages for SUSE Linux Enterprise Server 12 are supported for service pack 4 an newer due to openssl version incompatibility.

(4) Raspbian Limited Support
Agent2 and Java Gateway packages are not supported on Raspberry Pi.

(5) Missing features due to old distro
Expect certain features to be broken or missing due to old system packages.