Documentation

Zabbix Packages

Here you can find some general information regarding Zabbix packages.

Support By Platform

Distribution 6.2 6.0 LTS 5.0 LTS 4.0 LTS
RHEL/CentOS 9 Yes Yes Agent Only No
RHEL/CentOS 8 Yes Yes Yes Yes
RHEL/CentOS 7 Agent & Proxy Agent & Proxy Frontend SCL(1)(4) Yes
RHEL/CentOS 6 Agent Only Agent Only Agent Only Agent & Proxy
RHEL/CentOS 5 Agent Only Agent Only Agent Only Agent & Proxy
SLES 15 Yes Yes Yes Yes
SLES 12(3) SP4+(3) SP4+(3) SP4+(3) SP4+(3)
Debian 11 (Bullseye) Yes Yes Yes Yes
Debian 10 (Buster) Agent & Proxy Yes Yes Yes
Debian 9 (Stretch) Agent Only Agent Only Deprecated Frontend(2) Yes
Debian 8 (Jessie) No No Agent Only Agent & Proxy(4)
Ubuntu 22.04 (Jammy) Yes Yes Agent & Proxy Agent & Proxy
Ubuntu 20.04 (Focal) Yes Yes Yes Yes
Ubuntu 18.04 (Bionic) Agent & Proxy Yes Yes Yes
Ubuntu 16.04 (Xenial) Agent Only Agent Only Deprecated Frontend(2) Yes
Ubuntu 14.04 (Trusty) Agent Only Agent Only Deprecated Frontend(2) Yes
Raspbian 10 (Buster) Agent & Proxy Yes Yes Yes
Raspbian 9 (Stretch) Agent Only Agent Only Deprecated Frontend(2) Yes

(1) Frontend SCL
Zabbix 5.0 frontend packages on RHEL/Centos 7 depend on PHP 7.2 from Red Hat Software Collections. Extra attention is required when installing and especially when making upgrades from previous versions. Refer to Zabbix 5.0 documentation.

(2) Deprecated Frontend
Zabbix 5.0 frontend packages for old Debian-based systems have been deprecated. Refer to respective documentation page.

(3) SLES 12 SP4+
Zabbix packages for SUSE Linux Enterprise Server 12 are supported for service pack 4 an newer due to openssl version incompatibility.

(4) Missing features due to old distro
Expect certain features to be broken or missing due to old system packages.