Ad Widget

Collapse

Zabbix 5.0 не работает протокол snmp v1

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Zabbix 5.0 не работает протокол snmp v1

    После обновления Zabbix, перестал работать протокол snmp v1. Все устройства опрашиваемые по протоколу v2c и v3 работают без проблем. Mib файлы обновлены. Snmptranslate по OID находит MIB файл. Snmpwalk при установке v1 так же отрабатывает корректно, как и snmpget. В версии Zabbix 4.4 при создании элемента данных, можно было указать вручную тип протокола. В новой же версии, такой возможности нет. подскажите, что делать?

    #2
    Теперь настройка на другом уровне
    https://www.zabbix.com/documentation...nterface_level

    Comment


      #3
      Originally posted by Hamardaban View Post
      Теперь настройка на другом уровне
      https://www.zabbix.com/documentation...nterface_level
      Спасибо. Странно, что при обновлении эти настройки сбросились... Хотя в принципе не мешало бы и инструкцию по установке обновить. Теперь php нужно ставить не так , как для версии 4.4.
      Last edited by Steal; 20-05-2020, 18:41.

      Comment


        #4
        Т.е. если по каким-то причинам у меня есть итемы с разными версиями snmp, то при обновлении не будет установлена версия для хоста в минимальную и всё придётся править руками? ничёсе...

        Comment


          #5
          sles, у вас у одного хоста есть айтемы с разными версиями snmp?

          Comment


            #6
            Да, бывает и такое. У меня например есть устройство которое мониторится (read) по v2c , а управляется (write) по v3.
            И в элементах данных присутствует пробник “доступности” v3.

            Comment


              #7
              Originally posted by wins View Post
              sles, у вас у одного хоста есть айтемы с разными версиями snmp?
              уверен, что есть, за столько лет накопилось что попало.
              баг кто-нибудь репортил? оно ж закрывает путь к обновлению...

              Comment


                #8
                Совсем не закрывает! В описании изменений всё четко написано. А то, что не прочитал и перед обновлением не учел такую ситуацию - увы не баг.

                Comment


                  #9
                  Originally posted by Hamardaban View Post
                  Совсем не закрывает! В описании изменений всё четко написано. А то, что не прочитал и перед обновлением не учел такую ситуацию - увы не баг.
                  правильная реализация по неправильному техзаданию- тоже баг :-)
                  в заббиксе оно часто бывает.
                  завтра, если не лень будет, нарисую багрепорт.

                  Comment

                  Announcement

                  Collapse
                  No announcement yet.
                  Working...
                  X