ru:manual:installation:requirements

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
ru:manual:installation:requirements [2019/12/04 04:48]
127.0.0.1 external edit
ru:manual:installation:requirements [2019/12/17 02:15] (current)
dotneft
Line 53: Line 53:
 |//​Oracle// ​ |10g или более новая ​ |Требуется,​ если Oracle используется как основная база данных Zabbix'​а. ​ | |//​Oracle// ​ |10g или более новая ​ |Требуется,​ если Oracle используется как основная база данных Zabbix'​а. ​ |
 |//​PostgreSQL// ​ |8.1 или более новая ​ |Требуется,​ если PostgreSQL используется как основная база данных Zabbix'​а.\\ Предлагаем использовать PostgreSQL по крайней мере версии 8.3, который [[http://​www.postgresql.org/​docs/​8.3/​static/​release-8-3.html|показывает очень хорошую производительность VACUUM]]. ​ | |//​PostgreSQL// ​ |8.1 или более новая ​ |Требуется,​ если PostgreSQL используется как основная база данных Zabbix'​а.\\ Предлагаем использовать PostgreSQL по крайней мере версии 8.3, который [[http://​www.postgresql.org/​docs/​8.3/​static/​release-8-3.html|показывает очень хорошую производительность VACUUM]]. ​ |
 +|//​TimescaleDB// ​ |1.0 или более новая,​\\ OSS (бесплатная) версия ​ |Требуется,​ если TimescaleDB используется как основная база данных Zabbix'​а. ​ |
 |//IBM DB2//  |9.7 или более новая ​ |Требуется,​ если IBM DB2 используется как основная база данных Zabbix'​а. ​ | |//IBM DB2//  |9.7 или более новая ​ |Требуется,​ если IBM DB2 используется как основная база данных Zabbix'​а. ​ |
 |//​SQLite// ​ |3.3.5 или более новая ​ |Поддерживается только на стороне Zabbix прокси. Требуется,​ если SQLite используется базой данных Zabbix прокси. | |//​SQLite// ​ |3.3.5 или более новая ​ |Поддерживается только на стороне Zabbix прокси. Требуется,​ если SQLite используется базой данных Zabbix прокси. |
  
-<note important>​Поддержка IBM DB2 является экспериментальной!</​note>​+<note important>​Поддержка IBM DB2 и TimescaleDB ​является экспериментальной!</​note>​
  
 == Веб-интерфейс == == Веб-интерфейс ==
Line 66: Line 67:
 |//​PHP// ​ |5.4.0 или более поздняя | | |//​PHP// ​ |5.4.0 или более поздняя | |
 ^  Расширения PHP:  ||| ^  Расширения PHP:  |||
-|//​gd// ​ |2.0 или более поздняя ​ |Расширение PHP GD должен поддерживать формат PNG (//<​nowiki>​--with-png-dir</​nowiki>//​),​ JPEG (//<​nowiki>​--with-jpeg-dir</​nowiki>//​) изображения и FreeType 2 (//<​nowiki>​--with-freetype-dir</​nowiki>//​).|+|//​gd// ​ |2.0.28 или более поздняя ​ |Расширение PHP GD должен поддерживать формат PNG (//<​nowiki>​--with-png-dir</​nowiki>//​),​ JPEG (//<​nowiki>​--with-jpeg-dir</​nowiki>//​) изображения и FreeType 2 (//<​nowiki>​--with-freetype-dir</​nowiki>//​).|
 |//​bcmath// ​ | |php-bcmath (//<​nowiki>​--enable-bcmath</​nowiki>//​) | |//​bcmath// ​ | |php-bcmath (//<​nowiki>​--enable-bcmath</​nowiki>//​) |
 |//​ctype// ​ |  |php-ctype (//<​nowiki>​--enable-ctype</​nowiki>//​) ​ |  |//​ctype// ​ |  |php-ctype (//<​nowiki>​--enable-ctype</​nowiki>//​) ​ | 
Line 106: Line 107:
 |//​libssh2// ​ |:::| Требуется для поддержки SSH. Версия 1.0 или более новая.| |//​libssh2// ​ |:::| Требуется для поддержки SSH. Версия 1.0 или более новая.|
 |//​fping// ​ |:::| Требуется для [[ru:​manual:​config:​items:​itemtypes:​simple_checks#​icmp_пинг|элементов данных ICMP пинг]].| |//​fping// ​ |:::| Требуется для [[ru:​manual:​config:​items:​itemtypes:​simple_checks#​icmp_пинг|элементов данных ICMP пинг]].|
-|//​​libcurl//​ ​    |:::| Требуется для веб-мониторинга,​ мониторинга VMware ​и для SMTP аутентификации,​ ''​​web.page.*''​​ Zabbix агент [[:​ru/​manual/​config/​items/​itemtypes/​zabbix_agent|элементов данных]],​ элементов данных HTTP агента и Elasticsearch (если используется). Рекомендуется версия 7.28.0 или новее.\\ Требования к версии Libcurl:\\ - SMTP аутентификация:​ версия ​7.20.0 или новее\\ - Elasticsearch:​ версия ​7.28.0 или новее ​ |+|//​​libcurl//​ ​    |:::| Требуется для веб-мониторинга,​ мониторинга VMwareдля SMTP аутентификации,​ ''​​web.page.*''​​ Zabbix агент [[:​ru/​manual/​config/​items/​itemtypes/​zabbix_agent|элементов данных]],​ элементов данных HTTP агента и Elasticsearch (если используется). Рекомендуется версия 7.28.0 или новее.\\ Требования к версии Libcurl:\\ - SMTP аутентификация:​ версия ​7.20.0 или новее\\ - Elasticsearch:​ версия ​7.28.0 или новее ​ |
 |//​libiksemel// ​ |:::| Требуется для поддержки Jabber.| |//​libiksemel// ​ |:::| Требуется для поддержки Jabber.|
 |//​​libxml2//​ ​ |:::| Требуется для мониторинга VMware и XML XPath предобработки. ​ | |//​​libxml2//​ ​ |:::| Требуется для мониторинга VMware и XML XPath предобработки. ​ |
Line 185: Line 186:
  
 Очень важно иметь точную дату и время системы на сервере с запущенным Zabbix. [[http://​www.ntp.org/​|ntpd]] один из наиболее популярных демонов синхронизации времени хоста с временем на остальных серверах. Настоятельно рекомендуется поддерживать синхронизированное время на всех системах,​ где работают Zabbix компоненты. Очень важно иметь точную дату и время системы на сервере с запущенным Zabbix. [[http://​www.ntp.org/​|ntpd]] один из наиболее популярных демонов синхронизации времени хоста с временем на остальных серверах. Настоятельно рекомендуется поддерживать синхронизированное время на всех системах,​ где работают Zabbix компоненты.
-