Announcement

Collapse
No announcement yet.

Ayuda !! Por favor problema con el servidor

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Ayuda !! Por favor problema con el servidor

    Buen dia ente todo, soy novato con zabbix y debo instalarlo para cuestiones de mi tesis a parte de ser algo novato aun con linux .. mi problema es el siguiente:

    1- al entrar al servidor en la pagina principal no veo actividad entre el agente y servidor local , Zabbix server is running value NO ...

    no comprendo porque el NO ya que se supone que hice todo lo debido en la instalación

    Agradeciendo de antemano la ayuda de cualquiera de ustedes amigos gracias

    #2
    Hola,

    Es necessario hechar um vistazo para que sepas si todo esta bien:

    - ps -ef |grep zabbix_server
    - ps -ef |grep zabbix_agentd

    Y acceder lah GUI para poner el HOST a monitorear (Configuration -> Hosts).


    []s,
    Luciano
    --
    Luciano Alves
    www.unirede.net
    Twitter|Facebook|Blog|Youtube|Zabbix Performance Tuning
    Porto Alegre | São Paulo | Rio de Janeiro | USA

    Comment


      #3
      Hola, yo tambien tengo un problema parecido, mi zabbix-server no arranca, tras ver el estatus de mi servidor obtengo el siguiente mensage:

      cat: /var/run/zabbix-server/zabbix_server.pid: no such file or directory

      Despues de checar algunas posibles soluciones
      ya cheque que la ruta existiera y que tuviera los permisos necesarios para que funcionara y aun asi el problema persiste.

      tambien vi el log de zabbix y me encontre con lo siguiente:

      ...
      /usr/sbin/zabbix_server [5742]: ERROR: Configuration buffer is too small. Please increase CacheSize parameter.
      5736:20120502:102229.577 One child process died (PID:5742). Exiting ...
      5736:20120502:102231.579 Syncing history data...
      5736:20120502:102231.579 Syncing trends data...
      5736:20120502:102231.579 Syncing trends data...done.
      5736:20120502:102231.579 Zabbix Server stopped. Zabbix 1.8.2 (revision 11211).

      Referente a este error, encontre que debo de aumentar el parametro CacheSize dentro del archivo /etc/zabbix/zabbix_server.conf, Pero este parametro NO se encuentra en mi archivo. ¿Tengo que incluirlo yo en el archivo para que arranque mi servidor propiamente? o existe alguna otra solucion ???

      De antemano muchas gracias y cualquier ayuda es bienvenida.

      Comment


        #4
        Si es para tu tesis por que no te bajas la maquina virtual?, la que dice virtual appliance en la parte de downloads.


        saludos.

        Comment


          #5
          Yo resolvi mi problema , el cual era que las claves del frontend no eran las mismas configuradas en zabbix_server.conf ....a tu problema te puedo decir que el cache se configura en la parte de php que ya debiste haber configurado antes.. espero que sirva de algo

          saludos

          Comment


            #6
            Hola de nuevo, dentro del archivo php.ini cambie el parametro "mysql.cache_size" con valores desde 32M hasta 1G y sigo con el mismo problema

            No estoy seguro de estar cambiando el parametro correcto de no ser asi agradeceria la correccion.

            Saludos

            Comment


              #7
              ¿Después de cada cambio haces un reinicio de los servicios?
              /etc/init.d/mysqld stop
              /etc/init.d/httpd stop
              /etc/init.d/zabbix_server stop
              Y arrancas
              /etc/init.d/mysqld start
              /etc/init.d/httpd start
              /etc/init.d/zabbix_server start

              Sin eso los cambios en el php.ini no son efectivos.
              Number of hosts 1600,Number of items +90k,Number of triggers +22k, Number of users +100, New values per second +1270

              http://zabbixes.wordpress.com/

              Comment


                #8
                Hmmmm .... por lo que tenemos en el log:

                ERROR: Configuration buffer is too small. Please increase CacheSize parameter

                Necesitas arreglar el zabbix_server.conf y cambie el parametro CacheSize para que quede mas grande.


                []s,
                Luciano
                --
                Luciano Alves
                www.unirede.net
                Twitter|Facebook|Blog|Youtube|Zabbix Performance Tuning
                Porto Alegre | São Paulo | Rio de Janeiro | USA

                Comment


                  #9
                  Gracias por el tip angelhc, pero ya realice esos pasos y sigue igual.

                  exkg te comento que en mi archivo "zabbix_server.conf" no esta el parametro CacheSize, a lo que he cambiado el parametro mysql.cache_size en el archivo "php.ini" y no he conseguido arrancar el zabbix.

                  por lo que veo creo que tendre que respaldar mi informacion y reinstalar el zabbix de nuevo pero igual estoy al pendiente si alguien tiene alguna otra ayuda a mi problema,

                  Saludos y gracias.

                  Comment


                    #10
                    Hmmm ... y qual es la versiondel ZABBIX ?
                    Es que tuh error es con CacheSize y necesitas cambiar para un que sea mas grande.


                    []s,
                    Luciano
                    --
                    Luciano Alves
                    www.unirede.net
                    Twitter|Facebook|Blog|Youtube|Zabbix Performance Tuning
                    Porto Alegre | São Paulo | Rio de Janeiro | USA

                    Comment


                      #11
                      La version es 1.8.2

                      Comment


                        #12
                        zabbix server

                        tengo un problema con el servidor, ya que en el dashboard me sale que no hay conexion con el servidor, esta arrancado y funciona perfectamente, estoy usando vmware que me deja conectarme con la maquina virtual desde la maquina real, pero desde la maquina virtual no me deja conectarme a la maquina real, nose si puede ser ese el problema y la conexion esta prohibida desde las maquinas virtuales a las maquinas reales por politicas de seguridad; abro la aplicacion web de zabbix desde un navegador de la maquina real. Me gustaria tener algun tipo de ayuda. Un saludo y gracias de antemano.

                        Comment


                          #13
                          Hmmm ...

                          Reglas de Firewall ? SELinux activo ? Es posible que tenga alguna cosa mala ...


                          []s,
                          Luciano
                          --
                          Luciano Alves
                          www.unirede.net
                          Twitter|Facebook|Blog|Youtube|Zabbix Performance Tuning
                          Porto Alegre | São Paulo | Rio de Janeiro | USA

                          Comment

                          Working...
                          X