Ad Widget

Collapse

Complete HP server hardware monitoring

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    Another question. There are HP - MSA2000 with iLO on it.I need collect data from controllers and disk drives.

    Comment


      #32
      Originally posted by Dawii View Post
      Another question. There are HP - MSA2000 with iLO on it.I need collect data from controllers and disk drives.
      Sorry, you will not be able to do that with this template. You most certainly can monitor it using HP SIM but for monitoring via zabbix you should search for a SNMP based template (I think I one found one just for hp smart array).
      Good luck!

      Comment


        #33
        Hi, this work in HP server on linux os?

        can someone give me an working link for WBEM? for linux debian?

        Comment


          #34
          Originally posted by mie_mode View Post
          Hi, this work in HP server on linux os?

          can someone give me an working link for WBEM? for linux debian?


          Sorry, this only works on windows. Wbem may be available for linux, i dont know, but the script is written in vb and makes use of wmi, the windows.implementation of wbem.
          If there is a wbem providers kit for linux you're welcome to try and port the script to bash/pearl or whatever scripting language you prefer for linux

          Comment


            #35
            Originally posted by mmarkwitzz View Post
            Sorry, this only works on windows. Wbem may be available for linux, i dont know, but the script is written in vb and makes use of wmi, the windows.implementation of wbem.
            If there is a wbem providers kit for linux you're welcome to try and port the script to bash/pearl or whatever scripting language you prefer for linux

            It appears there is a WBEM providers support for linux:
            http://h71028.www7.hp.com/enterprise...0-225-121.html

            Comment


              #36
              This is really cool! I'm new at this though, and running into problems.

              Here is my config:
              Code:
              DebugLevel=0
              LogFile=C:\Zabbix_Agent\Zabbix_agentd.log
              EnableRemoteCommands=1
              Hostname=WAS-001
              ListenPort=10050
              ServerPort=10051
              StartAgents=5
              #zabbix server to send values to
              Server=172.16.1.187
              #hostname here must match the host name configured in zabbix server
              #enable active checks
              DisableActive=0
              #hp query
              UserParameter = hp.query[*],cscript "C:\ZabbixAgent\zabbix_hp_query.vbs" //Nologo $1 $2 $3 $4
              Here is what I get running the following command:
              Code:
              C:\ZabbixAgent>cscript zabbix_hp_query.vbs //nologo 1 1
              C:\ZabbixAgent\zabbix_hp_query.vbs(2, 1) (null): 0x8004100
              and trying to query from the zabbix server,
              Code:
              RSV-99-001:~ # zabbix_get -s 172.18.1.9 -k hp.query[1,1]
              ZBX_NOTSUPPORTED

              Any ideas? Thanks for your help!

              Comment


                #37
                Originally posted by garyozzy View Post
                This is really cool! I'm new at this though, and running into problems.

                Here is my config:
                Code:
                DebugLevel=0
                LogFile=C:\Zabbix_Agent\Zabbix_agentd.log
                EnableRemoteCommands=1
                Hostname=WAS-001
                ListenPort=10050
                ServerPort=10051
                StartAgents=5
                #zabbix server to send values to
                Server=172.16.1.187
                #hostname here must match the host name configured in zabbix server
                #enable active checks
                DisableActive=0
                #hp query
                UserParameter = hp.query[*],cscript "C:\ZabbixAgent\zabbix_hp_query.vbs" //Nologo $1 $2 $3 $4
                Here is what I get running the following command:
                Code:
                C:\ZabbixAgent>cscript zabbix_hp_query.vbs //nologo 1 1
                C:\ZabbixAgent\zabbix_hp_query.vbs(2, 1) (null): 0x8004100
                and trying to query from the zabbix server,
                Code:
                RSV-99-001:~ # zabbix_get -s 172.18.1.9 -k hp.query[1,1]
                ZBX_NOTSUPPORTED

                Any ideas? Thanks for your help!
                Hey there,

                The error occurs on line 2 of the script which is : Set objWMI = GetObject("winmgmts:\\.\root\hpq")

                So either you have not installed HP WMI Providers (support.hp.com and look for them in the download section for your specific server) or you have not rebooted the server since installing them.

                Comment


                  #38
                  Originally posted by mmarkwitzz View Post
                  Hey there,

                  The error occurs on line 2 of the script which is : Set objWMI = GetObject("winmgmts:\\.\root\hpq")

                  So either you have not installed HP WMI Providers (support.hp.com and look for them in the download section for your specific server) or you have not rebooted the server since installing them.
                  Thanks, that worked!

                  Comment


                    #39
                    Hi mmarkwitzz,
                    Trust you are well. This is working for me and It was already tested. But I don't have idea about the unites that data is showing. As a example for the HP Power supply sensor C Unites is "C" , for HP Physical disk 2 status using the unit "2OK5PRE6ER", HP System status 2OK3DEG4ER, etc. Can I please let me know the meaning and details of these unites. That will help to understand of the server status.

                    Thank you.
                    Best Regards,
                    Tharaka Wehalla

                    Comment


                      #40
                      Hello, working on Zabbix 4.0.6 on Ubuntu 16? I want to try to use this template, but if I change the file "zabbix_agentd.conf" on my monitored server, the zabbix service cannot be started. So I cannot use it.
                      Thank you

                      Comment

                      Announcement

                      Collapse
                      No announcement yet.
                      Working...
                      X