Ad Widget

Collapse

HP servers monitoring via iLO

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    #46
    The script is using somewhat unclean (or call it not-so-perfect) code.

    Please read the whole thread or have at least a look at post #16.

    Comment


      #47
      Oh i am sorry

      Comment


        #48
        yum will do the trick

        Originally posted by gnarsch View Post
        Hello,

        i got the same problem her. I have compilit it for 64-bit systems but got the same error:

        "/usr/sbin/ipmi-sensors: error while loading shared libraries: libfreeipmi.so.16: cannot open shared object file: No such file or directory"

        any idea?

        Thanks in advance.

        Edit: i solved the problem with "apt-get install freeipmi" on my ubuntu server. sorry for the trouble...

        Comment


          #49
          Originally posted by Vengant View Post
          Scripts does not interact with Zabbix Agent anyway.

          Check your agent configs.
          Hi,

          How do I collect the status of DISK via IPMI?

          Comment


            #50
            After import template into Zabbix i receive only 6 items - most of the Applications is empty. Why? How to fix that? Zabbix 3.
            All other "tests" - ok.
            Please help.

            Comment


              #51
              @kobe
              a HDD Status is included in the template.

              @Buaaa
              wait some time, the discovery rules are quiet "high" in time. ~6 hours i think.

              Comment


                #52
                Hi all,

                Thank you for good mannual.
                I did everything step by step and i stopped on item 8


                8. Attach template "Template IPMI Script iLO Discovery" to host,

                I was confused, because i have no idea how to create that template to attache to host.

                Please give your suggestion.

                Thanks.

                Comment


                  #53
                  Originally posted by dyuha85 View Post
                  Hi all,

                  Thank you for good mannual.
                  I did everything step by step and i stopped on item 8


                  8. Attach template "Template IPMI Script iLO Discovery" to host,

                  I was confused, because i have no idea how to create that template to attache to host.

                  Please give your suggestion.

                  Thanks.
                  Please download the ZIP file in the first post ( https://www.zabbix.com/forum/attachm...4&d=1397131920 )
                  in this file you get the ipmi-ilo.xml
                  that is the template that should be imported in the Zabbix Server and than attach your host to that template

                  Comment


                    #54
                    Thank you man I didn't notice xml file.

                    Could you please see below picture. Did i perform it correctly?

                    Thanks.
                    Last edited by dyuha85; 13-05-2016, 21:42.

                    Comment


                      #55
                      that Looks fine
                      please dont Forget to set the username + Password in the files on the zabbix Server.

                      you can check this with the following command:
                      Code:
                      [email protected]***-s-zab01:/usr/local/share/zabbix/externalscripts# ./ilo_discovery.pl 10.10.110.51 chassis fault discrete
                      {
                              "data":[
                                      {
                                              "{#CLASS}":"chassis",
                                              "{#TYPE}":"discrete",
                                              "{#KEY}":"Power fault"},
                                      {
                                              "{#CLASS}":"chassis",
                                              "{#TYPE}":"discrete",
                                              "{#KEY}":"Power control fault"},
                                      {
                                              "{#CLASS}":"chassis",
                                              "{#TYPE}":"discrete",
                                              "{#KEY}":"Drive Fault"},
                                      {
                                              "{#CLASS}":"chassis",
                                              "{#TYPE}":"discrete",
                                              "{#KEY}":"Cooling/fan fault"}]}

                      Comment


                        #56
                        My ilo_discovery.pl works fine and it gives back necessary info.
                        But i still don't get any metrics in latest data.
                        Last edited by dyuha85; 13-05-2016, 21:42.

                        Comment


                          #57
                          I followed to JasperE suggection to added 2 lines:

                          $server =~ tr/"//d;
                          $server =~ tr/'//d;

                          And it works for me.
                          Also i forgot to add username/password to ipmi_proliant.pl.
                          Now it's working fine.

                          Thanks a lot for helping.

                          Comment


                            #58
                            Originally posted by michael.weber View Post
                            @kobe
                            a HDD Status is included in the template.

                            @Buaaa
                            wait some time, the discovery rules are quiet "high" in time. ~6 hours i think.
                            Hello! I've succesfully imported this template and installed the *pl scripts. I get messages from my IPMI but only about FANs and temperature data.
                            One of my HDD on "Degraded" status, but I can't see it neither on lastest data and there are no triggers about it.

                            Comment


                              #59
                              Originally posted by michael.weber View Post
                              @kobe
                              a HDD Status is included in the template.

                              @Buaaa
                              wait some time, the discovery rules are quiet "high" in time. ~6 hours i think.

                              Hi! You say that HDD status is included, but I get only information about FANs and temperature data. Ony of HDDs on a server on "degraded" status, but I can't see it neither on lastest data and there are no triggers about it.
                              I've imported the template which attached by topic started on first post.

                              Could you tell me how can I get this type of information?

                              Comment


                                #60
                                Hi Guys!

                                Did anybody experienced a problem that the data didn't "refresh" for him ??

                                I'm using Zabbix 3.0.4 on Debian 8.

                                I did as per instructions, I got first "batch" of data but since then the data looks like they are still the same, I can't belive that fan value is static all the time, also the fan value is strange because it is in %.

                                I used the modified scripts with username and pass as a macro values.

                                BTW. To collect data I'm using zabbix proxy, so all scripts are on proxy. In proxy log I don't see any problems.

                                Comment

                                Announcement

                                Collapse
                                No announcement yet.
                                Working...
                                X