Announcement

Collapse
No announcement yet.

Upgrade Zabbix appliance? (for testing)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Upgrade Zabbix appliance? (for testing)

    Anybody have some tips or can point me in the general direction for applying updates to the appliance version of Zabbix? I'm only using the appliance version for evaluation and testing. Currently using v2rc1 but I'd like to get it running rc2. I could deploy a new appliance, but I want to keep my currently configured items/templates/hosts.

    #2
    there isn't an official procedure for that, but it is possible. things to solved :

    a) getting zabbix updated. theoretically, you could try to grab zabbix packages from a latter package... but there is no appliance for rc2
    you can either build your own packages or just remove the packages zabbix from the appliance and install from the source.

    b) patching the database
    database has changed a bit, and there are no official patches. there are unofficial patches, but only for mysql. luckily, appliance is using mysql.

    you will have to dive into https://zabbix.org/wiki/How_to/trunk_db_patches and see which method you would prefer, then figure out how to use it. database backup is _highly_ suggested.

    detailed questions on this might fit in irc quite well
    Zabbix 3.0 Network Monitoring book
    Zabbix tips and inspiration (blog)

    Comment


      #3
      Thanks Richlv. Sounds more complicated than I have time to deal with. I'll just recreate my test data when the next appliance version comes out. I can't export from my rc1 appliance, I get a server error. Thankfully I don't have too many templates at this point.

      It would be nice for people running deployments small enough to use the (production version) appliances to have an upgrade path. (maybe nobody does this?)

      Anyway, thanks for the info!

      Comment


        #4
        well, the appliance isn't fully "official" anyway

        upgrading zabbix itself is pretty similar to you having it installed yourself.
        db patching is same as for any trunk/dev build installation, but since 2.0.0rc3 all db upgrades will be officially supported - see http://blog.zabbix.com/upgrades-from...ally-supported

        and there's a 2.0.0rc3 virtual appliance available, if you'd prefer using that
        Zabbix 3.0 Network Monitoring book
        Zabbix tips and inspiration (blog)

        Comment


          #5
          If after testing we opt to implement Zabbix we'd build out a virtual system for it rather than using the appliance. Looks like patching is fairly straight forward then.

          Comment


            #6
            note that patching and upgrading is in no way different in the appliance when compared to installing on your own and creating proper packages - appliance does not make that harder in any way (although it does not make it easier currently either)
            Zabbix 3.0 Network Monitoring book
            Zabbix tips and inspiration (blog)

            Comment

            Working...
            X