Announcement

Collapse
No announcement yet.

Agent Ecryption problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Agent Ecryption problem

    Hi,

    Using Zabbix 3.0.0rc1

    I just tried to get encrypted communications going between an agent on Windows server 2012 R2 and Zabbix 3.0.0rc1 (on Centos 6.7 64bit).

    I defined in the agent config file on the windows server the following:

    TLSConnect=tls (tried both upper and lower case)
    TLSAccept=tls (tried both upper and lower case)
    TLSPSKIdentity=myprivatesharedkey

    All other TLS parameters are left commented out.

    When i start the agent it says:
    zabbix_agentd.exe [668]: ERROR: cannot start service [Zabbix Agent]: [0x0000041D] The service did not respond to the start or control request in a timely fashion.

    Looking at the zabbix_agentd.log file i noticed that TLS Support = NO, although the release notes says it has been fixed.




    Thx in advance.
    Last edited by erisan500; 04-02-2016, 01:42.
    EriSan
    Zabbix Certified Specialist

    #2
    Firstly, precompiled Windows agents come without encryption support compiled in. This is something to be fixed, but you can speed up the process by voting on ZBXNEXT-3047.
    Secondly, TLS parameters you provide do not seem to be correct. Please refer to the documentation.

    Comment


      #3
      Voted for ZBXNEXT-3047
      EriSan
      Zabbix Certified Specialist

      Comment


        #4
        Hi,

        If you are interrested, I've compiled the agent version 3.0.1 for Win64.

        Download it here : http://dl.free.fr/mEJSaErXp

        Visual C++ 2015 redistributable is required.

        OpenSSL 1.0.2.7 is used (and included).

        Regards,

        PS : I've juste seen that he was available on https://support.zabbix.com/browse/ZBXNEXT-3047 too...

        Comment

        Working...
        X