Announcement

Collapse
No announcement yet.

zabbix 1.5.2 source Not found mysqlclient library

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    zabbix 1.5.2 source Not found mysqlclient library

    hello,

    I am trying to compile zabbix 1.5.2 in FEDORA core 6, and i ve got this message.
    Code:
    # ./configure --enable-server  --with-mysql
    ...
    checking for mysql_config... /usr/lib/mysql/mysql_config
    checking for main in -lmysqlclient ... no
    configure: error: Not found mysqlclient library
    i ve have seen all the tread in this forum about this!

    i have put the path to libmysqlclient.so (--with-mysql=/usr/lib/mysql) => Not good
    i have all the mysql rpm needed
    Code:
    # rpm -qa |grep -i mysql
    mysqlclient14-4.1.14-4.2.1
    perl-DBD-MySQL-3.0007-1.fc6
    mysql-connector-odbc-3.51.12-2.2
    php-mysql-5.1.6-3.7.fc6
    mysqlclient10-3.23.58-9.2.1
    MySQL-python-1.2.1-1
    mysqlclient14-devel-4.1.14-4.2.1
    mysql-5.0.27-1.fc6
    mysql-server-5.0.27-1.fc6
    mysqlclient10-devel-3.23.58-9.2.1
    libdbi-dbd-mysql-0.8.1a-1.2.2
    and now i am trying to compile mysql (with source) ...
    keep in touch
    any help will be appreciate
    thank

    #2
    I have compile mysql 5.0 , put the good path in --with-mysql and I've got the same problem

    Need your help plz

    Comment


      #3
      Yessssss



      it works
      without the compiled mysql.
      just use the mysql in package BUT i had the mysql-devel with yum

      Code:
      # yum install mysql-devel
      if you need more information, don't hesitate

      Comment


        #4
        Originally posted by Jes View Post


        it works
        without the compiled mysql.
        just use the mysql in package BUT i had the mysql-devel with yum

        Code:
        # yum install mysql-devel
        The install of mysql-devel fixed it for me also.

        Now onto my next stumbling block

        Comment


          #5
          good I have tried it,it worked.
          My OS is centos 5.x
          YUM is a good tool

          Comment

          Working...
          X