configure: error: Not found NET-SNMP library with zabbix 1.6.4

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    configure: error: Not found NET-SNMP library with zabbix 1.6.4

    Hi,

    Here's my config :
    zabbix 1.6.4
    $ net-snmp-config --libs
    -L/usr/local/lib -lnetsnmp -lm

    I have tried anything but I still have that error :
    $ ./configure --enable-server --with-mysql --with-net-snmp --with-libcurl
    checking for net-snmp-config... /usr/local/bin/net-snmp-config
    checking for main in -lnetsnmp ... no
    configure: error: Not found NET-SNMP library

    Thanks,
    Fatiha

    #2
    search the forums


    --with-net-snmp=/path/to/net-snmp-config

    and/or have net-snmp-config in the $PATH
    and/or make sure the libraries are in the LD_LIBRARY_PATH (or its path in /etc/ld.so.conf)
    and/or make sure that you have the headerfiles in a normal location (if you have a package based OS, this should be the case since you have net-snmp-config already available)

    Comment


      #3
      Thank you xs- I will check those things.

      Fatiha.

      Comment


        #4
        Hi Fatiha,

        please install net-snmp-devel and it'll work.

        best regards,

        Fred

        Comment


          #5
          Thank you for your answer.

          I will inform you if it works.

          Comment


            #6
            Hi

            For Debian (also Ubuntu), You should install "libsnmp-dev".

            Best Regards

            Saygin

            Comment

            Announcement

            Collapse
            No announcement yet.
            Working...
            X