Ad Widget

Collapse

Launch trigger when down five minutes

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Launch trigger when down five minutes

    The default trigger alert you when a service is down (eg BASIC App {Template: net.tcp.service [ssh]. Last (0)} = 0)

    How can I indicate that launch the trigger if host takes the down (state 0) more than 5 minutes?

    Thanks .

    #2
    you have to link it with "&"

    e.g:

    {Template: net.tcp.service [ssh]. Last (0)} = 0) & {Template: net.tcp.service [ssh]. Avg (300)} = 0)

    So if the average value for the last 300sec (5min) = 0 then the trigger will be launched.
    this should work for you

    Comment


      #3
      And only with {Template: net.tcp.service [ssh]. Avg (300)} = 0) doesn't works??

      Thx

      Comment


        #4
        BASIC App {Template: net.tcp.service [ssh].min(5m)} = 0)

        Comment


          #5
          Can any one careated events based on the trigger? so that we can notify the emails?

          Comment


            #6
            Don't forget the nodata function!

            Example for an alert after 4 minutes of no data for an item :

            {Linux:system.cpu.util[,idle].nodata(4m)}=1

            Comment


              #7
              one question:

              I saw couple of things to work the eventa based on the triggers. we need to set the media option( let say email)

              1.SMTP server
              2. SMTP helo
              3. SMTP email


              Could you please suggest me, what I need to do to check my emails triggering option to work

              Comment


                #8
                Originally posted by harmonica View Post
                BASIC App {Template: net.tcp.service [ssh].min(5m)} = 0)
                I don't think that's correct for a service check, harmonica.

                That will trigger an event if the minimum value is 0 in the last 5 minutes. Assuming you're checking once a minute, then only one of the 5 checks needs to be 0 for that to trigger.

                Either using .max(5m) # 1 or .avg(5m) = 0 should work better, I think.

                Comment


                  #9
                  Hi!

                  I suggest:

                  .sum(#5)}=0

                  or

                  .sum(300)}=0

                  Comment


                    #10
                    Thanks a lot...

                    Comment


                      #11
                      Hello all,

                      I must be doing something wrong.

                      {(EXAMPLETEMPLATE):Temp.last(0)}>72 & {(EXAMPLETEMPLATE):Temp..min(5m)} = 0)

                      This is a temp monitor, needs to trigger when over 72 F and when it's been more then 5 minutes.

                      Thank you.

                      Comment

                      Working...
                      X