Announcement

Collapse
No announcement yet.

How to get the alert if server down.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    How to get the alert if server down.

    Hi All,
    I am trying to monitor and alert if any servers are going to down. I have found some articles to alert if the server is offline using ping status. But actually, if we monitoring using ping it will trigger not only server down but also the network is unreachable. If there any way to get the alert with details like if the server is going down for some reason(crash, plan, any other reason) and who have rebooted the server, Please let me know.

    Thank you.
    Best Regards,
    Tharaka



    #2
    Are you using Zabbix agents or SNMP for the servers.

    Comment


      #3
      In case monitoring over zabbix agent it is possible to peak on my OS {Linux,Solaris,Windows} templates how "SYS::host is down" trigger has been implemented (important part is set of dependencies on other triggers)
      https://github.com/kloczek/zabbix-templates
      http://uk.linkedin.com/pub/tomasz-k%...zko/6/940/430/
      https://kloczek.wordpress.com/
      zapish - Zabbix API SHell binding https://github.com/kloczek/zapish
      My zabbix templates https://github.com/kloczek/zabbix-templates

      Comment


        #4
        Hi Sby,
        I am using Zabbix Agents.

        Comment


          #5
          Hi kloczek,
          I was tried to import you said new template(OS Windows.xml) but It gives below error and failed. Can you please help me to figure out this.

          Click image for larger version

Name:	ZA.JPG
Views:	2
Size:	64.1 KB
ID:	362335
          Attached Files

          Comment


            #6
            Originally posted by Tharakaw View Post
            Hi kloczek,
            I was tried to import you said new template(OS Windows.xml) but It gives below error and failed. Can you please help me to figure out this.
            Which one version of the zabbix you are using? Probably not zabbix.3.4.x
            Begin of the xml file with this template has:
            HTML Code:
            <?xml version="1.0" encoding="UTF-8"?>
            <zabbix_export>
              <version>3.4</version>
            http://uk.linkedin.com/pub/tomasz-k%...zko/6/940/430/
            https://kloczek.wordpress.com/
            zapish - Zabbix API SHell binding https://github.com/kloczek/zapish
            My zabbix templates https://github.com/kloczek/zabbix-templates

            Comment


              #7
              Hi kloczek,
              Thank you for your reply. My Zabbix Version is below.
              zabbix_server (Zabbix) 3.4.2



              Click image for larger version

Name:	ZA.JPG
Views:	2
Size:	13.8 KB
ID:	362367

              Not sure why it's not supported.If it is not working if there any way to go through.
              Attached Files

              Comment


                #8
                Import is done over web frontend.
                Are you using matching version of the web frontend?

                PS. BTW. latest 3.4.x it is 3.4.11.
                http://uk.linkedin.com/pub/tomasz-k%...zko/6/940/430/
                https://kloczek.wordpress.com/
                zapish - Zabbix API SHell binding https://github.com/kloczek/zapish
                My zabbix templates https://github.com/kloczek/zabbix-templates

                Comment


                  #9
                  Hi kloczek,
                  I am a beginner for zabbix, Can I let me know how to verify the
                  version of the web frontend?.
                  Thank you.

                  Comment


                    #10
                    Version of the web frontend is on each zabbix web page on the bottom.
                    I've checked few my files with templates exported out of older zabbix stacks and I think that you may have issue with importing zabbix templates because some php extensions are not present in php installed on web server.
                    If you are using some rpm based Linux like RH, CentOS, OL or other can you show me result of the command "rpm -qa | grep ^php" ?
                    I think that in your case php-xml may be missing.
                    http://uk.linkedin.com/pub/tomasz-k%...zko/6/940/430/
                    https://kloczek.wordpress.com/
                    zapish - Zabbix API SHell binding https://github.com/kloczek/zapish
                    My zabbix templates https://github.com/kloczek/zabbix-templates

                    Comment


                      #11
                      Template_Net_Juniper_SNMPv2_3.4.5.xml Hi kloczek,
                      Thank you for your extended support and the reply. I have checked with your command and it is giving below result.

                      Click image for larger version

Name:	PHP.JPG
Views:	1
Size:	30.2 KB
ID:	362469

                      And also I able to upload and used below template without an issue. I am not understand why it is not given to upload the required file.

                      Comment

                      Ask questions to Zabbix Dev Team in person at the Zabbix Summit 2018!
                      Working...
                      X