Ad Widget

Collapse

Zabbix appliance 4.0 - installation issues - VMware ESXi 6.5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Zabbix appliance 4.0 - installation issues - VMware ESXi 6.5

    Hi,
    I downloaded the Zabbix Appliance 4.0 for Platform VirtualBox, VMWare (.vmdk).

    Click image for larger version

Name:	image_12048.jpg
Views:	3492
Size:	86.9 KB
ID:	366603

    I converted the VMWare .vmdk (for WMwork station) file using the VMware converter, to VMware ESXi 6.5 file.

    On the VWwre ESXi 6.5 host, I power ON the VM, I get the prompt;

    Click image for larger version

Name:	image_12049.jpg
Views:	3706
Size:	79.5 KB
ID:	366605




    The Manual says to change I/F IP ... 1.4 Using a static IP address

    By default the appliance uses DHCP to obtain the IP address. To specify a static IP address:
    • Log in as root user;
    • Open file /etc/network/interfaces in your favourite editor;
    • iface eth0 inet dhcpiface eth0 inet static
    • Add the following lines after iface eth0 inet static:
      • address <IP address of the appliance>
      • netmask <network mask>
      • gateway <your gateway address>
    • Run the commands sudo ifdown eth0 && sudo ifup eth0.


    I tried modifying the interface settings as mentioned to a static IP, and it fails...



    Can someone please provide help for this setup?

    Thanks


    Last edited by saifkhantm; 03-10-2018, 22:18.

    #2
    I know this post is very old, but I had the same exact experience even 20 months later.

    TLDR:
    -Run ifconfig -a, get your primary interface name(for me it was ens32), it will likely be different from what is in /etc/network/interfaces.
    -Edit /etc/network/interfaces and change whatever default primary interface name is(ens33) to what you found in the ifconfig results(ens32).
    -DNS: The documtation will not be helpful with configuring persistent DNS servers.
    -DHCP: Make your life easier, after fixing /etc/networking/interfaces, just use DHCP for your testing and POC. You can figure out all the static settings later if you decide to use Zabbix in production.

    First off, the appliance documentation is not accurate at all, at least not for the VMware appliance. And don't expect any type of pre-sales support to help you through this either.

    So after painstakingly trying to figure out this myself, as a Windows admin knowing very little about Linux, I discovered several things and was able to get networking up.

    First, the network adapter was not labeled "eth0" in /etc/network/interfaces, but "ens33".

    So I configured ens33 per the instructions, but still no luck. Then I found a forum post that said to change ens3# to eth0 and restart networking, but that didn't work.

    After struggling through this horrible experience, running an "ifconfig -a" showed an adapter named "ens32". After finding this, I went back to /etc/network/interfaces and changed "ens33" to "ens32", restarted networking and BAM, I was online.

    Lastly, the documentation doesn't tell you how to set persistent nameservers. It instructs you to add "nameserver #.#.#.#" in /etc/resolv.conf, but the first thing you will see in resolv.conf is an all caps warning "DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN". And it wasn't wrong, on the first reboot my DNS servers were gone and I couldn't resolve any host names.

    I finally threw my hands in the air, put the VM on a VLAN with DHCP, gave it reservation and reverted the appliance back to DHCP to make the full network config easier.

    Comment

    Announcement

    Collapse
    No announcement yet.
    Working...
    X