Ad Widget

Collapse

Error - DB type "MYSQL" is not supported by current setup.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Error - DB type "MYSQL" is not supported by current setup.

    Ubuntu 18.04.1, currently upgraded from Zabbix 3.4 to Zabbix 4.0. All was working well for several days, now when accessing the Zabbix Dashboard via the browser, receive the error message "DB type "MYSQL" is not supported by current setup.". Zabbix logs are not reporting any errors and I am receiving Zabbix alerts so it appears to just be affecting the web front end.

    #2
    I got it figured out. Turns out that Zabbix was configured to use php7.0 and the system had 7.2 installed. What I did to resolve was apt-get autoremove zabbix-server-mysql zabbix-frontend-php. Then reinstalled - apt-get install zabbix-server-mysql zabbix-frontend-php. Then had to create a couple symbolic links in /etc/apache2/mods-enabled that references php7.2 in mods-available. Ran through the web initial setup and all data and everything was back to normal!

    Comment


    • akornow
      akornow commented
      Editing a comment
      Hi mmcc1970.
      I´m getting exact same problem. Ubuntu 18.04.1, zabbix upgraded from 3.4 to 4 and probabely after some apt autoremove zabbix front end is broken to access mysql. Alarms are being received normally.
      I got error about zabbix_get when reinstalling, then was forced to remove it also. After reinstall with suggested commands apache is dead, so i reverted zabbix to same state as with error accessing mysql.
      Can you please post command history that fixed your problem?
      Best regards
      Alessandro

    #3
    After some additional trial and error i found that was not needed to remove and reinstall packages. Only creating sym links to correct actual php7.2 modules and removing older 7.0 fixed the issue:
    In my case these commands fixed the issue:
    # cd /etc/apache2/mods-enabled/
    # ln -s ../mods-available/php7.2.conf php7.2.conf
    # ln -s ../mods-available/php7.2.load php7.2.load
    # rm -rf php7.0.*
    # reboot

    Comment

    Working...
    X