Ad Widget

Collapse

Auto registration error

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Auto registration error

    I have a zabbix monitoring using a double structure (two different sites). In each site i have one zabbix server and 5 proxies. I'm using active agents and auto registration, I already created the auto registration action and have about 6.000 hosts that had been successfully registered in both sites. Now i'm adding another type of hosts, also using active agents and auto registration. There is no network error, the address respond, telnet respond, zabbix_get from proxy to the host respond. But the host only register in the 'secondary' site, the configuration files are almost equal (appart from address,etc ).

    There is no error (or even mention of anything about the registration) in the logs, the host appears on the hosts table (on the server) but not if i search in UI.
    Code:
    MariaDB [zabbix]> select * from hosts where host='XXXXHOSTNAME';
    +--------+--------------+----------------+--------+---------------+-------+-----------+-------------+------------+---------------+----------------+---------------+---------------+--------------------+----------------+--------------------+----------------+---------------+--------------------+------------------+------------------+------------------+------------------+------------+------------+-------------------+---------------+-----------------+-----------+----------------+-------+------------+-------------+-------------+------------+------------+-------------+------------------+---------+---------------+---------------+
    | hostid | proxy_hostid | host           | status | disable_until | error | available | errors_from | lastaccess | ipmi_authtype | ipmi_privilege | ipmi_username | ipmi_password | ipmi_disable_until | ipmi_available | snmp_disable_until | snmp_available | maintenanceid | maintenance_status | maintenance_type | maintenance_from | ipmi_errors_from | snmp_errors_from | ipmi_error | snmp_error | jmx_disable_until | jmx_available | jmx_errors_from | jmx_error | name           | flags | templateid | description | tls_connect | tls_accept | tls_issuer | tls_subject | tls_psk_identity | tls_psk | proxy_address | auto_compress |
    +--------+--------------+----------------+--------+---------------+-------+-----------+-------------+------------+---------------+----------------+---------------+---------------+--------------------+----------------+--------------------+----------------+---------------+--------------------+------------------+------------------+------------------+------------------+------------+------------+-------------------+---------------+-----------------+-----------+----------------+-------+------------+-------------+-------------+------------+------------+-------------+------------------+---------+---------------+---------------+
    |  16918 |        16543 | XXXXHOSTNAME    |      0 |             0 |       |         0 |           0 |          0 |            -1 |              2 |               |               |                  0 |              0 |                  0 |              0 |          NULL |                  0 |                0 |                0 |                0 |                0 |            |            |                 0 |             0 |               0 |           | XXXXHOSTNAME |     0 |       NULL |             |           1 |          1 |            |             |                  |         |               |             1 |
    +--------+--------------+----------------+--------+---------------+-------+-----------+-------------+------------+---------------+----------------+---------------+---------------+--------------------+----------------+--------------------+----------------+---------------+--------------------+------------------+------------------+------------------+------------------+------------+------------+-------------------+---------------+-----------------+-----------+----------------+-------+------------+-------------+-------------+------------+------------+-------------+------------------+---------+---------------+---------------+
    1 row in set (0.00 sec)
    Anyone have any ideas of why the host don't appear in the UI?
    The same host appears on the other zabbix server.
    Other hosts appears in this zabbix server.


    Attached Files
    Last edited by 1berto; 12-09-2019, 18:40.

    #2
    Do you have in those new hosts zabbix agents configuration
    Code:
    ServerActive=<zabbix_prx1_or_srv1>,<zabbix_prx2_or_srv2>
    entry?
    http://uk.linkedin.com/pub/tomasz-k%...zko/6/940/430/
    https://kloczek.wordpress.com/
    zapish - Zabbix API SHell binding https://github.com/kloczek/zapish
    My zabbix templates https://github.com/kloczek/zabbix-templates

    Comment


      #3
      Yes i have, the only 'abnormality' is that the agent is configured to send for 3 'servers', but i have tried keeping just the problematic server and it still don't show the host (althought it's created on the database).
      I have tried this way:

      ServerActive=SERVER_1,PROXY_2,PROXY_3
      nd this way ServerActive=PROXY_2
      In both ways the host is created in the table, but don't appear in the SERVER_2 UI

      In the first way, the host appears both in SERVER_1, and SERVER3 but not in SERVER_2

      The SERVER_1 is a direct connection (without PROXY), PROXY_2,PROXY_3 are connected to other servers (SERVER_2 and SERVER_3)

      I had tried to use another child proxy of SERVER_2, still the same

      I had tried to put IPs instead of addresses.

      The zabbix_get command works (from proxies).

      I had tried to delete the host (in SERVER_2 database ) it's recreated, but still don't appear in UI.

      Thanks for your attention


      Last edited by 1berto; 12-09-2019, 21:20.

      Comment


        #4
        I think that i resolved it.
        I'm using mysql autoreplication and the replication (one DB for zabbix_server other for web interface) and the replication is failing.
        Will keep the post for other users in the future.

        Comment

        Working...
        X