Ad Widget

Collapse

Reinstall after upgrade

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Reinstall after upgrade

    Good afternoon.

    Faced an incomprehensible problem (I did not find a similar search).
    A week ago, version 4.4.5 was successfully installed. The server worked for a week and today after apt-get upgrade zabbix was updated to version 4.4.6
    But after a reboot in the webmord, I am observing a new installation .......
    All folders and configs are in place, base acc. filled with data, but Zabbix stubbornly offers to put everything anew.
    I tried to connect it to noun. base, but swears:

    Cannot connect to the database.
    Unsupported charset or collation for tables: acknowledges, actions, alerts, application_discovery, application_prototype, applications, ....... and then all the database tables.

    Help me please.
    thanks

    #2
    According to the release notes for for Zabbix 4.4.6:

    DB character set and collation check

    A check for the correct character set and collation is now performed on the database, database tables and table fields during the initial frontend installation. If the check fails a warning message is displayed.
    A warning message is also displayed in ReportsSystem information.

    If Zabbix 4.4.5 was your first version ever and you just installed it a week ago, did you follow the installation document for creating the database?

    There have been other people posting in the forums that they are running into character set or collation issues with 4.4.6. You probably need to downgrade to version 4.4.5 until you can fix your character set and/or collation issue.

    Comment


      #3
      Thanks for the answer.
      Base Encoding - utf8mb4_unicode_ci
      Is this critical?
      If I change its encoding to utf8 in the current state of the database, will it help?
      I read the documentation, but did not find instructions for downgrading. Could you give a link?
      Thanks

      Comment


        #4
        You probably want to read up on the difference between character set and collation.

        Your database is apparently using the wrong character set AND the wrong collation. Recent versions of Zabbix have apparently become more strict about making certain the database, all tables, and all columns are using the expected settings for each.

        Just altering the database itself will not fix the issue, as existing tables and columns will have been created with the wrong settings.

        If you just started a week ago, your database is probably still quite small.

        Perhaps you want to use mysqldump to dump your database to an SQL file, then modify all of the DEFAULT CHARSET and COLLATE statements in that file to use the correct settings, and then reload the database? If you do that, or some other procedure that adjusts the character set and collation for all existing tables and columns, then you wouldn't need to worry about downgrading.

        Comment


          #5
          The situation is strange.
          It turns out that the problem is not only mine.
          Initially, the encoding of the table was yutf8, but after importing the files utf8, it changed to mb4_unicode_ci
          Because There was not much information, I decided for version 4.4.6 to create a new database with the utf8 encoding.
          BUT when importing files, it again changed to mb4_unicode_ci
          I found the solution here: https://support.zabbix.com/browse/ZB...hmentOrder=asc
          You need to convert all the tables.
          Adapt the schema of the DB:
          ALTER DATABASE `zabbix` DEFAULT CHARACTER SET utf8 COLLATE utf8_bin;
          Create command list:
          SELECT CONCAT("ALTER TABLE ", TABLE_NAME," CONVERT TO CHARACTER SET utf8 COLLATE utf8_bin;") AS ExecuteTheString
          FROM information_schema.`COLUMNS`
          WHERE table_schema = "zabbix" AND COLLATION_NAME = "utf8_general_ci";
          Then execute all individual commands in the way like:
          ALTER TABLE auditlog CONVERT TO CHARACTER SET utf8 COLLATE utf8_bin;
          Now everything is working well, but it is not known whether this will be fixed in new versions.

          Comment


            #6
            And again the same problem.
            After the automatic upgrade from 4.4.6 to 4.4.7, the initial installation screen Zabbix.
            The configuration files have not been changed.
            There are old versions of files zabbix.conf

            How is this problem solved?
            What needs to be done before or after the update so that the server works in normal mode?

            Comment

            Announcement

            Collapse
            No announcement yet.
            Working...
            X