Ad Widget

Collapse

Windows Service Discovery not adding new services.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Windows Service Discovery not adding new services.

    Hi,

    I have a Windows Service discovery that I created and after the first discovery, if some new service is installed do the SO, that service is not added in the item/trigger prototype.

    I have tested the key service.discovery on the client host and the new service is listed as an output.

    Discovery: Windows service discovery
    Type: Zabbix agent
    Key: service.discovery

    Filters:
    {#SERVICE.NAME} matchs @Windows service names for discovery
    {#SERVICE.STARTUPNAME} matchs @Windows service startup states for discovery


    Items Prototypes
    Name: State of service "{#SERVICE.DISPLAYNAME}"
    Key:
    service.info[{#SERVICE.NAME},state]

    Trigger Protoypes
    Name: Windows Service "{#SERVICE.DISPLAYNAME}" is not running (startup type {#SERVICE.STARTUPNAME})
    Expression: {FSBRSPS128013:service.info[{#SERVICE.NAME},state].min(#3)}<>0

    Anything more I should do?

    #2
    Without seeing how you have you global macro "@Windows". It's hard to tell whats going on here.

    You can troubleshoot this though,

    Head over the regextester.com - paste in your service.discovery output and test your global regex macro against this.

    Make sure that you're actually getting matches with the string you're supplying.

    Comment

    Announcement

    Collapse
    No announcement yet.
    Working...
    X