No announcement yet.

SNMP Switches - Trigger "Link down" Disable All at once

  • Filter
  • Time
  • Show
Clear All
new posts

    SNMP Switches - Trigger "Link down" Disable All at once


    I am running Zabbix 3.4.3 on Centos 7.3

    I been monitoring Switches (about 30 of them) by SNMP for a few weeks now, and i would like to disable a trigger on them all at once without having to do it individually.

    The trigger is "Link down", it does not give any information i need and its making zabbix send me over 200 messages a day.
    This triggers comes in template "Template Net Network Generic Device SNMPv2", wich has 2 "Discovery rules" and inside "Network Interfaces Discovery" --> "Trigger prototypes" there is the enabled trigger "Template Module Interfaces Simple SNMPv2: Interface {#IFDESCR}: Link down".
    I tried to disable this trigger prototype, restarted zabbix, but it seems to not be working.

    I wish you guys could help me find how to disable all "Link down" triggers in 30 Switches monitored by SNMP at once.
    I tried to do it 1 by 1 and its very time consuming and not doable at all...

    Let me know if you need any adiccional information in order to help me, would really appreciate it.

    I'll leave 2 attach links:

    Thanks in Advance,
    Pedro Marques

    Hi Predro,

    I'm a greenhorn, I've startet with Zabbix a few days ago. But I have the same problem. I've got hundret of Link UP/DOWN notifications.

    Did you already found a solution?

    When I'm looking to my host, there are hundrets of items. For each port there is an item. But I think it's not the best way to edit each item itself. I would prefer to edit the template and e.g. change the severity for link down.
    Any idea?



      Disable trigger in Template?

      When you indicated you disabled the trigger. I assume you did this in the template.

      I don't have the exact same scenario but in the Windows service discovery template I was able to disable a discovery trigger and it stopped pestering me until I had a chance to investigate.

      I then modify the trigger template and reactivate it and it propagate to the hosts using that template and I receive more accurate alerting.

      Soooo. not sure what your issue is.


        Hi Pedro,

        You are disabling just trigger prototype for next triggers created, it will not affect already existing triggers. The field is called "Create Enabled", which means triggers for new host items will be created in enabled or disabled state.

        What you need is mass trigger update, but this is not implemented yet

        You can just DELETE trigger prototype from template and Zabbix will remove that trigger from all hosts, then create more appropriate trigger prototype.




          I was able to solve my problem doing it host by host.
          What i did was going Configuration --> Hosts
          Then you open each host "Triggers" individually.

          I used the following Filter:
          Severity: Warning
          State: all
          Status: Enabled

          Then apply.

          As i only wanted to monitor 2 or 3 interfaces out of 48 (i was configuring switches) i found a quick way to do it.

          Start by selecting all items and only keep the "link down" of the ports you want using "CTRL + F).

          Fortunatly i was able do finish each host in about 5 minutes with the stratagy im presenting.

          It's a bit time consuming but at least i filtered the interfaces that i really want to receive notifications.

          Hope i helped you guys,
          Pedro Marques