Ad Widget

Collapse

MySQL Process is very high with Zabbix Server

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    MySQL Process is very high with Zabbix Server

    I'm running zabbix, monitoring only 4 hosts. When I start zabbix_server mysql process is very hight. When I stop zabbix_server my CPU is used 1%.
    Can I do any configuration in MySQL for it don't happen?

    #2
    Hmm, for 4 hosts this is rather weird.
    When you start the zabbix server, it queries the database for several things before actually starting. But this gets noticeable around 100+ hosts, not 4.

    When you start zabbix_server, login to mysql and execute the following query:
    > show processlist;
    This will give you all currently running queries, and thus show you what zabbix is doing.

    Comment


      #3
      I do show processlist.

      mysql> show processlist;
      +------+--------+-----------+--------+---------+------+-------+------------------+
      | Id | User | Host | db | Command | Time | State | Info |
      +------+--------+-----------+--------+---------+------+-------+------------------+
      | 7455 | zabbix | localhost | zabbix | Sleep | 573 | | NULL |
      | 7456 | zabbix | localhost | zabbix | Sleep | 511 | | NULL |
      | 7459 | zabbix | localhost | zabbix | Sleep | 642 | | NULL |
      | 7465 | zabbix | localhost | zabbix | Sleep | 512 | | NULL |
      | 7469 | zabbix | localhost | zabbix | Sleep | 573 | | NULL |
      | 7482 | zabbix | localhost | zabbix | Sleep | 542 | | NULL |
      | 7494 | zabbix | localhost | zabbix | Sleep | 542 | | NULL |
      | 7499 | zabbix | localhost | zabbix | Sleep | 612 | | NULL |
      | 7708 | zabbix | localhost | zabbix | Sleep | 642 | | NULL |
      | 7718 | zabbix | localhost | zabbix | Sleep | 612 | | NULL |
      | 7973 | zabbix | localhost | zabbix | Sleep | 1 | | NULL |
      | 7974 | zabbix | localhost | zabbix | Sleep | 1 | | NULL |
      | 7975 | zabbix | localhost | zabbix | Sleep | 53 | | NULL |
      | 7976 | zabbix | localhost | zabbix | Sleep | 1 | | NULL |
      | 7977 | zabbix | localhost | zabbix | Sleep | 1 | | NULL |
      | 7978 | zabbix | localhost | zabbix | Sleep | 1 | | NULL |
      | 7979 | zabbix | localhost | zabbix | Sleep | 60 | | NULL |
      | 7980 | zabbix | localhost | zabbix | Sleep | 43 | | NULL |
      | 7981 | zabbix | localhost | zabbix | Sleep | 17 | | NULL |
      | 7982 | zabbix | localhost | zabbix | Sleep | 7 | | NULL |
      | 7987 | zabbix | localhost | zabbix | Sleep | 1 | | NULL |
      | 7989 | zabbix | localhost | zabbix | Sleep | 4 | | NULL |
      | 7990 | zabbix | localhost | zabbix | Sleep | 4 | | NULL |
      | 7991 | zabbix | localhost | zabbix | Sleep | 4 | | NULL |
      | 7992 | zabbix | localhost | zabbix | Sleep | 4 | | NULL |
      | 7993 | zabbix | localhost | zabbix | Sleep | 4 | | NULL |
      | 7994 | zabbix | localhost | zabbix | Sleep | 4 | | NULL |
      | 7997 | zabbix | localhost | zabbix | Sleep | 29 | | NULL |
      | 8104 | root | localhost | NULL | Query | 0 | NULL | show processlist |
      +------+--------+-----------+--------+---------+------+-------+------------------+

      Can I do any configuration in zabbix_server.conf for zabbix_server running with less process? Or exist any configuration in my.conf?

      thanks.

      Comment


        #4
        I think that my problem is in my Raid Disk.
        In my server, I install new HD, then red led is crazy, because it use same flat cable.
        thanks.

        Comment

        Announcement

        Collapse
        No announcement yet.
        Working...
        X