Ad Widget

Collapse

Bugs after 1.6->1.8 upgrade

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Bugs after 1.6->1.8 upgrade

    Docs/Update:

    Upgraded according to docs (they are erroneous - there are no 1.6->1.8 like subdirs in updates directory, only confusing 1.6 and 1.8. I used 1.8 to perform mysql update.

    Still NO INFO on Zabbix-PHP root directory and PHP/Apache configs, it MUST be added to the docs. Make clear file ownerships.

    After DB rebuild, installed PHP-mbstring package.

    Zabbix config says everything is OK now.


    Trying to run:

    1. Maps. It is now completely impossible to edit maps. Newly created map shows a grid, Element +- and Link +- do not work. Existing map: no map is drawn, unable to do anything.


    2. Log file has multiple error strings:
    Query failed: [1054] Unknown column 'i.nextcheck' in 'where clause' [select h.hostid,min(i.itemid) from hosts h,items i where mod(h.hostid,1)=0 and i.nextcheck<=1260279281 and i.status in (0) and i.type in (0,1,4,6,12) and h.status=0 and h.disable_until<=1260279276 and h.errors_from!=0 and h.hostid=i.hostid and (h.proxy_hostid=0 or i.type in (5)) and i.key_ not in ('status','icmpping','icmppingsec','zabbix[log]') and h.hostid between 000000000000000 and 099999999999999 group by h.hostid]

    Query failed: [1054] Unknown column 'ip' in 'field list' [insert into dhosts (dhostid,druleid,ip) values (58,5,'147.134.192.157')]

    Seems to me mysql schema patch has been unsuccessful. Dunno, how to fix it.

    3. GUI bugs:
    Every screen containing multiple lines have a bug with "Displaying xx to xx of xx found". Every xx field is INVISIBLE until selected-reverted.

    Checking box left of Name in Export/Import does not check all boxes now. Very annoying, if need to export many items.

    4. GUI bugs:
    Configuration of Templates is a bit confusing. Need to double select Templates in Configuration Hosts screen.

    5. GUI bugs. Web page is not automaticaly refreshen after changing selection type often. VERY BAD.

    6. Templates, generated by user are lost. Host definitions, based on them, still list their names, but templates are not accessible anymore. Definite bug.


    Will now try to save all host definitions/templates and rebuild all maps after zeroing mysql database.

    Seems to me, 1.8 is VERY BETA yet.
    Last edited by bigmac; 08-12-2009, 16:18. Reason: added more info

    #2
    I was completely wrong. Didn't check installation path. Used OLD server binary.
    Problems mostly solved. Stupid i am.

    Comment


      #3
      http://www.zabbix.com/documentation/...on_and_upgrade

      Instructions seem clear to me

      Had no issues upgrading from 1.6.6 to 1.8. I do not have the issues you report.

      I hope you didn't blindly upgrade your production environment 1 day after a new major release because that would be plain silly. The documentation recommends to do the upgrade on a test environment first.

      Edit: oh good you fixed it already

      Comment


        #4
        Originally posted by krimson View Post
        http://www.zabbix.com/documentation/...on_and_upgrade

        Instructions seem clear to me

        Had no issues upgrading from 1.6.6 to 1.8. I do not have the issues you report.

        I hope you didn't blindly upgrade your production environment 1 day after a new major release because that would be plain silly. The documentation recommends to do the upgrade on a test environment first.

        Edit: oh good you fixed it already
        Happy me, i did it on test. Workhorse is still running 1.4.

        New map editor is wonderfull, and i'm impressed with grouping of triggers/alarms/hosts.

        Still do not understand, how to re-design the dashboard screen. or do i need it at all?
        Since "first screen" is configurable, it may be better to design "screen" with functions operators need and forward them there at login.

        Zabbix team, thank you for your work!

        Comment


          #5
          Originally posted by krimson View Post
          http://www.zabbix.com/documentation/...on_and_upgrade

          Instructions seem clear to me

          Had no issues upgrading from 1.6.6 to 1.8. I do not have the issues you report.

          I hope you didn't blindly upgrade your production environment 1 day after a new major release because that would be plain silly. The documentation recommends to do the upgrade on a test environment first.

          Edit: oh good you fixed it already

          Strange enough, there are TWO upgrade sections in 1.8 manual.

          This one http://www.zabbix.com/documentation/...tion/upgrading
          is not consistent with actual 1.8 distribution.

          It says: Go to the upgrades/dbpatches directory. In this directory are subdirectories named according to a version upgrade (e.g. 1.0beta3_to_1.0beta4). E

          However, actual distro contains 1.6 and 1.8 subdirs.

          It is rather confusing. Better to have only one upgrade section in the manual.

          Comment


            #6
            Graphs

            I,

            My testing lab:
            Ubuntu desktop 8.04

            Upgraded from version 1.6 to 1.8.
            When I try to copy a graph from one host to another, i receive this message:

            Warning: Invalid argument supplied for foreach() in /home/zabbix/public_html/graphs.php on line 309.

            Regards,
            José

            Comment


              #7
              Originally posted by jose_lourdes View Post
              I,

              My testing lab:
              Ubuntu desktop 8.04

              Upgraded from version 1.6 to 1.8.
              When I try to copy a graph from one host to another, i receive this message:

              Warning: Invalid argument supplied for foreach() in /home/zabbix/public_html/graphs.php on line 309.

              Regards,
              José
              thanks for finding this, registered at https://support.zabbix.com/browse/ZBX-1467
              please report further problems at the tracker, thanks (but make sure to search for already reported ones )
              Zabbix 3.0 Network Monitoring book
              Zabbix tips and inspiration (blog)

              Comment


                #8
                template import/clone problem

                I could not make working

                1. Full clone of template (tried with all hosts intact and removed - no difference). Console shows strange things.

                2. Template import. Apache log says:
                [error] [client XX.XX.XX.XX] PHP Warning: Invalid argument supplied for foreach() in /usr/share/zabbix/api/classes/class.capplication.php on line 508, referer: http://YY.YY.YY.YY/zabbix/import.php...2dd80b8a75b8f7

                [error] [client XX.XX.XX.XX] PHP Fatal error: Call to undefined method CTemplate::add() in /usr/share/zabbix/include/export.inc.php on line 585, referer: http://172.16.0.134/zabbix/import.ph...2dd80b8a75b8f7


                So, I am unable to add new template.


                CORRECTION:

                look at http://www.zabbix.com/forum/showpost...95&postcount=3

                Template import now works.
                Last edited by bigmac; 09-12-2009, 15:30.

                Comment


                  #9
                  please report the first one on the tracker, thanks
                  Zabbix 3.0 Network Monitoring book
                  Zabbix tips and inspiration (blog)

                  Comment


                    #10
                    Edit : sorry error, please delete this post
                    Last edited by sheen; 10-12-2009, 16:44.

                    Comment


                      #11
                      One bug and one &quot;feature&quot;

                      Zabbix 1.8

                      1. It is impossible to add host group in Confugure-Maps. When changing new element properties, after selecting "host-group" as a type and selecting existing group from pop-up menu, error window appears saying "ERROR: Zabbix has received an incorrect request".

                      2. When selecting Templates from Configure-Hosts "Create" menu, new page does contain Templates as a new object type, but is Group is set for Hosts group. It is inconvinient.

                      Comment


                        #12
                        1. https://support.zabbix.com/browse/ZBX-1465

                        2. agreed, it would be best to remember selected group separately for hosts and templates (at least in most cases). please, report on the tracker
                        Zabbix 3.0 Network Monitoring book
                        Zabbix tips and inspiration (blog)

                        Comment


                          #13
                          https://support.zabbix.com/browse/ZBX-1506

                          Comment

                          Announcement

                          Collapse
                          No announcement yet.
                          Working...
                          X