Announcement

Collapse
No announcement yet.

Zabbix_server does not start

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Zabbix_server does not start

    Hello,

    I search help,

    I installed a new zabbix server, but it not starting.

    #/etc/init.d/zabbix_server start
    #Starting zabbix_server: Usage: /usr/local/sbin/zabbix_server {start|stop|restart|condrestart}

    And the service not running.
    Have you a solution for this problem ?

    In "/usr/local/sbin/", I copied the "zabbix_server" file from file .tar.gz (/zabbix-1.8.11/misc/init.d/redhat/8.0/zabbix_server)
    The acces are in "chmod 755"

    Thank you for your help,

    Malik.

    #2
    What do you see in zabbix_server.log file?

    Comment


      #3
      I'm not 100% certain but in my build document I have:
      (within the zabbix extract folder)
      cp misc/init.d/redhat/8.0/zabbix_* /etc/init.d/

      so it's copying to /etc/init.d/ not usr/local/sbin

      then with nano i edit /etc/init.d/zabbix_server
      to include the line:
      progdir=”/usr/local/sbin/”
      Do the exactly the same with zabbix_agentd.

      Then add the services:
      chkconfig --add zabbix_server
      chkconfig --add zabbix_agentd

      Set to start at run level 3,4,5
      chkconfig --level 345 zabbix_server on
      chkconfig --level 345 zabbix_agentd on

      Then set the permission on the scripts
      chmod 755 /etc/init.d/zabbix_server
      chmod 755 /etc/init.d/zabbix_agentd

      Comment


        #4
        and how the compilation of zabbix went?

        Comment


          #5
          Hello,

          I'm sorry, I did not have acces on Zabbix since the last week.

          In the zabbix_server.log, nothing.

          For the compilation, not error.

          I retry with instructions of AxidaZabbix, but when I restart the zabbix_server, I have "#Starting zabbix_server: Usage: /usr/local/sbin/zabbix_server {start|stop|restart|condrestart}" always.

          I do restart the compilation of zabbix ?

          Comment


            #6
            Just to be clear, you're in a console windows and you type:

            Code:
            service zabbix_server start
            Then you get:
            "#Starting zabbix_server: Usage: /usr/local/sbin/zabbix_server {start|stop|restart|condrestart}"

            Comment


              #7
              yes exactly.
              I use "putty" for the connection on zabbix server

              Comment


                #8
                I retried the compilation of zabbix.
                I used your instructions for zabbix_server and now, it's OK
                Thank you for your help.
                My problem is resolved.

                Best regards,

                Malik.

                Comment

                Working...
                X