Ad Widget

Collapse

Server won't start

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Server won't start

    I'm trying to set up a Zabbix server in a test environment.

    I've followed the guide on the Zabbix site https://www.zabbix.com/download but for some reason the server itself won't fire up.

    Log file:
    https://pastebin.com/9CPswCUp

    Server config file (Yes, I even used the default password "password" in this test case)

    DBName=zabbix

    ### Option: DBSchema
    # Schema name. Used for IBM DB2 and PostgreSQL.
    #
    # Mandatory: no
    # Default:
    # DBSchema=

    ### Option: DBUser
    # Database user. Ignored for SQLite.
    #
    # Mandatory: no
    # Default:
    # DBUser=

    DBUser=zabbix

    ### Option: DBPassword
    # Database password. Ignored for SQLite.
    # Comment this line if no password is used.
    #
    # Mandatory: no
    # Default:

    DBPassword=password






    Status from the server:
    systemctl status zabbix-server
    ● zabbix-server.service - Zabbix Server
    Loaded: loaded (/usr/lib/systemd/system/zabbix-server.service; enabled; vendor preset: disabled)
    Active: deactivating (stop-sigterm) (Result: exit-code) since wo 2018-05-23 16:21:51 CEST; 18min ago
    Process: 11494 ExecStop=/bin/kill -SIGTERM $MAINPID (code=exited, status=1/FAILURE)
    Process: 11453 ExecStart=/usr/sbin/zabbix_server -c $CONFFILE (code=exited, status=0/SUCCESS)
    Main PID: 11455 (code=exited, status=0/SUCCESS)
    CGroup: /system.slice/zabbix-server.service
    └─11475 /usr/sbin/zabbix_server -c /etc/zabbix/zabbix_server.conf

    mei 23 16:21:51 localhost.localdomain kill[11494]: -a, --all herleiding van naam naar PID niet beperken tot
    mei 23 16:21:51 localhost.localdomain kill[11494]: processen met zelfde UID als huidige proces
    mei 23 16:21:51 localhost.localdomain kill[11494]: -s, --signal <signaal> te zenden signaal
    mei 23 16:21:51 localhost.localdomain kill[11494]: -q, --queue <signaal> sigqueue(2) gebruiken in plaats van kill(2)
    mei 23 16:21:51 localhost.localdomain kill[11494]: -p, --pid PID's tonen in plaats van een signaal te zenden
    mei 23 16:21:51 localhost.localdomain kill[11494]: -l, --list[=<signaal>] signaalnamen tonen, of eentje naar naam converteren
    mei 23 16:21:51 localhost.localdomain kill[11494]: -L, --table tabel van signaalnamen en -nummers tonen
    mei 23 16:21:51 localhost.localdomain kill[11494]: -h, --help deze hulptekst tonen en stoppen
    mei 23 16:21:51 localhost.localdomain kill[11494]: -V, --version programmaversie tonen en stoppen
    mei 23 16:21:51 localhost.localdomain kill[11494]: Voor meer informatie zie kill(1).




    Any ideas?




    #2
    Please carefully look at the log file.
    An error has occurred that sockets can not be created due to insufficient permissions.

    Code:
     22324:20180523:155440.976 cannot start alert manager service: Cannot bind socket to "/var/run/zabbix/zabbix_server_alerter.sock": [13] Permission denied.
     22325:20180523:155440.978 cannot start preprocessing service: Cannot bind socket to "/var/run/zabbix/zabbix_server_preprocessing.sock": [13] Permission denied.
    Check the permissions of the relevant directory.
    If you have enabled SELinux, please set policies properly.

    Comment


      #3
      So I disabled SElinux and now everything is running (that's what the logs tell me).

      I just don't get any login page or anything when I surf to the URL of the machine.


      What am I missing?

      Comment


      • Atsushi
        Atsushi commented
        Editing a comment
        Did you install the Web frontend packages?
        For packages for RHEL, zabbix-web and zabbix-web-mysql packages.

        Have you set up timezone in /etc/httpd/conf.d/zabbix.conf file and started httpd?

        If you are using Firewall, did you set permission to access web server such as HTTP?

      #4
      Hi everybody.

      I dont know why, but "maggicaly" the follow command works:

      Code:
      grep AVC /var/log/audit/audit.log* | audit2allow -M systemd-allow; semodule -i systemd-allow.pp
      The original reference came from : http://microdevsys.com/wp/zabbix-can...lready-in-use/

      Comment


        #5
        I disabled selinux, rebooted the CentOS host. This fixed the problem.

        Comment

        Working...
        X